Astronomie Logo
Diskussionsforen Lin_guider auf Raspberry | Montierung, Steuerung
Optionen
Thema bewerten
Schlimperdibix Offline
Mitglied

Registriert: 12/09/2011
Beiträge: 108
#1148425 - 28/03/2015 01:45 Lin_guider auf Raspberry


Hallo

da ich mir schon mehrere Tage bzw Wochen um die Ohren geschlagen habe und immer noch keine Lösung gefunden habe hier mein Problem:

Ich versuche mittels Lin_Guider auf einem Raspberry Pi 2 meine LXD75 zu guiden. (Eigenbau Stand-Alone-Guider)

Installation von Lin war erfolgreich und ich hab sogar ein Bild der Webcam am Monitor, wo ich die Guidingversuche sehe. (grünes Kasterl folgt Laserpointer an der Wand laugh )

Nur beim Starten bekomme ich die Fehlermeldung "Pulse drive not initialized".

Die LXD hängt mittels USB->RS232 am Pi und der Adapter wird als ttyUSB0 erkannt.

Leider habe ich keine Möglichkeit gefunden, wie ich testen kann, ob die Montierung und der Pi auch wirklich kommunizieren können.
Ich finde immer nur wie man mit einem Pi zu Windows testet frown

Wenn ich den Adapter an Windows ranhänge bekomme ich die Montierung mittels Stellarium und auch über Ascom und PHD zu laufen. mauer

Hab auch schon versucht INDI und PHD zu installieren, nur bekomme ich PHD nicht rauf... da geht irgendwas bei "make" nicht.

Da ich mich Null mit Linux auskenne kann ich immer nur Schritt für Schritt den Anleitungen folgen und wenn dann das so nicht geht komm ich nicht weiter confused

Meine Frage:
1.) Kennt sich wer mit Lin Guider aus? Denn eine Anleitung oder ein handbuch hab ich nicht gefunden.
2.) Kann das Programm überhaupt das LX200 Protokoll?
3.) Kennt jemand einen weg die Verbindung zu Testen
4.) Was muss ich mein Lin Guider einstellen? LPT und "/dev/ttyUSB0" nehme ich mal an

hoffe es kann mir wer weiterhelfen, denn alle Lösungen die ich finde sind immer für EQx oder für Montierungen, die nicht über das komische LX200 Protokoll laufen.

Besten dank schon mal im Vorraus
hochachtung

CS Martin
_________________________
PS.: Wer Fehler findet, darf sie behalten ironisch
NEQ6, Star Adventurer, LXD-75 6" SN, Canon EF 200 2.8L, Tamron 70-200 2.8 G2, Canon 80D, 600D, 550D (mod)

[zum Seitenanfang]
PhilipN Offline
Junior-Mitglied

Registriert: 16/09/2011
Beiträge: 8
#1148476 - 28/03/2015 11:07 Re: Lin_guider auf Raspberry [Re: Schlimperdibix]


Hallo Martin,
Da ich mich etwas mit dem Pi, Linux usw. auskenne, würde ich erstmal Folgendes empfehlen, um die Verbindung zu testen:

1. minicom (Programm zu seriellen Kommunikation) auf dem RasPi installieren, falls noch nicht vorhanden:
sudo apt-get install minicom

2. Versuchen, mit minicom eine Verbindung zu der Montierung aufzubauen:
sudo minicom -b 9600 -o -D /dev/ttyUSB0

3. Strg + F drücken (gleichzeitig). Falls die Montierung verbunden ist und reagiert, erscheint ein A oder ein P im Minicom-Fenster.

(Mehr dazu: http://lachlanmiskin.com/blog/2012/08/03/using-minicom-to-interface-with-serial-devices-on-linux/ und http://www.weasner.com/etx/autostar/as_testing.html - lässt sich prinzipiell auf Linux und minicom übertragen )

Sollte das nicht funktionieren, wäre eine mögliche Ursache, dass der USB-Adapter aus unbekannten Gründen nicht mit dem Pi zusammenarbeitet - das kann man herausfinden, indem man RxD und TxD einfach verbindet, Minicom mit dem obigen Befehl öffnet und etwas tippt, es sollte dann wieder erscheinen. Falls nicht, kann man die Fehlersuche dorthingehend ausweiten, oder alternativ mal die GPIO's des Pis verwenden um eine Verbindung mit der Montierung herzustellen (der Pi kann selbst UART, insofern braucht man nicht unbedingt einen Adapter).
Hoffe das hilft, den Fehler einzugrenzen.

Mit freundlichen Grüßen,
Philip

[zum Seitenanfang]
Schlimperdibix Offline
Mitglied

Registriert: 12/09/2011
Beiträge: 108
#1148480 - 28/03/2015 11:32 Re: Lin_guider auf Raspberry [Re: Schlimperdibix]


Hallo Philip

danke für deine Antwort.
Deine Tipps werde ich am Abend gleich mal versuchen.

minicom hab ich schon gefunden gehabt und installiert, nur wusste ich dann nicht wie ich es Testen soll ^^
Habs auch mit "screen" versucht, aber das macht sich einfach nach 5 sec wieder zu.

Die UART Schnittstelle vom Pi arbeitet ja laut Netz mit 3,3V RS232 mit 5V. Deswegen hab ich mit den Adapter besorgt. Falls der Fehler wirklich beim Adapter liegt, werde ich mit einen Level Umsetzer besorgen müssen oder?
Sowas mein ich. Hab irgendwie die Befürchtung, dass ohne dem Ding die Mount nix "versteht" oder noch schlimmer ich mir den Pi grille. confused

Aber mal deine Tests durchführen und dann melde ich mich wieder.
mfg
Martin
_________________________
PS.: Wer Fehler findet, darf sie behalten ironisch
NEQ6, Star Adventurer, LXD-75 6" SN, Canon EF 200 2.8L, Tamron 70-200 2.8 G2, Canon 80D, 600D, 550D (mod)

[zum Seitenanfang]
Sodiac Offline
Mitglied

Registriert: 04/06/2009
Beiträge: 2183
Ort: Münsterland
#1148556 - 28/03/2015 16:49 Re: Lin_guider auf Raspberry [Re: Schlimperdibix]


Hallo Martin,

ich bin zwar kein Linux-Guru, nutze aber selbst einen Pi als "Standalone-Guider". Da ich mir selbst schon die Finger bei der Verbindung USB-RS232- Montierung gebrochen habe, nutze ich aktuell den Autoguider-Ausgang meiner Guiding-Cam. Dazu müsste aber zum einen deine Kamera einen entsprechenden Ausgang haben und du müsstest dir ein Meade Autoguider Port Modul besorgen...

Alternativ eventuell Eigenbau? http://www.themilkyway.de/index.php/projekte/usb-st-4-guiding-adapter
_________________________
Clear Skies! Markus

Meine Website: www.13parsec.de

[zum Seitenanfang]
Schlimperdibix Offline
Mitglied

Registriert: 12/09/2011
Beiträge: 108
#1148748 - 29/03/2015 18:00 Re: Lin_guider auf Raspberry [Re: Schlimperdibix]


Hi,

@ Philip

so hab jetzt alles so gemacht, wie du es beschrieben hast, leider ohne Erfolg frown
Wenn ich Pin 2&3 zusammenhänge und Strg + A -> F mache (nur Strg F geht nicht) steht kurz "Sende Break", aber dann passiert nichts.
Bin per zufall auf was anderes gestoßen: wenn ich Pin 2 und Pin 7 zusammen tue, dann bekomme ich Zufallszeichen zu sehen, die man mit dem trennen und wieder herstellen verändern kann (hab mit dem Schraubenzieher herumgewackelt).

Weiters habe ich im Netz die Anleitung gefunden, wie man dem Pi die grafische Ausgebe auf der Schnittstelle abdreht, was ich auch gemacht habe. seit dem bekomme ich bei:

pi@raspberrypi ~ $ ls -l /dev/ttyUSB0
crw-rw---T 1 root dialout 188, 0 Jan 1 1970 /dev/ttyUSB0

Davor hatte ich bei dem Befehl nur /dev/ttyUSB0 stehen ohne dem davor.

Also irgenwie funktioniert der Adapter schon, nur nicht so wie er sollte.
Hab mir jetzt einen UART -> RS232 Level Umsetzer bestellt. Hoffe mit dem geht es dann besser. Da ist der Name dann /dev/ttyAMA0 wenn ich mich nicht irre oder?

@ Markus
Danke für den Tipp, aber funktioniert das Teil aus dem Link auch mit nen Pi? Denn den Brauche ich ja um die die Webcambilder auszuwerten und die entsprechend Korrektursignale zu erzeugen.
Klar mit einer Guiding-Cam und einer Montierung die nicht auf dem Alten LX200 Protokoll arbeitet wäre es viel einfacher. Oder mit einem Laptop, den ich aber nicht mitschleppen wollte biggrin
_________________________
PS.: Wer Fehler findet, darf sie behalten ironisch
NEQ6, Star Adventurer, LXD-75 6" SN, Canon EF 200 2.8L, Tamron 70-200 2.8 G2, Canon 80D, 600D, 550D (mod)

[zum Seitenanfang]
Soffel Offline
Mitglied

Registriert: 13/05/2013
Beiträge: 429
#1148844 - 30/03/2015 08:20 Re: Lin_guider auf Raspberry [Re: Schlimperdibix]


Hallo Martin,
falls Du Geld für einen ca. 50 Euro TV-Stick übrig hast, dann könntest Du Dir auch mal das ansehen (läuft auch Linguider drauf und hat noch andere features): iAstroHub

Wobei ich mir gut vorstellen kann, dass wenn man sich mal an einem Problem festgebissen hat, man es auch lösen will und nicht einfach auf eine Alternative umsteigen will....
_________________________
Viele Grüße
Stefan

Meine Bilder auf astrobin: http://www.astrobin.com/users/xb39/

[zum Seitenanfang]
Schlimperdibix Offline
Mitglied

Registriert: 12/09/2011
Beiträge: 108
#1148939 - 30/03/2015 18:21 Re: Lin_guider auf Raspberry [Re: Schlimperdibix]


Hi Stefan,

also einfach das "Hirn" ersetzen? Wäre auch eine Möglichkeit, aber du hast recht mit der "das muss doch gehen" Annahme zwinker

Aber das Programm schaut prinzipiell interessant aus.
Hab kurz gestöbert und auch Berichte gefunden, dass das ganze auf einem Pi laufen kann.

Löst zwar nicht mein eigentliches Hardware Problem, aber die Software sieht mächtiger aus gutefrage

Außerdem dann hab ich kein Tablet und hätte mir dann "unnötigerweise" einen 7" Touch-Screen besorgt biggrin

Schön langsam gehen mir die USB Anschlüsse aus XD

Webcam, BT Tastatur-Maus, Touchscreen, RS232 Adapter, Wlan, vielleicht dann noch ein Kabel zur Canon

Aja als Ergänzung zu meinen "Tests": weil ich was im Netz gefunden habe, dass es da ab un zu Probleme gibt, hab ichs sogar ohne Tastatur-Maus versucht (mittels VNC) aber auch das hat nicht geklappt. Selbes Ergebnis wie vorher smiley46

Grüße
_________________________
PS.: Wer Fehler findet, darf sie behalten ironisch
NEQ6, Star Adventurer, LXD-75 6" SN, Canon EF 200 2.8L, Tamron 70-200 2.8 G2, Canon 80D, 600D, 550D (mod)

[zum Seitenanfang]
PhilipN Offline
Junior-Mitglied

Registriert: 16/09/2011
Beiträge: 8
#1149222 - 01/04/2015 01:39 Re: Lin_guider auf Raspberry [Re: Schlimperdibix]


Hallo Martin,

Das mit den Spannungs-Leveln sollte man natürlich beachten. Wusste nicht wie das bei der Montierung aussieht, sorry.

Bzgl. der Tests, das mit Strg+F geht nur wenn der Pi mit der Montierung verbunden ist. Bei Verbindung der Pins 2 und 3 des USB->RS232 - Adapters sollte man die Zeichen erscheinen sehen die man tippt (hallo, test, 123 usw. - bei ctrl+f erscheint nichts, das stimmt so. ctrl+a->f ist wiederrum eine Zeichenfolge die einen Befehl an Minicom darstellt, so wie Ctrl+a->x zum Beenden. Hat leider nix mit der Montierung zu tun). Insofern ist es allerdings ein gutes Zeichen, dass bei Verbinden von Pin 2 (RxD -> Empfangen) mit Pin 7 (RTS, vermutlich nicht definiert zu dem Zeitpunkt und somit "zufällig") überhaupt etwas erscheint.
Mich würde noch interessieren ob das wirklich genau so verkabelt ist wie z.B. hier ( http://www.weasner.com/etx/techtips/images/jerzewski-power.jpg ) angegeben.

Die Schnittstelle /dev/ttyAMA0 für den UART an den GPIOs ist korrekt, allerdings muss man darauf achten, das der Pi darauf nicht den Bootvorgang ausgibt oder eine Anmeldekonsole bereitstellt, was er standardmäßig tut. Ein anderes Problem was ich da des öfteren hatte, waren Anwendungen, die eine beliebige Funktion der GPIOs nutzen, aber damit auch die serielle Schnittstelle belegten.

Bin gespannt ob das was wird zwinker
Mit freundlichen Grüßen,
Philip

[zum Seitenanfang]
Detlef_L Offline
Mitglied

Registriert: 18/04/2007
Beiträge: 360
Ort: Rheinland
#1149464 - 02/04/2015 13:32 Re: Lin_guider auf Raspberry [Re: Schlimperdibix]


Hallo Martin,
ich experimentiere auch schon einige Zeit mit Raspberry1+2, Lin_Guider, iAstroHub etc. herum.
Leider läuft die USB-Schnittstelle vom Raspberry als auch von den TV-Sticks Hardware seitig über die OTG-Schnittstelle, was leider ziemlich dumm ist, aber Kosten spart smiley63
Mit einen Linux Kernel 10.x hat bei mir der Raspberry vielleicht eine Minute durchgehalten, mit Kernel 12.x kam ein neuer OTG-Treiber, damit läuft der Raspberry halbwegs stabil.
Ich bin dann auf den Banana-Pi umgestiegen, der "echtes" USB hat, das nicht über die OTG-Schnittstelle geht. Damit läuft die ganze Konfiguration die ganze Nacht absolut stabil smiley61
Windows ade ...

Grüße, Detlef

[zum Seitenanfang]
Schlimperdibix Offline
Mitglied

Registriert: 12/09/2011
Beiträge: 108
#1149618 - 03/04/2015 10:21 Re: Lin_guider auf Raspberry [Re: Schlimperdibix]


Aktueller Lagebericht smile

Gestern habe ich den Level-Umsetzter (Uart auf Serial) bekommen.
Jetzt funktioniert die Schnittstelle so, wie du es beschrieben hast Philip. Wenn ich TDX & RDX verbinde seh ich im Minicom alles was ich eintippe, und jetzt geht auch das "send Break" super
Lag definitiv am USB->RS232 bzw am PL2303 Chip, denn ich habs auch mit einen anderen Adapter versucht. Anderer Hersteller, aber selber Chip.

Soweit die gute Nachrichten.
Leider bekomme ich in Lin Guider immer noch die Meldung "Pulse drive not initialized", egal mit welcher Einstellung ich es versuche.

Ich hab schon die Vermutung, dass Lin Guider kein LX200 kann.
Man findet ja leider keine Anleitung oder so dafür frown

Deswegen werde ich mal iAstroHub testen.
Damit das System aber Sauber ist, mach ich das auf einen "neuen" wheezy

@ Detlef
Blöde Frage: Worin liegt der Unterschied zwischen den 2 Systemen?
Hab auf Wiki gefunden, das OTG für Handys und so ist, aber verstehe nicht, warum das Probleme macht?
Mit ist nur aufgefallen, dass die Webcam ab und zu aus dem Lin Guider fällt und dann selbst mit nen Programmneustart nicht mehr geht, da muss ich den Pi neu starten, dann geht sie wieder. Hab aber gedacht, dass liegt daran, dass ich ja keinen Stern "beobachte" sondern mit der Kamera in der Gegend herum gefahren bin.

Und mit der Banane geht es?

Grüße @ All
_________________________
PS.: Wer Fehler findet, darf sie behalten ironisch
NEQ6, Star Adventurer, LXD-75 6" SN, Canon EF 200 2.8L, Tamron 70-200 2.8 G2, Canon 80D, 600D, 550D (mod)

[zum Seitenanfang]
Detlef_L Offline
Mitglied

Registriert: 18/04/2007
Beiträge: 360
Ort: Rheinland
#1150286 - 06/04/2015 21:37 Re: Lin_guider auf Raspberry [Re: Schlimperdibix]


Original geschrieben von: Schlimperdibix

@ Detlef
Blöde Frage: Worin liegt der Unterschied zwischen den 2 Systemen?
Hab auf Wiki gefunden, das OTG für Handys und so ist, aber verstehe nicht, warum das Probleme macht?
Mit ist nur aufgefallen, dass die Webcam ab und zu aus dem Lin Guider fällt und dann selbst mit nen Programmneustart nicht mehr geht, da muss ich den Pi neu starten, dann geht sie wieder. Hab aber gedacht, dass liegt daran, dass ich ja keinen Stern "beobachte" sondern mit der Kamera in der Gegend herum gefahren bin.

Und mit der Banane geht es?


USB OTG: "USB On-The-Go", also USB für unterwegs, üblicherweise als Micro-USB Buchse. Der Sinn dahinter ist, einen USB Anschluss sowohl als Host als auch als Gerät betreiben zu können. Dabei wird ein großer Teil des Protokolls in Software (also im Gerätetreiber vom Betriebssystem) abgehandelt. Mal eben einen USB-Stick ans Handy anschließen - dafür ist es gedacht und funktioniert in der Regel auch. Die Treiber sind jedoch nicht für hohe Bandbreiten, komplizierte Fehlerkorrektur-Algorithmen, oder eine größere Anzahl gleichzeitig angeschlossener Geräte ausgelegt.

USB Host: Der USB-Anschluss im Rechner, meist gleich mehrere dicke, breite USB-A Buchsen. Kann nicht als Gerät irgendwo anders angeschlossen werden. Der allergrößte Teil des Protokolls wird bereits in der Hardware abgehandelt. Millionenfach bewährt ...

Jetzt haben die Pi's beides anzubieten, einen USB-OTG und mehrere USB-Host Anschlüsse. Und weil man ein paar Chips für den USB-Host einsparen kann, wenn man ihn einfach als USB-OTG behandelt, muss bei den Raspberry's der ganze USB Datenverkehr durch Linux hin und her. Und das geht dann irgendwann schief, wenn z.B. irgendwelche Zwischenpuffer verbraucht sind, Bitfehler auftreten, die korrigiert werden wollen ... wie bei Deiner Webcam. Die USB-Seriell Adapter sind auch vielversprechende Kandidaten für garantierte Treiber-Abstürze.

Bei den Banana-Pi's sind USB-OTG und USB-Host voneinander getrennt. USB-OTG nutze ich da gar nicht und die USB-Host Anschlüsse funktionieren wie sie sollen.

Grüße
Detlef

[zum Seitenanfang]
Schlimperdibix Offline
Mitglied

Registriert: 12/09/2011
Beiträge: 108
#1160577 - 02/06/2015 22:18 Re: Lin_guider auf Raspberry [Re: Schlimperdibix]


Nach langen herum versuchen und experimentieren die aktuelle Lage
bin gescheitert traurig

Lin_Guider hab ich zum laufen gebracht, er kannte aber mein Teleskop nicht
nach langen Gestöber hab ich auch die Antwort gefunden:
"No, lin_guider does not work with INDI" und alleine kann er LX200 nicht -> Sackgasse.

beim open PHD installieren bin ich jedes mal gescheitert, weil die Anleitungen so alt waren, dass mache "apt-get" nicht mehr zu finden waren

Alternativ hab ich dann das Programm KStars gefunden.
Installation hat geklappt, auch die Verbindung mit dem Teleskop (zumindest ein mal ^^) übern INDI,
nur die Guiding - Funktion gibt es erst ab der Version 2.2, Version für den Rasp 2.0 frown -> geht auch nicht

iAstroHub hab ich leider nur Anleitungen für die "TV-Sticks" gefunden, aber soweit ich das gelesen habe läuft da dann auch nur Lin_Guider.

Die Moral von der Geschicht LX200 & Guiden gehn am Raspberry nicht.
Schade nur, das ich schon einen 7" Touchscreen dafür habe pfeif

Hat jemand Vorschläge, was ich noch versuchen könnte?
Ich installier in der Zwischenzeit auf nen Atom n450 Win7 und versuch da mein Glück laugh

Gruß Martin
_________________________
PS.: Wer Fehler findet, darf sie behalten ironisch
NEQ6, Star Adventurer, LXD-75 6" SN, Canon EF 200 2.8L, Tamron 70-200 2.8 G2, Canon 80D, 600D, 550D (mod)

[zum Seitenanfang]
H_Kay Offline
Mitglied

Registriert: 13/01/2014
Beiträge: 133
Ort: Jena
#1160792 - 04/06/2015 10:20 Re: Lin_guider auf Raspberry [Re: Schlimperdibix]


Hallo Martin,

Hat dein Teleskop einen Auto-Guiding-Eingang? Also so eine Art ST-4-Schnittstelle wie bei den Skywatcher HEQ5-Montierungen bspw.

Dann könntest du den Autoguider-Port über ein I/O-Board ansteuern. So hab ich es ne Zeit lang gemacht. Habe auch mal den Code von Lin_Guider so geändert, dass er das I/O-Board nutzt. Hab nur leider keine Doku o.Ä. dazu.

Wäre das ne Lösung?

Viele Grüße,
Hardy

[zum Seitenanfang]
Schlimperdibix Offline
Mitglied

Registriert: 12/09/2011
Beiträge: 108
#1160848 - 04/06/2015 16:08 Re: Lin_guider auf Raspberry [Re: H_Kay]


Hi Hardy,

Die LXD75 bzw der Autostar 497 hat zwar einen Guiding aber keinen ST-4 sondern einen 4 Poligen Stecker. Weiters läuft es mit dem LX200 Protokoll, welches nicht wie bei den anderen auf die Impulse reagiert, sondern richtig über Seriell "Befehle" braucht
Wiki
Somit geht der "einfache" Weg leider nicht.
Leider kenne ich mich mit Linux zu wenig aus (hab mich bis vor nen halben Jahr noch nie damit beschäftigt gehabt biggrin ), dass ich Lin_Guider so umscripten könnte, dass er auf den INDI Treiber zugreift. Denn dann könnte es Funktionieren ... Glaub ich hald laugh

Grüße
Martin
_________________________
PS.: Wer Fehler findet, darf sie behalten ironisch
NEQ6, Star Adventurer, LXD-75 6" SN, Canon EF 200 2.8L, Tamron 70-200 2.8 G2, Canon 80D, 600D, 550D (mod)

[zum Seitenanfang]
H_Kay Offline
Mitglied

Registriert: 13/01/2014
Beiträge: 133
Ort: Jena
#1160854 - 04/06/2015 16:57 Re: Lin_guider auf Raspberry [Re: Schlimperdibix]


Hi Martin,

Wenn das wirklich eine serielle Schnittstelle ist, müsste der Zugriff doch relativ leicht sein.
Du brauchst dan "nur" eine virtuelle serielle Schnittstelle durch einen USB-Seriell-Adapter. Dessen Funktionalität kannst du testen, indem du mal ein paar LX200-Kommandos auf die entsprechende serielle Schnittstelle ausgibst (Google-Suche).
Wenn das geht ist der Weg zum Autoguiding nicht mehr weit.
Die Code-Änderungen für Lin_Guider dürften machbar sein, wenn sie nicht schon ohnehin schon implementiert sind... (die Ansteuerung meiner I/O-Platine habe ich ja auch selbst implementiert).

Welches Raspberry-Modell nutzt du zur Zeit?

Viele Grüße,
Hardy

[zum Seitenanfang]


Moderator:  Michael_Pagitz 
Aktuelle Fotos
Hier die Milchstraße mit 35mm
Neues von La Palma
Messier 64 - NGC 4826
Cirrus-Nebel / veil nebula
Aufnahmeplanung La Palma
Astrourlaub La Palma
Sonne am 14.6.18
Wer ist Online
21 Mitglieder (A_Haubeiss, epfeli, davidundsterne, 9 unsichtbar), 377 Gäste und 12 Suchmaschinen online.
Status: Admin, GlobalModerator, Moderator
Forum Statistik
27706 Mitglieder
68 Foren
254883 Themen
1327947 Beiträge

Besucher Rekord: 1886 @ 17/10/2009 22:24