Astronomie Logo
Diskussionsforen ASCOM Advanced LX200 Treiber | Montierung, Steuerung
Seite 1 von 2 1 2 >
Optionen
Thema bewerten
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1208842 - 05/03/2016 10:50 ASCOM Advanced LX200 Treiber *****


Hallo,

Ich benütze seit Jahren meine FS2 mit dem generic LX200 Driver.
Die FS2 hat keine Park-Funktion und keinen "Meridian Flip", und keine Info für das "Side of Pier".

Ich habe einen ASCOM Treiber geschrieben, mit diesem Treiber sind alle Funktionen nun möglich.

https://pixelstelescopes.wordpress.com/advanced-lx200/

Viel Spass beim Auprobieren.

Charles


Bearbeitet von Charles (05/03/2016 10:51)
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
MountyPython Offline
Mitglied

Registriert: 12/05/2007
Beiträge: 4113
Ort: DE, NRW, SI
#1208890 - 05/03/2016 15:44 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hi Charles,

coole Arbeit! Vielen Dank!
LG
Gerrit
_________________________
Blicke oft zu den Sternen empor – als wandelst du mit ihnen.
Solche Gedanken reinigen die Seele von dem Schmutz des Erdenlebens.

[zum Seitenanfang]
qrtem Online   cool01
Mitglied

Registriert: 23/06/2012
Beiträge: 1057
Ort: Wien
#1208926 - 05/03/2016 18:37 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hi Charles,

Vielen Dank! respekt2

LG

Martin


Bearbeitet von qrtem (05/03/2016 18:40)

[zum Seitenanfang]
SternfreundArno Offline
Mitglied

Registriert: 22/05/2012
Beiträge: 220
#1208982 - 06/03/2016 06:11 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo Charles,
bin gespannt ob und wie das funktioniert!

wäre super wenn ich mir das ewige alignment jedes mal sparen könnte in meiner sternwarte.

also funktioniert das jetzt dass ich das teleskop parke und bei der nächsten nacht von der position starte und das alignment passt?

das wär ja zu schön um wahr zu sein!
_________________________
LG
Arno

www.far-light-photography.at
Esprit80 + Moravian G2-8300m

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1209000 - 06/03/2016 09:52 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo Arno,

Ja genau das war die Motivation. Er parkt sogar immer auf der selben Seite. Im Normalbetrieb brauchst du nicht mehr der FS2 zu sagen, ob sie "East" oder "West" ist, da das Teleskop immer am der gleichen Position parkt. Die FS2 ist ein mal für alle initialisiert mit Ost oder west.

Hier sind die Anweisungen für das Setup:
Im Treiber-setup solltest du zuerst die Länge und Breite deiner Sternwarte eingeben (Latitude und Longitude, die Uhrzeit deines Rechners muss auch ok sein).
Dann wählst du im Treiber am welcher Seite von der Säule dein Teleskop ist (Also wenn du in der FS2 West eingibst, ist es in ASCOM EAST). Dann schaltest du die FS2 wie üblich an.

Dann verbindest du das Treiber. Bitte Richtige COM eingeben smile

Du synchronisierst dein Telescop auf einen bekannten Stern. und dann fährst du mit goto oder mit den Tasten zu den Position, den du möchtest als Park position. Du musst jetzt lediglich auf SetPark drücken.

Als test bewege ein wenig dein Telescop und drück auf "Park"
Es sollte dort hin Fahren.

Bitte immer das Treiber zu erste trennen und dann die FS2 Auschalten.

Charles


Bearbeitet von Charles (06/03/2016 10:48)
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
herwig Offline
Mitglied

Registriert: 23/01/2005
Beiträge: 434
Ort: Linz/austria
#1209092 - 06/03/2016 18:47 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo Charles,

Klingt sehr gut und könnte ich auch gut brauchen.
Leider behauptet mein Windows 10, dass da ein Trojaner drinnen sitzt.... gruebel
Hast du eine andere download-Option oder Version?

cs Herwig

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1209116 - 06/03/2016 20:15 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Ein neu setup ist jetzt online.

Charles


Bearbeitet von Charles (06/03/2016 20:38)
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
Jens_Lange Offline
Mitglied

Registriert: 03/05/2006
Beiträge: 259
Ort: Weißenfels, Mitteldeutschland
#1209378 - 08/03/2016 15:45 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo Charles,

Dein Treiber interessiert mich auch sehr. Leider ist der Download fehlerhaft: "FEHLER 404 Internetseite konnte nicht gefunden werden!"

Viele Grüße
Jens

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1209426 - 08/03/2016 19:52 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


@Herwig: das Setup war nicht signiert... Normaleweise sollte jetzt keine Meldung von Defender kommen.

@Jens: es ist wieder online
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
Hanibal Offline
Mitglied

Registriert: 01/09/2015
Beiträge: 136
Ort: Südostbayern
#1209488 - 09/03/2016 01:35 Re: ASCOM Advanced LX200 Treiber [Re: Charles]



Dann will ich das mal ausprobieren. Eine Limitfunktion wär ja auch nicht schlecht.
_________________________
Grüße vom Christian - Sternwarte Winzer

[zum Seitenanfang]
herwig Offline
Mitglied

Registriert: 23/01/2005
Beiträge: 434
Ort: Linz/austria
#1209496 - 09/03/2016 06:44 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


herzlichen Dank,
werde ich gleich versuchen
cs herwig

[zum Seitenanfang]
Jens_Lange Offline
Mitglied

Registriert: 03/05/2006
Beiträge: 259
Ort: Weißenfels, Mitteldeutschland
#1209527 - 09/03/2016 09:27 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo Charles,

Der Link funktioniert jetzt. Vielen Dank!
Die Vorhersagen für nächste Nacht sehen gut aus, da werde ich Deinen Treiber testen.

Viele Grüße
Jens

[zum Seitenanfang]
herwig Offline
Mitglied

Registriert: 23/01/2005
Beiträge: 434
Ort: Linz/austria
#1209530 - 09/03/2016 09:32 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo Charles,
geht jetzt zwar zum downloaden, aber funktioniert leider weder mit win7/64bit noch mit win10/64 bit

schade, trotzdem danke für deine Idee und Mühe
cs herwig

[zum Seitenanfang]
SternfreundArno Offline
Mitglied

Registriert: 22/05/2012
Beiträge: 220
#1209558 - 09/03/2016 13:26 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Gott sei Dank verwende ich XP. mal schauen was der Himmel heute Abend hergibt. dann werde Ichs auch testen!
_________________________
LG
Arno

www.far-light-photography.at
Esprit80 + Moravian G2-8300m

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1209593 - 09/03/2016 17:27 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo Herwig,

die Länge (Longitude) ist ost positiv d.h. +9 für Stuttgart smile

Könntest du sagen was nicht funktionniert?

Das download? Hast du probleme mit dem installation? oder hast du keine verbindung zu deine Montierung ?

Für diese Treiber man braucht das ASCOM platform 6.2

Ich habe nur mit Windows 10 getestet, und am verschiedene windows 10.

Ich benutze diese Treiber mit dem POTH oder generic HUB

Dh. in carte du Ciel (Skychart), als telescop POTH wählen und im POTH AdvancedLX200

Charles


Bearbeitet von Charles (09/03/2016 18:18)
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1209594 - 09/03/2016 17:39 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hier ein video:
https://www.youtube.com/watch?v=5Bacq2obpe4

Ich muss noch eine video tutorial für das setup und die configuration machen.

Charles


Bearbeitet von Charles (09/03/2016 17:40)
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
herwig Offline
Mitglied

Registriert: 23/01/2005
Beiträge: 434
Ort: Linz/austria
#1209597 - 09/03/2016 17:52 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


hallo charles,
danke für die wichtige info. habe ascom 6.2, aber als treiber direkt deinen ausgewählt und nicht poth

werde ich gleich nochmals probieren

cs herwig

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1209602 - 09/03/2016 18:17 Re: ASCOM Advanced LX200 Treiber [Re: herwig]


Also Im Maxim DL geht die direkt verbindung zur LX200.

ABER: Das Meridian Flip geht nicht weil Maxim Dl prüft ob das Goto befehl Asynchron ist (Der meridian flip kann nicht mit einem LX200 protocol asynchron sein). Scripting mit MaximDL, und ASCOM telescop, geht aber ohne probleme.

In Carte du ciel es geht nicht. Wahrscheinlich benutzt carte du ciel eine ältere ASCOM Library.

Charles
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
herwig Offline
Mitglied

Registriert: 23/01/2005
Beiträge: 434
Ort: Linz/austria
#1209751 - 10/03/2016 16:15 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo Charles,
ich lerne dazu!
Montierung und Software (Hello northern sky ) verstehen sich, auch goto klappt, aber noch nicht manuelle Steuerung. Aber ich werde noch dahinterkommen. Cartes du ciel macht Probleme, ebenso sharpcap
Danke nochmals!

cs herwig

[zum Seitenanfang]
mickthelord Offline
Mitglied

Registriert: 24/03/2003
Beiträge: 153
Ort: Germany, Bonn
#1209770 - 10/03/2016 18:14 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Super Sache! Wird bald ausprobiert!

Danke!!!!!

Mick/Bonn

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1209773 - 10/03/2016 18:29 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Carte du ciel über POTH oder generic HUB sollte gehen. Wenn nicht bitte melden. Das Video würde mit Carte du ciel + POTH + AdancedLX200 gemacht
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
mickthelord Offline
Mitglied

Registriert: 24/03/2003
Beiträge: 153
Ort: Germany, Bonn
#1209897 - 11/03/2016 11:32 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hi!
Ich habe gestern mal alles getestet.
Mir ist aufgefallen:

1. Cartes Du Ciel -> Poth -> Advanced Treiber
2. FS2 auf West eingestellt, da Teleskop auf Ost Seite
3. Advanced Treiber auf Ost
4. Parkposition gesynct
5. Goto zu einem Stern geht
6. Parken funktioniert!
7. Wenn ich aber im advanced treiber die Vorgabe für die Richtugstasten auf sagen wir 180 min. einstelle um grössere Bewegung zu testen, fährt die Montierung immer weiter (musste dann notfallmässig stoppen).

Grundsätzlich wäre es gut, es gäbe dann eine abbruch Möglichkeit. Ich konnte es nicht stoppen.

Bei direkter Verbindung zum Advanced Treiber ohne ASCOM Poth scheint das Problem nicht aufzutreten.

Gruss!

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1210090 - 12/03/2016 11:09 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hi,

Ich könnte dir eine neuversion geben zum testen wenn du möchtest.

Schike mir ein PM mit dein email.

Charles
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1211974 - 21/03/2016 21:01 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Neu version 6.2.0.1 ist freigegeben

HIER

Es sollte die gemeldete probleme Lösen.

Charles
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
peter54 Offline
Mitglied

Registriert: 20/08/2002
Beiträge: 501
#1212212 - 23/03/2016 10:58 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo Charles,

habe gestern versucht Deinen Treiber in meiner Sternwarte zum Laufen zu bringen.
Rechner ist mit WIN7 64bit betrieben.
ASCOM Plattform ist die Version 6.2

Leider hat es bei mir nicht geklappt- und.....anschließend wollte der generic LX200 Treiber auch nicht mehr.
Löschen der beiden Treiber und Neuinstallation des generic LX200 Treibers brachte erst einmal nichts.
Erst nach dem Zurücksetzen des Rechners auf einen früheren Zeitpunkt klappte die Anbindung Teleskop, Kuppelsteuerung und Rechner wieder.


Ist Dir bekannt, ob der Treiber mit WIN7 64 bit läuft?

Danke für Deinen tollen Ansatz hier eine Lösung für die FS2 Nutzer anzubieten. Ich würde mich sehr freuen, wenn es mit WIN7 64bit klappen würde!

LG
Peter


Bearbeitet von peter54 (23/03/2016 10:59)

[zum Seitenanfang]
mickthelord Offline
Mitglied

Registriert: 24/03/2003
Beiträge: 153
Ort: Germany, Bonn
#1212239 - 23/03/2016 13:41 Re: ASCOM Advanced LX200 Treiber - Funktioniert [Re: Charles]


Hi Charles,

ich konnte nun die neue Version testen (ohne Himmelsicht leider ;-(. ).
Aber es funktionierte mit meiner FS2 unter diesen Bedingungen:

FS2 bei Ost lage des Telskops auf Osten (!) eingestellt.

Cartes Du Ciel und Poth mit Treiber verbunden. Treiber auf "Side of Pier = East" eingestellt.

Häkchen bei "Meridian Flip...Ascom Compatibilität" raus.

Auf einen Stern synchronisiert.

Dann parkposition angefahren. Set Park. Dann Park.

Verbindung in Cartes Du Ciel getrennt.

FS2 abgeschaltet.

Später FS2 eingeschaltet, Verbindung wieder aufgebaut mittels CDC und Poth.

Sync auf Park durchgeführt.

Hier ist allerdings wichtig gewesen, dass CDC beendet wird und wieder gestartet wird, dann ist die Parkposition auch in der Sternkarte korrekt. Vielleicht geht es auch mit einer einfachen Unterrechung der Verbindung in CDC.


Was ich mir wünschen würde, wäre eine Möglichkeit die Steuerungstasten im Treiber im kontinuierlichen Modus nutzen zu können,
Also die vorgegebenen Slew-Geschwindigkeiten der FS2 zu nutzen.


Ist aber auch jetzt schon eine feine Sache!

Danke!!!

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1212369 - 24/03/2016 10:30 Re: ASCOM Advanced LX200 Treiber - Funktioniert [Re: mickthelord]


Original geschrieben von: mickthelord


FS2 bei Ost lage des Telskops auf Osten (!) eingestellt.

Cartes Du Ciel und Poth mit Treiber verbunden. Treiber auf "Side of Pier = East" eingestellt.



Hmmm,

Normaleweise es ist so:

FS2 bei Ost lage des Teleskops auf Westen eingestellt. Also Teleskop zeigt in der westliche Himmelseite
Cartes Du Ciel und Poth mit Treiber verbunden. Treiber auf "Side of Pier = East" eingestellt.

ODER

FS2 bei West lage des Teleskops auf Ost eingestellt. Also Teleskop zeigt in der östliche Himmelseite
Cartes Du Ciel und Poth mit Treiber verbunden. Treiber auf "Side of Pier = West" eingestellt.
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1212386 - 24/03/2016 11:25 Re: ASCOM Advanced LX200 Treiber - Funktioniert [Re: mickthelord]


Original geschrieben von: mickthelord

Was ich mir wünschen würde, wäre eine Möglichkeit die Steuerungstasten im Treiber im kontinuierlichen Modus nutzen zu können,
Also die vorgegebenen Slew-Geschwindigkeiten der FS2 zu nutzen.


Ja es wäre schön, eine richtige virtuelle Kontrollbox zu haben. Die LX200 command sind leider nicht schnell genug d.h.. man sollte mit zeitlichem Verzug rechnen.
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
mickthelord Offline
Mitglied

Registriert: 24/03/2003
Beiträge: 153
Ort: Germany, Bonn
#1212387 - 24/03/2016 11:26 Re: ASCOM Advanced LX200 Treiber - Funktioniert [Re: Charles]


Hi!
Das war bei mir das Problem. Das Teleskop liegt auf der Ost Seite der Polachse (rechts oben!?). Gegengewichte liegen links unten. Wenn ich das dann so mache wie beschrieben, dann fahren GoTo Befehle auch in die richtige Richtung. Wenn ich in der FS2 West einstelle und im Treiber Ost, fährt es in die falsche Richtung.

Das gleiche macht APT beim Goto.

LG

[zum Seitenanfang]
mickthelord Offline
Mitglied

Registriert: 24/03/2003
Beiträge: 153
Ort: Germany, Bonn
#1212390 - 24/03/2016 11:28 Re: ASCOM Advanced LX200 Treiber - Funktioniert [Re: Charles]


Bezüglich der virzuelle Kontrollbox habe ich gute Erfahrung mit den Steuertasten in Metaguide gemacht, und ich glaube auch in Iris geht es!

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1212408 - 24/03/2016 13:33 Re: ASCOM Advanced LX200 Treiber [Re: peter54]


Original geschrieben von: peter54
Hallo Charles,

habe gestern versucht Deinen Treiber in meiner Sternwarte zum Laufen zu bringen.
Rechner ist mit WIN7 64bit betrieben.
ASCOM Plattform ist die Version 6.2

Leider hat es bei mir nicht geklappt- und.....anschließend wollte der generic LX200 Treiber auch nicht mehr.
Löschen der beiden Treiber und Neuinstallation des generic LX200 Treibers brachte erst einmal nichts.
Erst nach dem Zurücksetzen des Rechners auf einen früheren Zeitpunkt klappte die Anbindung Teleskop, Kuppelsteuerung und Rechner wieder.


Ist Dir bekannt, ob der Treiber mit WIN7 64 bit läuft?

Danke für Deinen tollen Ansatz hier eine Lösung für die FS2 Nutzer anzubieten. Ich würde mich sehr freuen, wenn es mit WIN7 64bit klappen würde!

LG
Peter


Original geschrieben von: mickthelord

Was ich mir wünschen würde, wäre eine Möglichkeit die Steuerungstasten im Treiber im kontinuierlichen Modus nutzen zu können,
Also die vorgegebenen Slew-Geschwindigkeiten der FS2 zu nutzen.


Hallo Peter,

Bist du sicher dass dein prolific Treiber war nicht aktualisiert? Es passiert bei uns regel mässig. Windows macht ein update und dann wird der neuste prolific Treiber installiert und dann funktionniert der USB2Serial nicht mehr.

Eigentlich mein Treiber hat gar kein einfluss auf der generic LX200 Treiber. Also wenn hier etwas geht nicht mehr es liegt am etwas anderes am PC.

Der Poth manchmal lauft noch in hintergrund bitte prüfen in Taskmanager ob er noch lauft. Wenn du bist nicht sicher einfach neu booten. Wenn die verbindungen funktionniert nicht bitte prüfen in geräte manager ob alle serial port sind gegeben.

Bitte probiere es noch mal, und schicke mir ein paar screenshot von Taskamanager, und geräte manager, man könnte auch ein Teamviewer session organizieren.

Charles
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1212410 - 24/03/2016 14:13 Re: ASCOM Advanced LX200 Treiber - Funktioniert [Re: mickthelord]


Original geschrieben von: mickthelord
Hi!
Das war bei mir das Problem. Das Teleskop liegt auf der Ost Seite der Polachse (rechts oben!?). Gegengewichte liegen links unten. Wenn ich das dann so mache wie beschrieben, dann fahren GoTo Befehle auch in die richtige Richtung. Wenn ich in der FS2 West einstelle und im Treiber Ost, fährt es in die falsche Richtung.

Das gleiche macht APT beim Goto.

LG

_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1212830 - 26/03/2016 21:23 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Jetzt neu version 6.2.0.2 mit pulse guiding
geteste mit Maxim DL

HIER
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
MountyPython Offline
Mitglied

Registriert: 12/05/2007
Beiträge: 4113
Ort: DE, NRW, SI
#1212904 - 27/03/2016 13:00 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo Charles,

Dein Arbeit bewundere ich. Auch wenn ich keine FS2 mehr habe.
Im Prinzip hatte ich die Idee, die hinter Deiner Umsetzung steht hier mal vor ein paar Jahren skizziert. In Ermangelung einer FS2 (nutze die Pulsar, Onstep und Sitech Servo II) hab das allerdings nicht umsetzen können. Auf der anderen Seite wäre es auch an der Zeit gescheitert. Hatte ne andere Baustelle. An Deiner Arbeit wird deutlich, wieviel Potenzial in ASCOM steckt. Man kann einiges im Treiber oder in der Infrastruktur regeln. Von daher ist Dein Ansatz wirklich klasse.

Der Name Advanced LX200 Treiber nicht sehr eindeutig, wenn nur die FS2 unterstützt wird. Oder heißt es, daß ich den Treiber auch mit anderen Montierungen verwenden kann, die das Generic LX200 Interface implementieren? Wäre ja nicht schlecht. D.h. hieße ja auch, daß die Delta Code dann unterstützt würde.

Wenn ich Dein Video richtig interpretiere, dann muß man schon in der Sternwarte sein. D.h. es wird schon Interaktion Vorort notwendig sein. Ist denn dann mit dem neuen Treiber die FS2 Remote-Fähig? Das würde bestimmt einige interessieren.

(Ich habe aber jetzt nicht den ganzen Thread gelesen)

Danke schonmal für Deine Antworten und....

Die Sideres 85 macht eine gute Figur. Also noch jemand, der sie einsetzt.
Sehr toll!

CS
Gerrit


Bearbeitet von MountyPython (27/03/2016 13:06)
_________________________
Blicke oft zu den Sternen empor – als wandelst du mit ihnen.
Solche Gedanken reinigen die Seele von dem Schmutz des Erdenlebens.

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1212980 - 27/03/2016 21:15 Re: ASCOM Advanced LX200 Treiber [Re: MountyPython]


Original geschrieben von: MountyPython


Der Name Advanced LX200 Treiber nicht sehr eindeutig, wenn nur die FS2 unterstützt wird. Oder heißt es, daß ich den Treiber auch mit anderen Montierungen verwenden kann, die das Generic LX200 Interface implementieren? Wäre ja nicht schlecht. D.h. hieße ja auch, daß die Delta Code dann unterstützt würde.



Hallo diese Treiber unterstutzt alle LX200 protokole:
d.h. FS2, Dynostar, PicAstro, boxdoerfer.

Wenn es mit dem Generic LX200 tut es sollte auch mit dem AdvancedLX200 tun
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1212982 - 27/03/2016 21:20 Re: ASCOM Advanced LX200 Treiber [Re: MountyPython]


Original geschrieben von: MountyPython


Wenn ich Dein Video richtig interpretiere, dann muß man schon in der Sternwarte sein. D.h. es wird schon Interaktion Vorort notwendig sein. Ist denn dann mit dem neuen Treiber die FS2 Remote-Fähig?


Eigentlich man braucht nur noch ein remote controler für die Stromversogung der FS2. Wer kann die FS2 remote auschalten kann sie auch mit diesen Treiber remote betreiben.

Charles
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
mickthelord Offline
Mitglied

Registriert: 24/03/2003
Beiträge: 153
Ort: Germany, Bonn
#1213329 - 29/03/2016 16:20 Re: ASCOM Advanced LX200 Treiber - Funktioniert [Re: Charles]


Hi Charles!
Endlich habe ich es kapiert! Danke! Es funktioniert nun auch bei mir tadellos!

Ich benutze übrigens mit Deinem Treiber nun die Richtungstasten im APT Programm. Dort funktioniert das kontinuierliche Movement!

(Basis: dein erstes Update)

LG Mick

[zum Seitenanfang]
mickthelord Offline
Mitglied

Registriert: 24/03/2003
Beiträge: 153
Ort: Germany, Bonn
#1213331 - 29/03/2016 16:25 Re: ASCOM Advanced LX200 Treiber - Funktioniert [Re: mickthelord]


hier ein Screenshot


Anhänge
APTexample.jpg



[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1214517 - 04/04/2016 19:16 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1215417 - 09/04/2016 10:54 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo,

Version 6.2.0.4 ist online

Wichtig: fix a small bug with PHD2 "Telescop has moved"

Charles ironisch
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
peter54 Offline
Mitglied

Registriert: 20/08/2002
Beiträge: 501
#1215447 - 09/04/2016 13:12 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo Charles,

hatte ja nach meinem mißglückten Versuch alles wieder gelöscht.
Hat jetzt jemand den Treiber in Kombination mit WIN 7 64bit laufen?

Du schreibst, dass ggf. prolific Treiber nicht aktuell ist. Aber sollte dann nicht auch der generic LX200 Treiber die Probleme mit der seriellen USB-Schnittstelle haben?

Das Poth manchmal im Hintergrund weiterläuft hatte ich auc schon bemerkt und dies dann per Taskmanager bereinigt.

Wenn jemand mit WIN7 erfolg hatte würde ich gerne noch einen Versuch bei meiner FS 2 starten und dann auch in unserer Limburger Sternwarte umsetzen.

DANKE für Dein tolles Engagement !!!

CS
Peter

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1215448 - 09/04/2016 13:16 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Also ich sehe kein grunde warum es sollte mit Win64 nicht funktionnieren, wenn du Teamviewer hast können wir ein remote session organisieren.


Bearbeitet von Charles (09/04/2016 13:17)
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1215452 - 09/04/2016 13:42 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


"Du schreibst, dass ggf. prolific Treiber nicht aktuell ist. Aber sollte dann nicht auch der generic LX200 Treiber die Probleme mit der seriellen USB-Schnittstelle haben?"

Ja das ist richtig. In deiner Nachricht hast du gesagt, dass beide nicht mehr gingen. Mein Treiber hat keinen einfluss auf die generic LX200. Bei uns in Leonberg funktionniert der neueste Prolific treiber nicht. Wir müssen einen von 2011 nehemen. Man sollte sowieso lieber keinen Prolific nehmen, sondern einen FTDI super

Einige Astrokollegen haben meinen Treiber probiert, bis jetzt ohne Verbindungsprobleme.

Charles


Bearbeitet von Charles (09/04/2016 14:02)
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
astromensch Offline
Mitglied

Registriert: 24/01/2004
Beiträge: 12
Ort: Uelzen, Germany
#1223859 - 22/05/2016 15:49 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo Charles,

ich habe den Treiber an der Remote Sternwarte C95 installiert und er geht fast. Es gibt zwei Sachen, die Du evtl. noch einbauen könntest. Leider ist die beschreibung schwierig, aber ich hoffe verständlich.

1. Beim Generic Hub Treiber kann man auf die Schnitstelle noch von anderen Programmen zugreifen. So kann ich mit dem Planetariumsprogramm "Guide" mir einen Ort aussuchen und die Montierung da hin fahren lassen, obwohl der generic Hub Treiber in ASCOM verbunden ist. Das geht bei deinem Treiber leider nicht (die Schnittstelle ist blockiert). Abtrennen und wieder anbinden an ASCOM führt dann nach einigen Versuchen zur dauernden Blockade der COM7, so daß man den Rechner neu starten muß.

2. An der C95 Station steht eine Knicksäulenmontierung. Das Fernrohr hängt also wie bei einer deutschen Montierung auf einer Seite, muß aber NIE umgeschlagen werden. Die Kuppelspaltsteuerung geht mit ASCOM. Wenn ich jetzt Deinen Treiber installiert habe und deutsche Montierung gewählt habe und das Fernrohr bei der Verbindung mit Maxim auf der gleichen Seite steht, wie angegeben, geht alles gut. Auch beim Meridianübergang bei der normalen Nachführung verschiebt sich der Spalt nicht (was er sonst gemacht hat, weil Maxim "denkt", das Fernrohr wird auf die andere seite gedreht). Wenn ich dann aber ein neues Objekt ansteuern will (egal welche Seite) blockiert der Treiber und ich muß erst die Seite im Konfigurationsmenü wechseln. Die kryptische fehlermeldung der nonkonformen ASCOM Weitergabe (Kreuz im Menü) führt dazu, daß das Fernrohr auf die andere Seite über den Pol bewegt werden soll, was dort aber zum Kabelabriß führen würde. Damit gehen keine Mosaike, die über den Meridian hinaus laufen. Ich habe dann einfach mal Gabelmontierung probiert und damit geht es. Aber, wenn das Fernrohr dann auf der falschen Seite ist, dann bewegt sich der Dome mit dem Spalt bei einem neuen Ziel schon mal vorwärts (so als ob das Fernrohr auf der anderen Seite hänge) und zurück, sobald die Position erreicht wird. Dummerweise fängt Maxim aber mit der Belichtung beim Mosaikmodus dann schon an, so daß die erste Aufnahme ruiniert ist. Als Behelf mache ich eine 30s Aufnahme zu Anfang im Autosave Planer, aber störend ist das schon. Wahrscheinlich ist dieser Sonderfall eine seher spezielle Problematik im Zusammenspiel Maxim, Treiber, Domesteuerung. Wäre toll, wenn das gelöst werden könnte.

Was bei Deinem Treiber aber immer funkioniert, ist daß Maxim die Goto Kommandos an die FS2 weiterleitet. Bei den anderen Treibern (Generic Hub, LX200) verschluckt irgendwas diese Befehle, so daß Mosaike damit nicht machbar waren.

Tolle Arbeit!

Jost

[zum Seitenanfang]
peter54 Offline
Mitglied

Registriert: 20/08/2002
Beiträge: 501
#1224156 - 24/05/2016 06:52 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo Jost,

ich habe die gleichen Erfahrungen bei mir gemacht...

Frage an Jost,
kannst Du nach der Installation des Advanced LX200 Treibers jetzt in MaxIm (nach einem Rechner Neustart, oder auch mal so zwischendurch) auswählen welchen Treiber, Advanced oder Generic Hub, Du verwenden möchtest?
Das war bei mir nicht mehr möglich, es lief nur noch der Advanced Treiber.

LG
Peter

[zum Seitenanfang]
astromensch Offline
Mitglied

Registriert: 24/01/2004
Beiträge: 12
Ort: Uelzen, Germany
#1224477 - 25/05/2016 19:10 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hallo Peter,

ich kann nach neustart und auch ohne Neustart den Treiber frei wählen. Den Advanced nehme ich jetzt, wenn die Nacht durchlaufen soll, sonst den Generic

LG
Jost

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1225173 - 29/05/2016 20:09 Re: ASCOM Advanced LX200 Treiber [Re: astromensch]


Hallo Jost,

zur 1.
wenn du mehrere Programme mit dem AALX200 benutzen möchtest, dann solltest du den ASCOM-POTH oder ASCOM-HUB wählen. Es sollte dann gehen.



http://ascom-standards.org/FAQs/POTH.htm

Es ist keine gute idee das mehrere Progamme das com port offennen und schlissen.

zur 2.

Ich muss eine kleine änderung Machen, bis jetzt es sind nur 3 Stunden maximal über das Meridian erlaubt. Für dein fall sollte es 12 Stunden sein.

Danke für deinen Lobe.

Charles
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
Charles Offline
Mitglied

Registriert: 20/02/2009
Beiträge: 109
Ort: West Frankreich
#1225391 - 30/05/2016 22:16 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Es ist jetzt erledigt. cool

Version 6.2.0.6 ist online
_________________________
https://pixelstelescopes.wordpress.com/

[zum Seitenanfang]
ich Offline
Mitglied

Registriert: 20/10/2002
Beiträge: 766
Ort: Österreich/Kärnten
#1238118 - 24/08/2016 11:32 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Hi Leute,

wir wollen die FS2 meines Kollegen nun auch über den ASCOM Advanced LX200 Treiber betreiben. Die FS2 ist an einer 10Micron verbaut.

Der PC läuft mit Win 7. Was sollen/müssen wir bei der Installation und im weiteren Betrieb beachten.

Angesteuert wird die FS2 über The Sky X.

Ich bin über jede Hilfe und jeden Ratschlag dankbar.

Beste Grüße,

Wolfgang
_________________________
vergoldermeister[at]aon.at
9020 Klagenfurt
Österreich

...Gott würfelt nicht. (A. Einstein)

[zum Seitenanfang]
SternfreundArno Offline
Mitglied

Registriert: 22/05/2012
Beiträge: 220
#1238141 - 24/08/2016 13:35 Re: ASCOM Advanced LX200 Treiber [Re: Charles]


Original geschrieben von: Charles
Es ist jetzt erledigt. cool

Version 6.2.0.6 ist online



Hallo Charles,
kannst du vielleicht ein "how to" erstellen?

Mich würde eine genaue Anleitung interessieren:
Was muss alles installiert sein?
Welche Programme müssen in welcher Reihenfolge gestartet werden.
Was muss in den Programmen eingestellt werden.


Arbeite selbst mit einer G11+FS2 und würde gerne mit APT pointcraft (blindsolve) nutzen (allskyplatesolver) bzw. die Montierung in einer selbst definierten Position parken..

Bis jetzt habe ich es leider nicht geschafft…
_________________________
LG
Arno

www.far-light-photography.at
Esprit80 + Moravian G2-8300m

[zum Seitenanfang]
Seite 1 von 2 1 2 >

Dieser Thread wurde bisher wie folgt bewertet:
MountyPython (*****),
qrtem (*****),
SternfreundArno (*****),
frasax (*****)


Moderator:  Michael_Pagitz 
Aktuelle Fotos
Mond in Farbe
Ein fast voller Mond
Ein "Ent" auf der Sonne ;-)
Tête à tête von Mond und Venus
21P bei NGC 2174 und IC443
Ein schneller M31
Sonne am 24.9.2018 vormittags
Wer ist Online
3 Mitglieder (astromaxx, MichaelBonn, RoudenLeiw), 8 Gäste und 0 Suchmaschinen online.
Status: Admin, GlobalModerator, Moderator
Forum Statistik
27246 Mitglieder
55 Foren
130500 Themen
969000 Beiträge

Besucher Rekord: 2829 @ 19/09/2018 11:21