Stellarmate & Asiair Pro

BackyardImaging

Aktives Mitglied
Hallo zusammen,

ich benötige mal wieder euer Schwarmwissen. Vor einer Weile hatte ich das Stellarmate OS erstanden und das Projekt aber vorerst auf Eis gelegt. Aufgrund des anhaltend schlechten Wetters habe ich mich jetzt mal wieder damit beschäftigt. Ich habe eine alte Asiair Pro und es ist ohne Probleme möglich, das Stellarmate auf eine SD Karte zu flashen und diese dann in der ASIAIR Pro zu verwenden. Es wird ein Hotspot gestartet, ich kann mich mit der App verbinden; alles funktioniert.

Nun würde ich aber auch gerne die 12 V Outputs aktivieren. Wie das geht, wird hier beschrieben: Installing Stellarmate OS on ASI AIR
Dort heißt es, man soll in der [pi4] section und über der [all] section in der Config die im Thread beschriebenen zwei Zeilen hinzufügen:
#Enable 12v gpio output
gpio=18,12,13,26=op,dh,pu

Außerdem hat ein User dort sogar als Attachment für Noobs wie mich die gesamte Config angehängt, die man einfach per copy & paste übertragen kann.

Jetzt habe ich folgendes Problem: Meine Config sieht ziemlich anders aus als die im Attachment. Ich habe nicht mal die dort beschriebene [pi4] section. Wenn ich die Zeilen über meiner [all] section in der Config einfüge, funktionieren die 12 V Ports nicht.

Verwende ich dagegen die komplette Config aus dem Attachment, dann funktionieren zwar die 12 V Ports, aber danach kann ich mein Stellarmate/Asiair Device nicht mehr mit der App verbinden. Mit der originalen Config funktioniert die Verbindung dagegen sehr gut.

Kennt sich jemand mit dieser Config und dem Editieren aus und kann mir helfen? Ich habe meine Config mal in die Anhänge gepackt.

CS,

Ulrike
 

Anhänge

  • Config2.txt
    66,2 KB · Aufrufe: 32
Hallo Ulrike,

ich glaube du hast die falsche Datei erwischt. So beginnt deine Config2.txt.

[2023-11-27 18:34:29] PixInsight Core 1.8.9-2 Ripley (x64)
[2023-11-27 18:34:29] ************************************************************
[2023-11-27 18:34:29]
[2023-11-27 18:34:29] ************************************************************
[2023-11-27 18:34:29] WeightedBatchPreprocessing 2.6.2
[2023-11-27 18:34:29] ************************************************************
[2023-11-27 18:34:30]
[2023-11-27 18:34:30] ************************************************************
[2023-11-27 18:34:30] * Begin integration of Bias frames
[2023-11-27 18:34:30] ************************************************************
 
Danke für den Hinweis, Harald. Ich lade später noch die Config hoch.
 
Hier noch einmal die Config
 

Anhänge

  • config.txt
    1,2 KB · Aufrufe: 21
Hallo Ulrike,

die config.txt die du angehangen hast, ist die mit der du erfolgreich die Verbindung herstellen kannst!

In der anderen Config sind nur die hier unten aufgeführten Zeilen aktiv. Wenn diese Config den Betrieb der 12V Ports dir ermöglichte, dann kannst du diesen Abschnitt in deine vor dem [all] einfügen. Danach wieder die ASI neu starten. Vielleicht geht es dann.

# USB Power
max_usb_current=1

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

# I2C Bus
dtoverlay=i2c3,pins_4_5

#Enable 12v gpio output
gpio=18,12,13,26=op,dh,pu


[all]
 
Danke Harald, ich werde es mal probieren.
 
Die 12 V Outputs werden aktiviert. Allerdings ist dafür jetzt kein Hotspot mehr etabliert :unsure:
 
Hallo Ulrike,

mir war nicht aufgefallen, dass in deiner Konfiguration was hier unter [pi4] steht schon unter # Enable DRM VC4 V3D driver existiert. Daher erst einmal in den beiden roten Zeilen die # davor setzen. Damit werden die Befehle nicht ausgeführt. In deiner Config wird ein neuer Treiber aufgerufen und unter [pi4] haben wir dann einen alten Treiber für das gleiche Problem aufgerufen, das geht natürlich nicht. Ich kann es leider nicht selbst testen.

# USB Power
max_usb_current=1

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack

# dtoverlay=vc4-fkms-v3d
# max_framebuffers=2


# I2C Bus
dtoverlay=i2c3,pins_4_5

#Enable 12v gpio output
gpio=18,12,13,26=op,dh,pu
 
Hi Harald,

danke für die Unterstützung. Ich bin gerade nicht daheim und kann das nicht testen. Ich gebe dir morgen eine Rückmeldung.

Viele Grüße,
Ulrike
 
@Harald.

Hi Harald,

danke dir, jetzt scheint es zu funktionieren. Zumindest hat bei der Kamera das Lämpchen geleuchtet und ich konnte mich verbinden :)
Jetzt muss ich mal versuchen, mit der App warm zu werden. Intuitiv ist das alles nicht.

Viele Grüße,

Ulrike
 
Hallo Ulrike,

das hat ja über die Ferne gut geklappt.

Du kannst jetzt diesen Abschnitt löschen, er hat keinen Einfluss in deiner Konfiguration.

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
# dtoverlay=vc4-fkms-v3d
# max_framebuffers=2

Wo siehst du den Vorteil bei Stellarmate OS? Geht es dir um "nicht ZWO Geräte" zum Einsatz zu bringen? Du arbeitest dann mit KStars/Ekos.
 
Wo siehst du den Vorteil bei Stellarmate OS? Geht es dir um "nicht ZWO Geräte" zum Einsatz zu bringen? Du arbeitest dann mit KStars/Ekos.
Ja genau. Das war der Gedanke dahinter. Aber ob das von Vorteil ist, weiß ich nicht unbedingt. Wenn man von der Asiair kommt, packt man sich dabei doch eher an den Kopf. Man kann die Dinge halt auch unnötig kompliziert machen.

Im ersten Test wurde das Equipment erstmal nicht erkannt. Keine Kamera, Montierung usw... Möglicherweise krankt es jetzt an den USB-Ports? Oder ich muss irgendwas in der Stellarmate-App machen, was sich mir noch nicht erschließt. 3x habe ich probiert, ein Profil anzulegen. 2x hat das Speichern nicht funktioniert, aus Gründen, die mir nicht bekannt sind. Hat erst beim dritten Mal geklappt. Spaß macht das nicht wirklich.
 
Oben