Jupiter mit CMOS | Seite 2 | Astronomie.de - Der Treffpunkt für Astronomie

Jupiter mit CMOS

Status
Es sind keine weiteren Antworten möglich.

Christian_P

Aktives Mitglied
Hallo Jan, danke für die Information. Mein Laptop ist bereits 6 Jahre alt. Da könnte ich mir auch schon vorstellen, dass es da Engstellen gibt. Ich muss mal sehen für was ich mich in Zukunft entscheide.


Viele Grüße,
Christian
 

Jan_Fremerey

Aktives Mitglied
Hallo Christian und Peter,

habe eben noch ein paar ergänzende Messungen mit "HD_Speed" unternommen und dabei herausgefunden, dass die Festplatte meines älteren YAKUMO-Notebooks gar nicht mal das entscheidende Nadelöhr ist. Denn, auch wenn ich eine RAM-Disk mit einer Transfer-Rate von 1,2 GB (!) anlege, kommen dort von der ALccd5 im Bildformat 400x400 Pixel bei 28 ms Belichtungszeit (das ist offenbar das Optimum) innerhalb von 10 s nur 357 Frames (167 MB) an, auf der mechanischen HD sind es immerhin 332 Frames (156 MB).

Möglicherweise liegt die Engstelle in der Kamera selbst und/oder beim USB-Transfer. An meinem Desktop bringt die Kamera bei gleicher Konfiguration in 10 s auch nur 346 Frames (162 MB) auf die HD. Die Transfer-Rate von der ALccd5 bis zum Speichermedium liegt also hier in Verbindung mit beiden Rechnern bei rund 16 MB/s. Die Kamera selbst ist mit 24 MB/s spezifiziert, das gilt aber vermutlich nur bis zur Übergabe an die USB-Schnittstelle.

Die von mir zuvor genannten SSD-Festplatten sollen ähnliche Transfer-Raten bieten wie meine RAM-Disk, damit hätten wir dann wohl noch nicht viel gewonnen. Daher bitte nicht voreilig ein mit SSD-Platte ausgestattetes Notebook bestellen!

Gruß, Jan
 

marioweigand

Aktives Mitglied
Hallo Jan,

...kommen dort von der ALccd5 im Bildformat 400x400 Pixel bei 28 ms Belichtungszeit (das ist offenbar das Optimum) innerhalb von 10 s nur 357 Frames (167 MB) an, auf der mechanischen HD sind es immerhin 332 Frames (156 MB).

Vielleicht habe ich nur zu ungenau gelesen,
aber wie sollen denn bei 28 ms Belichtungszeit mehr als 35,7 fps auf der Platte landen?
Angenommen, die ganze Hardware bräuchte für die Übertragung 0 Zeit,
wäre doch rein rechnerisch bei maximal 35,7143 fps Schluss...
Wieso erwartest du mehr?

Gruß,

Mario
 

Zyklop

Aktives Mitglied
Jo, für 100fps bräuchte man 10ms, für 400fps 2,5ms...etc
Die Software QGVideo ist aber auch total daneben - hat mich meist ziemlich genervt.
Als Trockenübung kann man ja 1ms Belichtung in QGVideo einstellen und schauen was passiert.
 
Zuletzt von einem Moderator bearbeitet:

Zyklop

Aktives Mitglied
Ich habe eben mal selber einen Test mit meiner ALCCD5 und meinem ollen NB gemacht.
Bei 400x400 komme ich auf 250frames in 10sek und bei 160x120 komme ich auf ca. 800frames.
Belichtung war 1ms.
Die fps wird ja live angezeigt, wenn man nicht aufnimmt.
Die Transferraten über den usb2 habe ich mittels usb3-festplatte und h2testw gemessen - imho das beste tool dafür. Meine Platte kommt normal auf >110mb/s aber an dem Port auf 22mb/s schreiben und 25mb/s lesen.
Teste das mal ähnlich, wenn du kannst, Jan.
VG

 

Jan_Fremerey

Aktives Mitglied
Hallo Mario,

Dank Dir für's Mitlesen und - vor allem - für's Mitdenken! - Deine Bemerkung ist natürlich völlig zutreffend, in ähnlicher Weise hatte sich zuvor schon Markus geäußert. Das Merkwürdige ist nur, das hatte ich jetzt hier nicht nochmal dazugeschrieben, dass nämlich bei einer Verkürzung der Belichtungszeit die Bildrate nicht steigt. Dazu eine kleine Messreihe:

t[ms]_____10*fps_______MB/s

_100______99(99)_____4,6(4,6)
__50_____196(196)____9,2(9,2)

__30_____318(320)___14,9(15,0)
__28_____351(344)___16,5(16,1)
__25_____193(193)____9,0(9,0)

__20_____239(238)___11,2(11,2)
__10_____254(255)___11,9(12,0)
___5_____255(254)___12,0(12,0)
___2_____254(254)___11,9(11,9)
___1_____255(254)___12,0(11,9)

Es bedeuten t die Belichtungszeit, 10*fps die Anzahl der in 10 s auf der HD bzw. auf der RAM-Disk (Werte in Klammern) abgespeicherten Frames und MB/s die über die Aufnahmedauer von 10 s gemittelte Datenrate.

Bei t > 28 ms nimmt die Bildrate mit steigender Belichtungszeit genau aus dem von Dir/Euch genannten Grunde ab, nämlich deshalb, weil die verfügbare Zeit von jeweils 10 s allein mit den Belichtungszeiten der Frames voll ausgefüllt ist. Bei t < 28 ms nimmt allerdings die Framerate zunächst drastisch ab, um sich dann bei t < 20 ms auf einem im wesentlichen konstanten Wert einzustellen.

Nach meinem Verständnis der Dinge arbeitet die Kamera mit zwei unterschiedlichen Betriebsmodi, (1) mit lückenlos aufeinanderfolgenden Belichtungen und (2) mit zeitlich voneinander getrennten Belichtungen. Im ersten Modus werden die Frames als zusammenhängender Stream übertragen, während im zweiten Modus offenbar für jede einzelne Belichtung ein Overhead erzeugt wird, der eine gewisse Zeit in Anspruch nimmt. Bei sehr kurzen Belichtungszeiten wird die Zeit dann im wesentlichen von diesem Overhead aufgezehrt.

Wenn die neue ALccd5-II dieses Problem nicht hat, dann ist es dort offenbar gelungen, die Anfangs- und Endpunkte der einzelnen Belichtungen "fliegend" zu kennzeichnen und auf diese Weise den Zeitverlust zwischen den einzelnen Frames auf ein Minimum zu reduzieren.

Bitte betrachtet diese Darstellung lediglich als einen mir plausibel erscheinenden Deutungsversuch der beobachteten Daten.

Gruß, Jan
 
Zuletzt von einem Moderator bearbeitet:

Jan_Fremerey

Aktives Mitglied
Zitat von Zyklop:
Meine Platte kommt normal auf >110mb/s aber an dem Port auf 22mb/s schreiben und 25mb/s lesen. Teste das mal ähnlich, wenn du kannst, Jan.
Hallo Peter,

eben habe ich es mal mit dem Format 96x96 versucht, da ergibt sich ein ganz ähnliches Bild wie aus dem zentralen Teil der zuvor gezeigten Tabelle:

t[ms]_____10*fps________MB/s

___6____1422(1428)____3,8(3,9)
___5____1663(1655)____4,5(4,5)
___4____1234(1182)____3,3(3,2)

Für die HD meines Laptops habe ich mit Hilfe von "HD_Speed" eine Transferrate von 24,1 MB/s gemessen und für die USB-Schnittstelle mit angeschlossenem USB-Stick 16,6 MB/s. Die RAM-Disk (RD) hatte ich ja schon mit 1,2 GB/s angegeben. Die Tabellenwerte zur HD machen im Vergleich mit denen zur RD (in Klammern) deutlich, dass die ALccd5 mit meiner HD praktisch ebenso schnell arbeitet wie mit der RD.

Mit der laut Tabelle bis zu 39 MB/s schnellen ALccd5-II wird dann möglicherweise doch ein Laptop mit schnellerer HD fällig, wenn sich nicht dann die USB-Schnittstelle als eigentlicher Flaschenhals erweist. Die von Dir gemessenen 25 MB/s reichen dann ja auch nicht.

Gruß, Jan
 
Zuletzt von einem Moderator bearbeitet:

Zyklop

Aktives Mitglied
Hi Jan,
imho kann usb2 sowieso netto kaum mehr als 30mb/s.
Warum die neue ALccd5-II immer noch einen ollen usb2-port hat, verstehe ich nicht so ganz.

Übrigens sehr interessant deine Untersuchungen.
Versuche mal mit einer Taschenlampe bei 1ms auf den Chip zu leuchten - komischerweise änderte sich bei mir dann teilweise die framerate nach oben. Warum auch immer. Vielleicht lags auch an der Software. Also der usb-port ist 100%ig der Flaschenhals, dann kommt die CPU oder die Software, denke ich.
Aber bevor ich mich wirklich mit QGVideo rumärgere braucht es 60fps und mehr...
Übrigens hatte ich am 26.09.2011 (die gute alte Zeit) auch mal mit der ALCCD5 auf Jupiter gehalten...ich hoffe es ist ok wenn ich den mal als Beispiel poste, Jan.
Wenn ich die Originaldaten noch hätte, würde ich da vermutlich heute noch mehr rausholen können.
Link zur Grafik: http://www.astrobin.com/uploads/0a32fb95-d4c7-4d02-8ca4-5f7fde8dcf57.jpg
 
Zuletzt von einem Moderator bearbeitet:

Jan_Fremerey

Aktives Mitglied
Hallo Peter,

erstmal zu Deinem Jupiter von der vergangenen Saison: Der gefällt mir sehr und er ist ein schönes Beispiel für die Leistung der ALccd5. Mit welchem Deiner Teleskope ist denn die Aufnahme entstanden und, falls Du das noch irgendwo protokolliert hast, mit welcher Belichtungszeit und Aufnahmedauer?

Zitat von Zyklop:
imho kann usb2 sowieso netto kaum mehr als 30mb/s. Warum die neue ALccd5-II immer noch einen ollen usb2-port hat, verstehe ich nicht so ganz.
Offenbar geht es aber doch, selbst mit einem etwas älteren Laptop, schau mal hier, das sind dort offenbar echt ermittelte Transfer-Raten. Was man da unter "highspeed read out" versteht, weiß ich allerdings noch nicht.

Zitat von Zyklop:
Versuche mal mit einer Taschenlampe bei 1ms auf den Chip zu leuchten - komischerweise änderte sich bei mir dann teilweise die framerate nach oben. Warum auch immer.
Seltsam! - Mal schauen, ich will ohnehin noch ein paar Versuche mit der Kamera unternehmen.

Zitat von Zyklop:
Also der usb-port ist 100%ig der Flaschenhals, dann kommt die CPU oder die Software, denke ich.
Das will ich mir gerne noch im Detail anschauen. Die Chameleon übrigens schafft hier am Laptop über die USB-2.0 Schnittstelle 20 MB/s auf die HD und - merkwürdigerweise - nur 14 MB/s auf die RAM-Disk. An meinem Desktop schafft sie 22 MB/s auf die HD.

Gruß, Jan
 

Zyklop

Aktives Mitglied
Hi Jan, sorry die Daten habe ich nicht mehr - protokolliere ich aber auch nie. Ich weiss auch die fps nicht mehr.
Das Teleskop war mein 8" f8, mit dem ich am gleichen Tag mit der DBK31 diese Aufnahme gemacht habe. Die Auflösung ist bei der ALCCD5 natürlich einen Tick höher.
Gut, die Bruttotransferrate ist bei usb2 mit 60MB/s (480Mbit) spezifiziert, aber das habe ich noch nie erlebt. Mehr wie 35MB/s habe ich noch nie erreicht...
Mag sein dass die Kamera das voll ausschöpft, aber dann muss das Notebook, das Kabel, etc. auch passen.
Ich denke über einen ohnehin schnellen USB3-Port kann sowas klappen.
Da fällt mir ein, dass ich diesen Speed-Frame-Test ja über meinen PC hätte machen können, der hat USB3....bin ich doof. Hole ich heute abend nach.
 

Jan_Fremerey

Aktives Mitglied
Hallo Peter,

habe vorhin einen Namensvetter im Rahmen der oben bereits erwähnten Diskussion über die ALccd5-II angeschrieben mit der Bitte, uns hier bei unseren Fragen bezüglich der Transferraten weiter zu helfen, der kennt sich offenbar aus mit den Kameras.

Gruß, Jan

P.S. - Den Hinweis auf die Jupiterbilder habe ich wieder entfernt, weil diese mit einer QHY5L-II (nicht QHY5-II) aufgenommen waren.
 
Zuletzt von einem Moderator bearbeitet:

Zyklop

Aktives Mitglied
So daheim hab ich mal einen aktuellen QHY-Treiber installiert und ein frisches QGVideo4.1.
An einem USB3-Port mit 3m USB2-Kabel und SSD komme ich auf folgende Werte:
640x480pixel bei 28ms: 34fps
504x504pixel bei 27-28ms: 35fps
400x400pixel bei 20ms: 46fps
300x300 Pixel bei 20ms: 46fps
160x120pixel bei 5ms: stolze 160fps
84x72pixel bei 4ms: tolle 248fps
Wie sinnvoll die letzten beiden Auflösungen sind, wenn man während der Aufnahme kein Livebild hat kann man sich denken.
Wenn man allerdings Ganymed filmen will und die Monti perfekt nachführt...warum nicht.

Es ist schon seltsam wie die Belichtungszeit die fps beeinflusst.
Die 50fps von denen hier die Rede ist, habe ich nicht erreicht und bei voller Auflösung komme ich ich auch nur auf 7,5fps.
 
Zuletzt von einem Moderator bearbeitet:

Jan_Fremerey

Aktives Mitglied
Zitat von Jan_Fremerey:
Den Hinweis auf die Jupiterbilder habe ich wieder entfernt, ...
Hier ist stattdessen zur Auflockerung der Diskussion zwischendurch ein Bild von heute Nacht gegen 02:30 MEZ mit der eigenen ALccd5.

Link zur Grafik: http://www.astro-vr.de/RGB_p40wD1400Gs100.jpg

Das Seeing war - wie man hoffentlich sieht - um einiges besser als bei der mit der Eröffnung dieses Threads gezeigten Aufnahme. Die Daten: RGB mit Astronomik Typ II Filtersatz, jeweils 60s mit QGVideo bei 28 ms und Gain 60, 1,5x Drizzle aus AutoStakkert v1 und Nachbearbeitung in Fitswork.

Gruß, Jan
 

Jan_Fremerey

Aktives Mitglied
Nachtrag

Bei genauerem Hinsehen fällt auf, dass das Bild von einem engen Muster parallel verlaufender Linien mit vertikaler Ausrichtung durchsetzt ist. Dieses Muster kommt in dieser etwas stärkeren Vergrößerung deutlicher zum Ausdruck:

Link zur Grafik: http://www.astro-vr.de/RGB_p40dSinc120wD1400Gs100_0-45Kg090.jpg

Hier habe ich unter Berücksichtigung der 1,5-fachen Nachvergrößerung mit Drizzle in AutoStakkert nochmal zusätzlich um 20%, d.h. gegenüber den Original-Videoframes insgesamt um einen Faktor 1,8 nachvergrößert.

Das Linienmuster stört mich - merkwürdugerweise - nicht so sehr wie andere typische Überschärfungs-Artefakte, offenbar weil das Muster mit seiner Gleichmäßigkeit eher die Wirkung eines Grundrasters hat, wie man es etwa von Bildern auf Leinwand-Untergrund her kennt, und somit den Gesamteindruck des Bildes nicht wirklich entstellt.

Andererseits frage ich mich, ob es sich hier um eine Besonderheit des CMOS-Chips in Verbindung mit seiner Ausleseelektronik handelt, denn solche Muster waren mir bei CCD-Aufnahmen bislang nicht aufgefallen. Vielleicht kann uns dazu einer der mit der ALccd5 schon besser vertrauten Videografen etwas sagen?

Gruß, Jan
 

Jan_Fremerey

Aktives Mitglied
Zitat von Zyklop:
nicht schlecht...dafür dass man kein livebild hat.
Hallo Peter,

Deine Bemerkung bezieht sich offenbar auf die eingefrorenen Bilder auf dem Live-Monitor von QGVideo während der Aufnahme. Ohne Livebild kann man natürlich nicht vernünftig nachführen. Bei 400x400 brauchte ich aber noch nicht nachzuführen. Hier sind mal die ersten 30 Frames aus einem der drei Originalvideos (Rot) zu dem oben gezeigten Bild als Endlosschleife:

Link zur Grafik: http://www.astro-vr.de/Ju121113_0232_R_28msG50t60_0-29.gif

Gruß, Jan
 
Zuletzt von einem Moderator bearbeitet:

Zyklop

Aktives Mitglied
Hi Jan, na das geht ja noch.
Also ich hab bei meiner DBK31 auch oft ein Raster drin, dass ich mit einem 0,3 bis 0,5 pixel-gauss-blur entferne. - liegt glaub auch an der stacking-software.
 

Jan_Fremerey

Aktives Mitglied
Zitat von Zyklop:
Also ich hab bei meiner DBK31 auch oft ein Raster drin, ... liegt glaub auch an der stacking-software.
Hallo Peter,

hier ist mal zur Abwechselung noch ein R-RGB aus der vergangenen Nacht,

Link zur Grafik: http://www.astro-vr.de/conv_GRB_28msG50t60_00008g3_Driz_q384_p40lumi_dSinc116wD1306_mitRGB_fs120_0-65Kg090_cr.jpg

da ist dieses vertikale Linienmuster nicht zu erkennen.

Im übrigen ist mir - leider erst jetzt - aufgefallen, dass sich die in obigen Tabellen angegebenen Datenraten aus einer Übertragung von 3 Byte je Pixel ergeben. Monochrome Bilder im Y8-Format sollten aber nur 1 Byte pro Pixel enthalten. So sieht es jedenfalls auch bei meinen verschiedenen CCD-Kameras aus.

Die für die neue ALccd5-II spezifizierte Datenrate von 39 MB/s bezieht sich demnach vermutlich auf die Übertragung von 24 Bit RGB-Farbbildern. Möglicherweise bezieht sich der hier von Peter angegebene "highspeed read out" Modus schlicht auf eine reduzierte Datenrate mit 1 Byte pro Pixel. Damit käme man bei der ALccd5-II auf 13 MB/s statt 39, und das kann nicht nur der "4 Jahre alte Laptop" von Peter, sondern, wie die Tabellen ausweisen, auch mein gegenwärtig benutztes Notebook.

Gruß, Jan
 

Zyklop

Aktives Mitglied
Hi Jan,
ich glaube du solltest mal versuchen zu prüfen wieviel dropframes in den hohen Auflösungen stecken.
Vielleicht geht das ja irgendwie mit wxAstroCapture.
Wäre doch doof, wenn man mit 100fps aufzeichnet und die Hälfte sind doppelt...was meinst du?
 
Status
Es sind keine weiteren Antworten möglich.
Oben