Problem, Schwarz/Weiß statt Farbe

astroh

Mitglied
Hallo,
vielleicht hat jemand eine Erklärung. Seit kurzem sind meine Fits-Bilder, wenn ich sie in Fitswork öffne nur noch in schwatz-weiß.
Aufnahmetechnik hat sich nicht geändert. Kamera QHY8, Software "Nebulosity", Speicherformat "Fit". In Nebulosity sind die Bilder in Farbe.
Hier ein Screenshot:
Vergleich.JPG

Sie lassen sich auch nicht in Farbe umwandeln.
Kann mir da jemand helfen?
Vielen Dank schon mal.

SC, Horst
 

mettling

Mitglied
Hallo Horst,

Ich kenne Nebulosity nicht, aber ich vermute mal, die Software debayert Dein Bild austomatisch für die Anzeige, speichert es aber nicht debayert als s/w-Bild. Wenn das vorher nicht war, muss es also irgendwo an den Einstellungen von Nebulosity liegen.
Hast Du mal versucht die Bilder in Fitswork durch debayern in ein Farbbild umzuwandeln?

Bis dann:
Marcus
 

astroh

Mitglied
Hallo Marcus,

Danke für die Antwort. In Nebulosity habe ich an den Einstellungen nichts geändert. Hier werden die Bilder auch noch in Farbe angezeigt. Umwandeln in Fitswork geht auch nicht. Sie ändern sich nicht.
Habe jetzt mal in BMP und in TIF gespeichert, da sind sie dann in Farbe.

VG, Horst
 
Zuletzt bearbeitet:

Optikus

Mitglied
Hallo Horst,

das muss an den Einstellungen liegen, das Problem in der von Dir vorgetragenen Form kenne ich nicht. Entweder ist irgend eine .dll den Heldentod gestorben oder das Debayern der Ausgabebilder fällt aus irgendeinem Grund aus. Das muss dem Programm irgendwo mitgeteilt worden sein, anders geht es nicht.

CS
Jörg
 

astroh

Mitglied
Danke Jörg für deine Rückmeldung.
Also an den Einstellungen habe ich nichts geändert. Man kann in den Einstellungen Ausgabeformat folgendes einstellen:
ColorFileFormat -> RGB FITS: ImagesPlus
-> RGB FITS: Maxim
-> 3 Seperate FITS
Der erste Punkt war immer eingestellt. Habe nun mal den 2. probiert. Hier sind dann zwar die Bilder in Fitswork in Farbe, kann sie dann aber nicht mehr im DSS oder RegIm bearbeiten.
Beim 3. Punkt erhalte ich drei Einzeilbilder. Diese kann ich dann auch in Fitzwork zu einem Farbbild kombienieren.
Wenn ich dies tun würde, müsste ich alle Frames, Flates und Bias vorher umwandeln.
Habe jetzt auch mal auf einen anderen Rechner, wo das neu Win10-Update (1903) noch nicht drauf ist, probiert. Es ändert sich nichts.
Bin da erst mal etwas ratlos.

CS
Horst
 

moos

Mitglied
hi Horst,
schonmal vorweg: Für Farbbilder gibt es kein standard fits. Sie werden fit-rgb oder fits-cube genannt. fitswork liest daher nur die erste Tabelle des fits aus und das ist vermutlich rot. Wenn du das debayerst wird nichts brauchbares herauskommen. Der weg über 3 einzelne fits ist zwar aufwändig, aber letzlich der sicherste.
Ich würde aber in fitswork nochmal nachsehen, ob es dort eine Einstellung gibt.
 

pem.bn

Mitglied
Schau Dir mal in den verschiedenen Programmen den Fits-Header an. In Fitswork geht das z.B. mit Fenster -> Fits-Header (zweite von unten, Häkchen setzen). Dann siehts Du die Dimension des Bildes. Bei Farbe sollte das 3-D sein, also NAXIS=3, wobei auch NAXIS3=3 ist, also ein Cubus der Form (3, Rows, Cols).

Das ist bei mir so und es wird auch ein buntes Bild angezeigt in Fitswork.

Möglicherweise speichern einige Programme das anders ab: 3 Karten mit NAXIS=2
Dann kann es sein, dass Fitswork nur die erste Karte einliest.
 

astroh

Mitglied
Hallo Carsten und pem.bn,

danke für Eure Hinweise. Entschuldigung, dass ich heute erst antworte. Ich denke habe den Fehler gefunden. Es haben sich aus mir nicht erklärbarem Grund die Einstellungen in Nebulosity geändert. Habe Tests mit meinem Laptop und gleichem Programm mit einer älteren Version gemacht. Hier hat alles funktioniert. Nach dem Vergleich der Einstellungen habe ich zwei Unterschiede festgestellt. Nach der Änderung im Hauptrechner ist auch hier wieder alles bestens. Die Fits-Header werden auch wieder so angezeigt wie pem.bn (Name ?) beschrieben hat.

Noch mal vielen Dank und CS
Horst
 
Oben