StarNet klemmt nach PixInsight Update

Okke_Dillen

Mitglied
Moin,

nach dem PI-Update geht StarNet nicht mehr. Die Fehlermeldung lautet: "Checkpoint file not found!" :oops: Nanu?
Ist euch das auch schon passiert und was kann ich dagegen tun?

Danke und Gruß,
Okke
 

Terrorernie

Mitglied
Hatte ich auch mal... Hab Starnet dann neu hinzugefügt, und PI dann als lokaler Computer Admin ausgeführt, dann ging es.

scheint ein Rechteproblem zu sein...

gruss
Ernie
 

Hoschie

Mitglied
3 Tage bevor das letzte PI Major Update rauskam, hatte ich mich gerade erst zur Installation des Letzten durchgerungen. Bin davon, dass man jetzt offenbar auf den Update-Wahnsinn - Hype mit aufgesprungen ist, eher so mittelprächtig begeistert.
 

Okke_Dillen

Mitglied
Moin,

seltsamerweise funktionierts wieder. Warum? Keine Ahnung :oops:

Ich hab StarNet eben aus dem Processes - All Processes - Pulldown gestartet. Läuft.
Zuvor hatte ich es aus einem Process-Icon gestartet, das ich mir nebst allen anderen Prozessen, die ich so brauche auf dem PI-Desktop abgelegt hab (MyIcons.xpsm). Wenn ich von hier aus starte, kommt die o.g. Fehlermeldung.

Icon gelöscht und neu angelegt, alles wieder gut... :oops: aha... es rechnet.... und entsternt. Ja gut, geht wieder, fein! :giggle:

Bescheid!

Grüße und CS!!
Okke
 

skyborg

Mitglied
Hallo,

das Problem tritt auf, wenn starnet++ die eigenen Bibliotheken nicht findet. Diese werden ja im Rahmen der Installation in das bin-Verzeichnis kopiert. In manchen Situationen (z.B. Projekt geladen) scheint sich die PixInsight-Umgebung in einem anderen Working-Directory zu befinden. Nachprüfen (und korrigieren) kann man das wie folgt:
- in PI die Process Console öffnen und dort den Befehl pwd eingeben [Anmerkung: pwd steht für print working directory].
- Ausgabe ist ein Dateipfad, z.B. bei mir im Fall wo Starnet++ die Fehlermeldung zeigt, ist es immer "C:/Program Files/PixInsight"
- mit dem Befehl cd kann dann in das bin-Verzeichnis gewechselt werden, z.B. cd bin oder auch cd "C:/Program Files/PixInsight/bin"
- mit nochmaligem pwd kann man prüfen, ob der Verzeichniswechsel geklappt hat
Bei mir funktioniert starnet++ dann immer wieder sofort, ohne PixInsight neu zu starten, Icons zu löschen o.ä.

Liebe Grüße, Frank
 

Astromusi

Mitglied
Moin Okke,
hallo liebe alle anderen,
das mit Checkpointfile tritt (Internetrecherche) immer dann auf, wenn es innerhalb einer gespeicherten Projekt-Datei ausgeführt werden soll.
D.h.
-> PI-Projekt schließen
-> PI (ohne load Project) öffnen
-> Starnet++ ausführen... warten bis endlich fertig
-> Bild(er) abspeichern und ggfs. mit Projekt weitermachen...

HG
Thomas
 

Okke_Dillen

Mitglied
lange! Bei 2x drizzle ohne Crob schonmal 20minuten. Bei Stride-Werten unter 128 noch länger... :oops:
Schätze, das hängt auch von der Anzahl Sterne ab.

CS Okke
 

Forgnod

Mitglied
Hi Okke,

gut dann ist mein Eimer nicht eingerostet hatte grade Stride von 16 eingestellt und er hat ca. 8 min gebraucht.
Wäre cool wenn es GPU optimiert wäre. Damit sollte es deutlich schneller gehen

Forgnod
 

skyborg

Mitglied
Moin Okke,
hallo liebe alle anderen,
das mit Checkpointfile tritt (Internetrecherche) immer dann auf, wenn es innerhalb einer gespeicherten Projekt-Datei ausgeführt werden soll.
D.h.
-> PI-Projekt schließen
-> PI (ohne load Project) öffnen
-> Starnet++ ausführen... warten bis endlich fertig
-> Bild(er) abspeichern und ggfs. mit Projekt weitermachen...
Ja genau, und die Ursache ist das aktuelle Working Directory der PI-Umgebung. Wenn ich z.B. PI direkt starte, ist das Working Directory "C:/Program Files/PixInsight/bin" und starnet++ funktioniert. Ebenso, wenn ich bei mir ein Projekt über "Open Recent" oder "Load Project" lade. Wenn ich dagegen im Windows-Explorer ein project.xosm doppelklicke, ist das Working Directory anschließend das, wo die Projekt-Datei gespeichert ist, z.B.
Code:
pwd
E:/Projects/M45/M45.pxiproject
und starnet++ funktioniert nicht. Wie oben beschrieben cd "C:\Program Files\PixInsight\bin" und starnet++ geht wieder.

Grüße, Frank
 
Oben