Was verursacht die Gradienten? | Astronomie.de - Der Treffpunkt für Astronomie

Was verursacht die Gradienten?

TakFan

Mitglied
Hallo ins Forum,

Ich bin PI Anfänger und wundere mich über den fleckigen Gradienten nach dem Stacken:
stack.jpg

Lights 140 x 90sec, große Anzahl an Darks & Bias, Flats, ISO 800, Canon 550D mod, aufgenommen aus Dortmund 2km vom Zentrum

Workflow:
Masterbias
Superbias
Kalibrierung darks -> masterdark
Kalibrierung flats -> masterflat
Kalibrierung lights
Cosmetic correction
Debayern
Regsitrieren der lights
Integrieren der Lights
Drizze Intrgration

Da mögen handwerliche Fehler bei vorgekommen sein.

Das Superbias sieht m.E. Ok aus:
bias.jpg


Auch das Masterdark wirkt normal:
dark.jpg


Und auch das Flat:
flat.jpg


Mich würde interessieren, wie solche Gradienten dennoch entstehen?

Ich habe über 4 Nächte fotografiert. Das oberste Bild ist aus Nacht 4.
In Nacht 1, 2 und 3 sieht es auch nicht besser aus.

Beispiel Nacht 1 (120 Lights, selbe Einstellungen wie Nacht 4):
Nacht1.jpg


Ich habe die Bias und die Darks aus allen 4 Nächten integriert und für die jeweiligen Lights der einzelnen Nächte verwendet. Die 4 Nächte hatten aber auch ähnliche Temperaturen und die Kameraeinstellungen waren immer identisch.

CS
Dirk
 
Zuletzt bearbeitet:

bulrichl

Mitglied
Hallo Dirk,

es könnte ein Problem bei der Kalibrierung sein. Die Empfehlung, die Darks mit dem MasterBias zu kalibrieren, ist großer Mist. Dabei besteht die Gefahr, dass in den kalibrierten dark frames Clipping auftritt (negative Werte, die beim Abspeichern auf Null gesetzt werden). Wie man auf Clipping prüft, habe ich ganz unten beschrieben. Das MasterDark sollte durch einfache Integration der dark frames erzeugt werden, in diesem Fall enthält das MasterDark den bias offset.

Bei der Kalibrierung der light frames gibt es dann zwei Fälle, die zu einem korrekten Ergebnis führen:

a) mit dark frame otpimization (Skalierung des MasterDarks):
Abschnitt 'Master Bias' aktivieren, MasterBias selektieren, Option 'Calibrate' deaktivieren,
Abschnitt 'Master Dark' aktivieren, MasterBias selektieren, beide Optionen 'Calibrate' und 'Optimize' aktivieren,
Abschnitt 'Master Flat' aktivieren, MasterFlat selektieren , Option 'Calibrate' deaktivieren.

b) ohne dark frame optimization:
Abschnitt 'Master Bias' deaktivieren,
Abschnitt 'Master Dark' aktivieren, MasterBias selektieren, beide Optionen 'Calibrate' und 'Optimize' deaktivieren,
Abschnitt 'Master Flat' aktivieren, MasterFlat selektieren , Option 'Calibrate' deaktivieren.

Für beide Fälle wird ein MasterFlat benötigt, das folgendermaßen hergestellt wurde:
Flat frames mit MasterBias oder MasterFlatDark kalibrieren und kalibrierte flat frames integrieren.

Man kann sehr einfach überprüfen, ob Clipping auftritt: entweder durch Anschauen des Histogramms (horizontal zoom auf ca. 50 setzen) oder der Statistik ('Unclipped' deaktiviert, das ist die Default-Einstellung; der Wert von count (%) muss sehr nahe bei 100 % sein). Wenn im kalibrierten light frame trotz der beschriebenen Vorgehensweise Clipping auftritt, muss bei der Kalibrierung der light frames ein 'Output pedestal' verwendet werden.

Bernd
 

TakFan

Mitglied
Hallo Bernd,

Haben herzlichen Dank für Deine Rückmeldung. Ich werde dies in der näcshten Nacht am Rechner ausprobieren udn hier eien Rückmeldung geben.

Du gibts hier im Forum immer wieder ausführliche Tipps. Vielen Dank für Deine Hilfestellungen!

Dirk
 

bulrichl

Mitglied
In meinem post #2 sind zwei (offensichtliche) Fehler. Richtig muss es natürlich heißen (Unterschiede untrstrichen):

a) mit dark frame otpimization (Skalierung des MasterDarks):
Abschnitt 'Master Bias' aktivieren, MasterBias selektieren, Option 'Calibrate' deaktivieren,
Abschnitt 'Master Dark' aktivieren, MasterDark selektieren, beide Optionen 'Calibrate' und 'Optimize' aktivieren,
Abschnitt 'Master Flat' aktivieren, MasterFlat selektieren , Option 'Calibrate' deaktivieren.

b) ohne dark frame optimization:
Abschnitt 'Master Bias' deaktivieren,
Abschnitt 'Master Dark' aktivieren, MasterDark selektieren, beide Optionen 'Calibrate' und 'Optimize' deaktivieren,
Abschnitt 'Master Flat' aktivieren, MasterFlat selektieren , Option 'Calibrate' deaktivieren.

Bernd
 

wynnie

Mitglied
Hallo Dirk,

verwendest Du Dithering ? Wenn nicht ist es mit hoher Wahrscheinlichkeit Walking Pattern Noise.
Zumindest sahen meine Bilder auch so aus bevor ich gedithert (feinstes denglisch ;) ) habe.

Leider bekommt man das aus den Bildern kaum mehr heraus.

Viele Grüße
Michael
 

Stefan_Lilge

Mitglied
Hallo Dirk,

abgesehen von dem Tip von Dirk, kein Bias von den Darks abzuziehen, sieht mir dieses schachbrettartige Muster nach einem Artefakt von Bildverarbeitung aus. Ich habe manchmal solch einen Hintergrund, wenn ich einen Algorithmus für Gradientenbeseitigung angewendet habe. Hast du sowas vielleicht auch gemacht?

Ansonsten würde ich es mal ohne drizzle integration versuchen. Und sicher gehen, dass nicht irgendwo ein Haken bei "Darks optimieren" o.ä. gesetzt ist, damit PI die Darks nicht irgendwie herumskaliert.
 

VMC_Andre

Mitglied
hi,

Dithering ? Wenn du das machst ,dann lass die Darks weg. Das führt bei mir zu besseren Ergebnissen in Hintergrund und Farben der Motive.
Walking Partnern Mouse würde ich eher auch meinen. Da diese Kamera das wohl stark hat ist auch klar bei immer mehr Aufnahmen wird auch das immer mehr verstärkt im Bild zu sehen sein.
 

wynnie

Mitglied
Hallo!

Darks sind bei DSLRs eh schwierig, da es, meiner Meinung nach, sehr schwierig ist, die passende Temperatur hinzubekommen. Ich habe früher auch immer Darks gemacht und mir einen abgebrochen, die mit halbwegs richtiger Temperatur hinzubekommen. Vor allem in Nächten mit starkem Temperaturgradienten nahezu ein Ding der Unmöglichkeit. Seit ich Dither (geht mit APT und phd2 quasi automatisch) mache ich keine Darks mehr. Wie André schon geschrieben hat bringen die mehr Probleme mit sich als sie verbessern, zumindest nach meiner Erfahrung. Ich habe sie zuletzt nur für die Erstellung einer BadPixelMap im Astro Pixel Processor verwendet. Die nutze ich dann allerdings, aber das ist ja auch was anderes.

Wichtig ist, wenn man Dithert beim Stacken, je nach Programm, entweder Kappa Sigma Clipping oder die Outliner Rejection zu verwenden.

Viele Grüße
Michael
 

GanymedRN

Mitglied
Eine kleine Anmerkung. Darks braucht man nicht wenn man dithered ist nicht ganz korrekt.
Dithering verschiebt die Objekte (Sterne, Nebel, Galaxien, ...) relativ zu den Hot und Cold Pixel im Bild. Daher wird deren Einfluss beim Stacken stark reduziert da ja auf Sterne registriert wird und die anderen Bilder an der Stelle normale Pixelwerte haben. Eine Darkkorrektur für Hot und Cold Pixel ist daher nicht nötig.
Bei Kameras mit Ampglow braucht man aber auch die Darks.
 

TakFan

Mitglied
Euch Allen Vielen Dank für die Rückmeldungen. Walking Pattern Noise also.

Die Aufnahmen sind ohne Guiding / Dithering entstanden, da diese alte EM-200 Zweitmontierung noch nicht FS-2 kompatibel umgebaut ist und ich den vorhandenen MGEN somit nicht für's Dithern nutzen konnte. Mir fehlt dazu noch der Motor-Umbauset um die vorhandene 30V FS-2 zu nutzen.

So bleibt mir erst mal mit dem zu arbeiten, was ich auf dem Chip habe. Ich werde jetzt ein paar Nächte am PC ausprobieren, was über alternative Ansätze raus zu holen ist. Bernd hat ja u.a. einen Ansatz aufgezeigt.
Ich melde mich, wenn es neue Ergebnisse gibt.

CS & Danke
Dirk
 

eject

Mitglied
Hi Dirk,

hast du zufälligerweise Local Normalization verwendet? Ich habe nämlich heute Lights von 2 Nächten gestackt (auch DSLR, aber mit Dithering und ohne Darks) und hatte ähnliche "Farbinseln" nach ABE/DBE. Hab jetzt nochmal ohne die Local Normalization Files integriert und siehe da, die Farbgradienten sind weg. Eventuell ist das bei dir auch die Lösung des Problems.

lg, David
 

frasax

Mitglied
Hallo Dirk,

hier liegen m.E. zwei Dinge übereinander. Zum einen dieses sehr feine, bürstenstrichartige Muster. Das ist das viel zitierte WalkingPattern, was man dagegen tun kann wurde ja schon geschrieben.
Das große, fleckige Muster hat damit aber glaube ich nichts zu tun. Ich vermute hier fast ein Problem mit dem Debayering. Und aus eigener Erfahrung weiß ich, dass da schonmal was durcheinander gehen kann. Falsches Debayer Muster oder am falschen Punkt im Workflow angewandt. Ist aber nur ins blaue geraten.

CS Frank
 

TakFan

Mitglied
Hallo Frank und David,

Ich habe Drizzle und Normalization verwendet. Und das erstmalig. Ich habe auch schon vorher mit der DSLR gearbeitet und hatte solche Effekte nicht. Allerdings war ich bis dato bei max. 20 Lights.

Ich mache heute Nacht mit der EBV weiter (von vorne) und werden berichten. Ich denke es liegt an meiner falschen Programmbedienung und auch ein wenig am walking pattern. Bin gespannt.

Vielen Dank für Eure Rückmeldungen!
Dirk
 

TakFan

Mitglied
So, kleiner Zwischenstand:

imDFO.jpg

140 x 90sec, ISO800, DSLR mod, ohne Guiding / Dithern, Bortle 8

Workflow:
Masterbias
Superbias
Addieren der nicht kalibrierten darks -> masterdark
Kalibrierung flats -> masterflat
Kalibrierung lights (mit dark frame optimization)
Keine Cosmetic correction
Debayern
Star alignment
Integrieren der Lights
Kein Normalization oder Drizzle
Keine weitere Bearbeitung außer Stretch

Eure Vermutung bzgl. anderer Einflüsse, neben WalkingPattern, ist richtig!

Muss mal kurz schlafen gehen. Die vielen, sternklaren Nächte verursachen Schlafdefizit.
Ich berichte weiter.

CS
Dirk
 

bulrichl

Mitglied
Du bist auf einem guten Weg. Vielleicht sieht es ohne dark frame optimization noch besser aus? Für die Zukunft wäre allerdings noch wichtiger, die eigentliche Ursache zu klären. Hast Du mal überprüft, ob Deine kalibrierten dark frames des ersten Versuchs geclippt sind?

Bernd
 

TakFan

Mitglied
Hallo Bernd,

Ich habe mir ein kalibriertes Dark aus dem ersten Versuch genommen. Unter Statistik ist der Count um die 50 und im Histogram sehe ich folgendes:

1587763719971.png


Ich habe mir auch mal ein kalibriertes Light aus dem letzten Lauf (mit dem besseren Ergebnis angesehen, also mit unkalibrierten Darks gemacht). Dort liegt der count bei 99.999 und das Histogram sieht folgendermaßen aus.

1587763185606.png


Bei den Flats ist es vergleichbar. Heißt das es liegt clipping bei den Flats & Lights vor?

Ich mache jetzt mal eine Lauf ohne dark frame optimization.

Gruß
Dirk
 

TakFan

Mitglied
Und hier noch die Varaiante ohne Dark Frame Optimization:

ioDFO.jpg


Gleicht der Variante mit Dark Frame Optimization, wie ich finde.

CS
Dirk
 

bulrichl

Mitglied
Hallo Dirk,

ja, das erste Histogramm (von einem kalibrierten dark frame) zeigt genau, welches Problem hier vorlag: falsche Herstellung des MasterDark. Die Ursache: bei CMOS-Kameras wird eine kamerainterne Dunkelstrom-Subtraktion (also die Subtraktion einer Konstanten) durchgeführt. Dadurch ist der Mittelwert der Intensitätswerte eines dark frames nur wenig bis überhaupt nicht höher als der Mittelwert der Intensitätswerte eines bias frames. Da der Peak im Histogramm des dark frames durch Rauschen verbreitert ist, treten bei der Subtraktion des MasterBias vom dark frame bei ca. 50 % der Pixel negative Werte auf, die abgeschnittem (auf Null gesetzt) werden.

Die Empfehlung in einigen im Internet kursierenden Tutorials (z. B. im Tutorial von lightvortexastronomy), die dark frames zu kalibrieren, ist deshalb ganz großer Mist. Wenn Du die dark frames ohne Kalibrierung einfach integrierst, tritt dieses Problem überhaupt nicht auf.

Die Unterschiede zwischen den beiden Ergebnissen (mit dem neuen MasterDark, mit/ohne dark frame optimization) sind an den JPG-Bildern schwierig zu beurteilen. Man dürfte auch nicht jeweils die STF Auto Stretch Versionen miteinander vegleichen, da die Bilder in diesem Fall ganz unterschiedlich gestreckt sein können. Der Vergleich ist nur dann objektiv,wenn in den STF-Parametern derselbe Midtones-Wert gesetzt und mittels Shadows-Wert beide Bilder auf die gleiche Helligkeit eingestellt wurden.

Deine Bemerkung
Bei den Flats ist es vergleichbar. Heißt das es liegt clipping bei den Flats & Lights vor?
habe ich allerdings nicht verstanden. Wie hast Du denn die flat frames kalibriert? Hast Du es so gemacht, wie ich es im Beitrag #2 im vorletzten Absatz beschrieben habe?

Bernd
 

TakFan

Mitglied
Hallo Bernd. Ich denke meine Frage war ungeschickt. Habe das lesen der Kurven nicht recht verstanden gehabt. Dachte ein Wert nahe 100 wäre ein Indiz für Clipping.

Ich habe die Flats so kalibriert, wie Du es empfohlen hast.

Mein ursprünglicher Worklow war übrigens genau nach
lightvortexastronomy 😂.

Gruss Dirk
 

bulrichl

Mitglied
Die Kalibrierung der flat frames dürfte nie zu Clipping führen, da man ja versucht, die Belichtung so zu wählen, dass das Histogramm etwa in der Mitte liegt.

Clipping erkennt man im Histogramm daran, dass ein Peak am unteren oder am oberen Ende abgeschnitten ist. Bei dem kalibrierten dark frame ist das natürlich am unteren Ende, bei Null, der Fall. In Statistics soll der Wert von count (%) nahe 100 % sein. Eine größere Abweichung von diesem Wert zeigt Clipping an. In Deinem Beispiel des kalibrierten dark frames: ca. 50 % bedeutet, dass der Rest der Pixel (ebenfalls ca. 50 %) geclippt ist. Für das unkalibrierte dark frame: 99.999 % bedeutet, dass 0.001 % der Pixel geclippt sind (also praktisch gar keine).

Die letzte Integration (keine dark frame optimization) sieht immer noch nicht wirklich gut aus. Das Problem scheint besonders im Rotkanal vorzuliegen. Ohne die entsprechenden Dateien (die aus der Kamera im FITS- bzw. CR2-Format und die verarbeiteten im XISF-Format) kann man dazu wenig mehr sagen.

Wahrscheinlich würde Dithering helfen, was Michael ja schon im post #5 geschrieben hat.

Bernd
 

TakFan

Mitglied
So,

nachdem ich erst mal ein paar Tage Schlaf nachholen musste ging es übers WE wieder an den Rechner mit folgenden Workflow:
  1. Blink
  2. SubframeSelector zur Bestimmung des besten Bildes
  3. Addieren der BIAS Einzelbilder zum MasterBIAS
  4. Ableiten eines SuperBIAS aus dem MasterBIAS
  5. Addieren der DARK Einzelbilder zum MasterDARK (ohne Kalibrierung)
  6. Kalibrieren der FLAT Einzelbilder mit dem SuperBIAS
  7. Addieren der kalibrierten FLAT Einzelbilder zum MasterFLAT
  8. Kalibrieren der LIGHT Einzelbilder mit dem SuperBIAS, MasterDARK und MasterFLAT (mit Dark Frame Optimization)
  9. Mit CosmeticCorrection die sehr wenigen, defekten Pixel in den kalibrierten LIGHTs entfernt
  10. Debayern der korrigierten und kalibrierten LIGHT Einzelbilder
  11. Registrierung der Debayerten LIGHTS (StarAlignment)
  12. Addieren der registrierten LIGHTS Einzelbilder aus allen 4 Nächten zum MasterLIGHT
  13. DynamicCrop
  14. STF mit entkoppelten Kanälen + HistogramTransformation
  15. Speichern als 16bit tif und Umwandlung in jpeg geringer Tiefe mit PS

Ausgelassen habe ich:
- die Gewichtung der Lighframes über SubframeSelector
- Drizzle
- Normalization
- weitere Bearbeitung des Ergebnisses

Aufnahmedaten: 76mm Refraktor bei 594mm / Canon 550D mod / ISO 800 / 441 x 90sec (11h) + Dark, Flats & Bias, Dithering: nein, Guiding: nein, Dortmund Zentrumsnah

Ergebnis:
Alle.jpg


Alleinv.jpg

Die Querstreifen können m.E. kein Walking Pattern Noise sein. Die Sturkturen sind nicht stochastisch verteilt,. Könnte das auch an der kürzlich gebraucht erworbenen Kamera liegen?

Ich habe früher mit einer anderen Canon 550d fotografiert (anderes Gehäsue und unmodifiziert). Auch da ohne Dithering und ohne Guiding. Solche Effekte hatte ich nicht. Beispiel:

NGC147NGC185.jpg

22x240s / ISO1600 / 60mm Refraktor bei 355mm

Jedoch kam ich nie über 2h Belichtungszeit. Bei M51 sind es nun 11h aus der Großstadt.

Ich versuche mal den Hintergrund anzugehen.

CS
Dirk
 
Zuletzt bearbeitet:

TakFan

Mitglied
Nun, ich habe 2 x DBE hintereinander aufgerufen, ohne mir Mühe beim Gitternetz zu machen - und es wird besser. Jetzt muss ich mich darin einarbeiten. Für Tips habe ich ein offenes Ohr.

AlleDBE.jpg


CS
Dirk
 

TriffiD

Mitglied
Hallo Dirk!
Das ist schon ein sehr gutes Ergebnis mit DBE.
Ich habe sehr ähnliche Muster bei meiner Canon. Diese sind erst in den letzten Monaten entstanden und immer schlimmer geworden. Ist die Kamera alt? Liegt bei einer 550D ja nahe. Es kann durchaus sein, dass Bauteile der Elektronik so gealtert sind, dass sie nicht mehr so recht wollen.
Ich schreite jetzt zum Austausch.
Gruß
Sebastian
 

TakFan

Mitglied
Hallo Sebastian,

10 Jahre müsste ie laut Internet alt sein. Habe sie vor ein paar Wochen gebraucht mit 5400 Auslösungen erworben.

Habe neben der modifizieren auch schon lange eine unmodifiziert 550d. Da habe ich solche Effekte nicht. Nur die defekten Pixel werden m.E. mehr.

CS
Dirk
 

TriffiD

Mitglied
Hallo Dirk,
ok, 10 Jahre sind doch recht alt. Ich habe gehört, dass neben den Auslösungen auch längere Nichtnutzung der Kamera schadet. Eventuell wurde die Gebrauchtkamera ganz anders verwendet als dein unmodifiziertes Gerät. Dann ist der Vergleich nicht unbedingt stichhaltig.
Ich weiß das alles nicht genau, aber meine Kamera (eine modifizierte 1100D) hat derartige Probleme neuerdings eben auch und die ist von 2011 (oder frühes 2012). Auch der Fakt, dass das Forum hier letztlich keinen richtigen Rat weiß ist kein gutes Zeichen, zumal du die Bilder (für meine Begriffe) vollkommen korrekt behandelt hast.
Ich hoffe, du findest eine Lösung, aber an einen Alterungsdefekt sollte man bestimmt auch denken.
Gruß
Sebastian
 

TakFan

Mitglied
Hm, bei M13 (3h bei gleichen Parametern, Workflow & Optik) sieht alles "normal" aus. Nur das Flat funzt nicht richtig beim kalibrieren. Muss noch rausfinden warum (passiert, egal ob in PI oder DSS: das Ergebnis ist ähnlich).

118 x 90sec / ISO800 / weder dithern noch guiding / Canon 550Dm mod
Stack ohne weitere Bearbeitung
Pixinsight
MasterLIGHTmdO.jpg


Flat (nach Autokontrast inn PS)
MasterFLAT.jpg


CS
Dirk
 

TriffiD

Mitglied
Hallo Dirk,
das Flat hat im Grunde vielleicht ganz gut gepasst. Das helle Ding über M13 könnte ein Fussel sein, der im Laufe der Nacht gewandert und erst bei den letzten Aufnahmen, kurz vor der Flaterstellung dort gelandet ist.
Gruß
Sebastian
 
Das Homepagetool mit der aktuellen Mondphase u.v.m.

(Alle Angaben für 10 Grad ö.L. Länge / 50 Grad n.B.)

In Kooperation mit www.Der-Mond.org Hole Dir jetzt das kostenlose Mondtool für Deine Homepage

Oben