Flats: Vignettierung wird überkompensiert. Was mache ich falsch? | Astronomie.de - Der Treffpunkt für Astronomie

Flats: Vignettierung wird überkompensiert. Was mache ich falsch?

Dunkle Energie

Mitglied
Hallo, liebes Forum,

ich habe mehrere Flat-Aufnahmeserien gemacht, aber es kommt immer das gleich dabei heraus: Die Fehler, die die Flats in den Lights beseitigen sollen, werden überkompensiert.

Das einzig Positive ist, daß das Problem nach Vorverarbeitung, Stacken und Kalibrieren nahezu genauso aussieht wie bei einem einzigen Framepaar (ein Light und ein Flat), ich also offensichtlich beim Weiterverarbeiten keine Fehler künstlich produziere.

Die Flats habe ich so aufgenommen, daß in der Aufnahmesoftware die Intensitätswerte des Histogramms praktisch genau in der Mitte plaziert sind (ASIair). Da PI keine Farbkorrektur durchführt, erscheinen im Histogramm des nicht debayerten Bildes drei Peaks, aber auch die liegen nicht etwa am Rand, sondern so, daß nichts abgeschnitten wird. Außerdem gibt es diese Verschiebung logischerweise auch in den Lightframes.

Es mag sein, daß ich einen Denkfehler habe, aber es ist doch so, daß ein Flat dazu da ist, der Software die Helligkeitsverteilung mitzuteilen. Dabei sollte es doch egal sein, ob das Flat etwas heller oder dunkler ist, solange alle Intensitätswerte relativ zueinander korrekt wiedergegeben werden.

Da die ganzen Gerätschaften seit Monaten unverändert sind und fest miteinander verschraubt in der Sternwarte stehen, kann es kein Montageproblem sein. Als Lichtquelle verwende ich einen "Leuchttisch" (so ein 35-Euro-Allerweltsteil), welchen ich schon parallel zu den Sensokanten und um die optische Achse verdreht angeordnet habe. Ich habe etwas kürzer und etwas länge belichtet (immer auf das Histogramm achtend), die Flats bei Nacht aufgenommen (wegen möglicher Lichtlecks), aber egal, was ich mache, es ändert sich praktisch nichts (was einerseits gut ist, aber eben immer das gleiche Problem verursacht.

Hat jemand einen heißen Tip, was ich machen sollte?

Ich habe mal einen Light- und einen Flatframe in einem Zip-Archiv zum Download bereitgestellt:


Da der gesamte Ablauf des Kalibrierens nichts grundsätzliches an dem Problem ändert, sollten die beiden Bilder genügen.


Vielen Dank!

Markus
 

bulrichl

Mitglied
Hallo Markus,

das Problem ergibt sich daraus, dass (offenbar sowohl beim light frame als auch beim MasterFlat) der bias offset nicht subtrahiert wurde. Ohne diese Subtraktion geht die Flatfield-Korrektur aber völlig in die Hose.

Der bias offset (bei der ASI294MC Pro mit gain 120 und offset 30: ca. 1920 ADU) steckt sowohl im light frame als auch im flat frame, und er MUSS subtrahiert werden. Dies geschieht normalerweise einerseits beim Herstellen des MasterFlat (bei der Kalibrierung der flat frames) und anderererseits bei der Kalibrierung der light frames (durch Subtraktion des MasterDarks).

Der normale Rechenweg bei der Kalibrierung der light frames ist:

LightCal = (Light - MasterDark) / MasterFlat * mean(MasterFlat)

Das MasterFlat wird durch Kalibrierung der einzelnen flat frames mit dem MasterBias (oder MasterFlatDark) und anschließende Integration der kalibrierten flat frames zum MasterFlat erzeugt.

In Ermangelung eines MasterDarks und eines MasterBias (oder MasterFlatDarks) habe ich einfach die Konstante 1920 sowohl von Deinem lightframe als auch von Deinem MaterFlat subtrahiert und anschließend die Kalibrierung vorgenommen. Dieses Vorgehen ist natürlich nicht zur Nachahmung empfohlen. Die Flatfield-Korrektur funktioniert auf diese Weise aber problemlos.

Bernd
 

Dunkle Energie

Mitglied
Uiiiiiiiiiiiiiiiii … vielen Dank, Bernd!

Ich bilde mir zwar ein (Du merkst, daß ich noch nicht der absolute PI-Crack bin ;-) ), daß ich die Tutorials - ich habe zur Sicherheit mehrere angeschaut – Klick für Klick nachvollzogen habe, aber irgendwo habe ich wohl Mist gemacht. Eines habe ich aber festgestellt: Die jeweiligen Verfasser habe unter ImageIntegration unterschiedliche Einstellungen verwendet und sind trotzdem zum Ziel gekommen.

Jetzt wird es allerdings spannend: Ich habe natürlich brav ein Masterflat erstellt und habe dieses auch mit dem Biasmaster kalibriert. Wenn ich Dich richtig verstehe, muß mir dabei ein Fehler unterlaufen sein.

Ich habe die einzelnen Bearbeitungsschritte/Prozesse gespeichert und habe nun Screenshots davon erstellt. Wärst Du bitte so nett und würdest mal drüberschauen, ob Du den/einen Fehler findest?

Viele Grüße

Markus

1.png
2.png
3.png
4.png
5.png
 

bulrichl

Mitglied
1. Integration der bias frames zum Master Bias: OK
2. Integration der dark frames zum MasterDark: OK
3. Kalibrierung der flat frames mit dem MasterBias: OK
4. Integration der kalibrierten Flat frames zum MasterFlat: OK, falls die kalibrierten flat frames als targets ausgewählt wurden
5. Kalibrierung der light frames: OK

Das sieht also im Prinzip gut aus. Allerdings würde ich bei der ASI294MC Pro keine dark frame optimization verwenden. Schau bitte mal in den kalibrierten light frames nach, in welcher Größenordnung die dark scaling factors k0 liegen (das ist im FITS header der kalibrierten light frames dokumentiert).

Ohne dark frame optimization müsste man den Haken im Abschnitt 'Master Bias' entfernen und im Abschnitt 'Master Dark' beide Optionen 'Calibrate' und 'Optimize' abwählen.

Im Augenblick ist also für mich nicht ersichtlich, was da schief läuft. Ich bin mir aber sicher, dass die Ursache des Problems eine nicht korrekte Subtraktion des bias offsets ist.

Bernd
 

Dunkle Energie

Mitglied
Hallo, Bernd,

danke fürs Prüfen. Ich habe zu Punkt 4 sicherheitshalber noch einmal nachschaut: Ja, ich habe die kalibrierten Flats verwendet.
Weil der Fits-Header vielleicht noch mehr Anhaltspunkte liefert, habe ich auch davon einen Screenshot gemacht.
Ich habe den Eintrag bei "ImageCalibration.masterDark.scalingFactors:" stichprobenartig überprüft und bin auf Werte zwischen 0,048 und 0,077 gestoßen.

Wie erfährt man, daß der ADU-Wert für 294 bei 1920 liegt? Daß das Abziehen mittels Pixelmath erledigt wird, kann ich mir noch vorstellen, aber nicht wie das funktioniert. Tante Google wußte auch nix dazu zu sagen …
Ok, vielleicht habe ich nicht mit den richtigen Begriffen gesucht.

So, für heute reicht es. :)


Viele Grüße

Markus

Bildschirmfoto 2020-04-21 um 00.13.08.png
 

bulrichl

Mitglied
Deine dark frames passen von der Belichtungszeit (und hoffentlich auch von der Temperatur, gain- und offset-Einstellung) zu den light frames. Man sollte für die Kalibrierung der light frames also dark scaling factors in der Größenodnung von 1.0 erwarten. Dass dies nicht der Fall ist, sollte einem zu denken geben. Die ASI294MC Pro hat starkes "Verstärkerglühen". Da dieser Artefakt sich nicht linear verhält, ist es besser, für diese Kamera keine dark frame optimization zu verwenden.

Ich würde die Kalibrierung der light frames deshalb OHNE dark frame optimization wiederholen, mit den folgenden Einstellungen:

Abschnitt 'Master Bias' deaktivieren,
Abschnitt 'Master Dark' aktivieren, MasterDark selektieren, beide Optionen 'Calibrate' und 'Optimize' deaktivieren,
Abschnitt 'Master Flat' aktivieren, MasterFlat selektieren , Option 'Calibrate' deaktivieren.

Bernd
 

Dunkle Energie

Mitglied
Hallo, Bernd,

ja, die Darks habe ich mit den gleichen Parametern gemacht wie die Lightframes. Ich mache heute abend mal einen Test mit den von Dir genannten Einstellungen. Immerhin verstehe ich immer besser, was da passiert.

Vielen Dank für Deine Hilfe!

Markus
 

Dunkle Energie

Mitglied
Ganz vergessen: Ich hab das Bild nach dem Kalibrieren in RGB zerlegt und die Kanäle mit LiearFit (auf B bezogen) angeglichen. Wegen des Farbstichs des Leuchttischs war der Rotkanal nämlich überrepräsentiert. :)
 

bulrichl

Mitglied
Ja, so in etwa kann das aussehen. Jedenfalls weist das neue Ergebnis keine Überkorrektur durch das MasterFlat auf.

Man sieht aber auch, dass noch ein kräftiger Gradient von der rechten unteren Ecke (dunkel) zur linken oberen Ecke (hell) vorhanden ist. Dieser Gradient hat aber nichts mit Vignettierung zu tun, sondern kann z. B. durch Mondlicht, Lichtverschmutzung oder dünne durchziehende Wolken verursacht sein. Solche Gradienten können mit PixInsights BackgroundModelization Prozessen (ABE oder DBE) vom Summenbild entfernt werden.

Der normale workflow sieht folgendermaßen aus: Nach der Integration (bzw. besser: nach DrizzleIntegration, damit Interpolations-Artefakte durch Debayern vermieden werden) sollte man die Ränder beschneiden, wenn man gedithert hat. Dann wendet man PhotometricColorCalibration und anschließend BackgroundModelization an (oder in umgekehrter Reihenfolge - das ist egal). Den LinearFit Prozess braucht man nicht im workflow. Bei einfachen Gradienten hat sich bei mir bewährt, ABE einmal mit Function degree 1 und danach mit Function degree 4 anzuwenden. Es gibt aber auch komplizierte Gradienten, denen vermutlich nur mit DBE beizukommen ist.

Was war denn nun die Ursache der anfänglichen Überkorrektur?

Bernd
 

Dunkle Energie

Mitglied
Hallo, Bernd,

die Ursache waren die falschen Einstellungen im Kalibrierdialog. Wie ich oben schon geschrieben habe, hatte ich mir (unwissentlich) schon einmal die richtige Variante zurechtgeklickt,
dachte aber, es müsse besser gehen und habe daher einen Vorschlag aus einem Tutorial übernommen, welches auch die Bearbeitung von OSC-Daten zum Inhalt hatte (allerdings die einer DSLR).
Wie dem auch sei: Ich werde mir die Prozesse, die sich hinter Deiner Empfehlung verbergen, ebenfalls sehr gründlich anschauen und die Allgemeinheit erst wieder nerven, wenn ich mal wieder nicht weiterkomme.

Dir wird mein Dank auf jeden Fall ewig hinterherschleichen! ;-)

Viele Grüße

Markus

Übrigens:Mein M106-Bild habe ich mit dem gleichen, neulich noch selbst erdachten Ablauf kalibriert und dort bereits erfolgreich die ABE angewandt. Immerhin. :)
 
Zuletzt bearbeitet:

GanymedRN

Mitglied
Ein kleiner Tipp: WBPP WeightedBatchPreProcessing nimmt dir die Einzelschritte des Preproccesing komplett ab. Das ist ein neues Script für PI.
Es bewertet die Qualität der Einzelbilder und gewichtet diese im Stack.
Man gibt ihm die Lights, Flats, Darks und Bias Bilder und startet das Ganze. Nach einer Weile kommt dann das Resultat.
Ich habe das PreProcessing bisher auch immer separat gemacht aber mit WBPP sind die Ergebnisse gleich gut oder besser.
 

Dunkle Energie

Mitglied
Hallo, Roger,

danke für den Tip, das probiere ich gerne mal aus. Ich finde es aber trotzdem sinnvoll, wenn man halbwegs weiß, was passiert. :)

Viele Grüße

Markus
 

zwent

Mitglied
Kommando zurück! in WBPP im Tab Flats gibt es die Checkbox "Calibrate Flats with flat darks". Also nimmt PI vermutlich die Darks die zur Belichtungszeit der Flats passen. Tip-Top!
 
Das Homepagetool mit der aktuellen Mondphase u.v.m.

(Alle Angaben für 10 Grad ö.L. Länge / 50 Grad n.B.)

In Kooperation mit www.Der-Mond.org Hole Dir jetzt das kostenlose Mondtool für Deine Homepage

Oben