Motorfokus DIY | Astronomie.de - Der Treffpunkt für Astronomie

Motorfokus DIY

Kusifu

Mitglied
Nabend liebe Freunde des Eigenbaus,

da ich aktuell noch auf meinen Canon EOS Adapter und meine 50mm Verlängerung warte, dachte ich mir ich könnte die Wartezeit nutzen mein erstes richtiges Eigenbauprojekt mit meinem Bruder zu realisieren.
Das Projekt: Ein Motorfokus.
Wir wollten mit einem Winkel einen Schritmotor (17HS4401) am Okularauszug befestigen und mit Hilfe eines Zahnriemens den Fokus steuern. Erstes Problem war, dass der Riemen nicht auf das Zahnrad passte. Deshalb wollten wir ein Stück Riemen mit Heißkleber um das Zahnrad kleben.
Den Winkel haben wir testweise aus Pappe gebaut.
Weitere Bauteile sind ein Treiber für den Motor (DRV8825 mit Board), ESP12E oder Arduino und eine DC/DC Spannungswandler. Wir haben beim hiesigen Baumarkt einen Winkel gekauft und ein weiteres Loch gebohrt.
Als nächstes programieren wir den Arduino, und schneiden und kleben den Riemen.
Wir glauben inzwischen, dass wir kein Stück Riemen an den goldenen Fokusring kleben müssen. Das Band rutscht eng angelegt nicht, obwohl Ring und Riemen unterschiedliche Zahnabstände haben.
Der TS-Optics Motorfokus hat ein passendes Zahnrad und Riemen. Wisst ihr ob man diese einzeln kaufen kann. Der Schaft des Schrittmotors hat 5mm Durchmesser.

Clear Skies,
Felix
 

Anhänge

zwent

Mitglied
Hi Felix,

schönes Projekt! Passende Riemenscheiben finden sich in allen möglichen Durchmessern. Dazu kauft Ihr passend den Riemen und fertig. Aufpassen müsst Ihr nur auf kompatible Profile.

Habt Ihr die Software selbst geschrieben? Wie schaut's mit Treibern für ASCOM oder INDI aus?

Viele Grüße
Sven
 

Kusifu

Mitglied
Hey Sven, könntest du vielleicht einen Link Posten zu einer Passenden Zahnriemen Scheibe+Riemen wir finden da nichts. Immer nur die gleichen Zahn-Abstände. Als wären, diese standartisiert. Ja die Software schreiben wir selbst. Clear Skies Felix.
 

zwent

Mitglied
Hallo Felix,

die Profiie sind tatsächlich standardisiert. GT2 findet sich häufig, weil z.B. in 3D-Druckern verwendet. Besorgt euch doch noch eine Riemenenscheibe für die Welle des Auszugs.. der sollte auch 5mm haben.

Viele Grüße
Sven
 

astro_alex80

Mitglied
Hallo Felix,

sehr schönes Projekt.

Habt ihr mal ausgerechnet, um wieviel mm sich der Fokusser pro Schritt des Steppers bewegt, also wie hoch die Auflösung ist? Falls noch nicht, die Auflösung sollte min. 1/3 besser 1/5 oder 1/6 der kritischen Fokuszone der Teleskop/Kamera Kombi sein, was bei den gängigsten Teleskopen einen Wert um 0,01 mm ergibt. Das damit man sicher den Fokus trifft und nicht ständig drüber hinaus fährt.

Falls ihr eine ASCOM Anbindung implementieren wollt, kann ich euch das Robofokus Protokoll empfehlen. Schon älter, aber sehr einfach umzusetzen und relativ gut dokumentiert, einfach mal danach suchen, Kommunikation via Serial. Wahrscheinlich gibt’s in der Zwischenzeit schon neuere/bessere Protokolle, häufig haperte aber leider an der Dokumentation der Befehle.

Wollt ihr dem Arduino noch einen Temp Sensor spendieren ?

Viele Grüße,
Alex
 
Zuletzt bearbeitet:

zwent

Mitglied
Hallo zusammen,

generell ist die Dokumentation zu MyFocuserPro2 immer eine Lektüre wert, auch wenn man deren Implementierungen nicht nutzt. Da steht eigentlich alles drin, was man zum Thema wissen muss.



Viele Grüße
Sven
 

Kusifu

Mitglied
Hallo Astro-Freunde, danke für euer bisheriges Interesse an unserem Projekt. Die Zahnriemen und Riehmenscheiben scheinen standartisiert zu sein zbsp. GT2 die haben wir oder GT3. Weis einer von euch in welche Kategorie der goldene Ring an der Untersetzung fällt. Damit wir diese Riemen, Scheibe Dan einfach bestellen können und Dan fertig. Uns fehlen noch einzelne Komponenten weshalb wir aktuell auf diese warten und erstmal nicht weiter machen können. Eine Welle am Zahnrad befestigen oder so ähnlich möchten wir nicht. Wir möchten das mithilfe eines Riemen, welchen wir über den für Motorfokuse vorgesehenen Ring legen ermöglichen. Der Schriftwinkel des Motors beträgt 1,8 Grad, also 0,005 Schritte Clear Skies Felix
 

Anhänge

zwent

Mitglied
Ich vermute, der fällt in keine. Da müsstet ihr ausprobieren was einigermaßen passt. Der meiner Meinung nach richtige Weg ist aber, den Knopf auf der anderen Seite, also den ohne 1:10 Untersetzung, abzunehmen (der ist mit einer Madenschraube gesichert) und durch ein passendes Riemenrad zu ersetzen. Auf der Untersetzung würde ich den Fokusmotor auf keinen Fall laufen lassen.

Viele Grüße
Sven
 

Kusifu

Mitglied
Hey Zwent,
Hier hat es scheibar geklappt.
Kennt jemand anderes der möglicherweise meinen Okularauszug besitzt das passende?
Ansonsten werden wir es mit dem Riemen den wir haben probieren, wenn dieser eng genug anliegt funktioniert es nämlich.
Clear Skies
Felix
 

Jens_Lange

Mitglied
Hallo Felix,
ich habe vor längerer Zeit auch mal einen Baader Steeltrack mit passendem Zahnriemen motorisiert. Muss ich aber in der Sternwarte nachschauen, welche Maße das waren. Auf jeden Fall gibt es passende Zahnriemen.
Viele Grüße Jens
 

Optikus

Mitglied
Wenn sich die Teile an die Üblichkeiten halten sind es normale Zahnriemen Modul 0,8. Die sind auch in der Filmtechnik für Follow-Focus gebräuchlich. Man kriegt dazu für Fotoobjektive auch Zahnkränze.

CS
Jörg
 

Kusifu

Mitglied
Hey,
danke für die Antwort. Hab ich mir doch gedacht wäre das ein passendes Zahnrad was denkt ihr
Clear skies Felix
 

Optikus

Mitglied
Moin,

wenn es nicht so schmal wär. Es gibt auch Zahnriemenräder, die haben seitliche Flansche. Modul müsste stimmen (also Zahngröße).

CS
Jörg
 

Jens_Lange

Mitglied
Ich habe noch mal nachgeschaut, ich habe am Steeltrack einen Zahnriemen Profil 3M (das sind 3mm, halbrund). Bei Zahnriemen wird anders als bei Zahnrädern kein Modul angegeben, sondern der Zahnabstand. Dazu gibt es verschiedene Profile (Halbrund, Trapez, ...), wobei das bei den geringen Kräften am Fokusantrieb nicht ganz so wichtig ist.

Viele Grüße Jens
 

Kusifu

Mitglied
Jens,
3M scheint, doch nicht richtig zu sein.
Ich hab nach dem hier gezeigten gemessen. und brauch scheinbar 4m die Zahnriemen welche ich bereits besitze haben 3m. Die Frage ist dan noch ist das 0,8 Modul (Zahnrad), das richtige oder brauche ich auch da ein anderes.
Welches Zahnrad brauch ich bei 4mm Zahnabstand nach dem obig gezeigten gerne Verlinken. Gut das ich noch nichts bestellt habe
Clear Skies
Felix
 

Jens_Lange

Mitglied
Hallo Felix,
wie schon oben geschrieben, wird für Zahnriemenantriebe keine Modul angegeben, sondern es gibt andere Maßbezeichnungen (s. angehängte Datei). Es wird immer die Typbezeichnung und die Anzahl der Zähne angegeben. Du brauchst also kein Zahnrad mit dem Modul x, sondern eine Zahnriemenscheibe vom Typ "x".Bei manchen Anbietern (z.B. Conrad) muss man genau aufpassen, da sie alle möglichen Maße angeben, aber oft nich die exakte Typbezeichnung dazu. Suche mal unter "Zahnriemen Teilung", da wirst Du genügend Angeben finden.
Vielleicht hat Bader die Riemenscheibe am Steeltrack geändert, bei meinem (ältere Bauart) passt jedenfalls ein Typ 3M.
Viele Grüße
Jens
 

Anhänge

Kusifu

Mitglied
N'abend zusammen,
wir haben in den letzten Tagen große Fortschritte gemacht und möchten euch auf dem Laufenden halten.
Wir haben testweise erstmal alles auf dem Breadbord alles zusammen gesteckt und es angefangen zu programieren.
Der ESP 12-E auf der weißen PCB auf dem oberen Bild ist uns versehentlich abgeraucht. Wir benutzen aktuell einen ESP auf einer NodeMCU PCB. Zunächst haben wir es mit Erfolg getestet. Am nächsten Tag funktionierte es nicht mehr.
Die Fehlersuche hat lange gedauert, da unser Treiber kapput war aber unsere ersatz Treiber falsch eingestellt waren.
Um einen Wackelkontakt auszuschliesen haben wir angefangen zu löten. Erstmal nur den ESP plus Treiber. An dieser Stelle haben wir das Problem mit den Treibern gefunden und gelöst.
Der ESP verbindet sich mit unserem WLAN, stellt eine Website bereit und hört auf einem Websocket auf Befehle.
Wir haben das Board dann noch um einen Spannungswandler (LD1117V33), einen Lüfter und Jumper Pins erweitert. Der Spannungswandler erzeugt 3,3 Volt aus den 12 Volt, so brauchen wir nur ein Kabel zur Sromversorgung. Wir haben festgestellt das sowohl der Treiber, als auch der Spannungswandler heiß werden. Deshalb haben wir einen Lüfter eingebaut.
Als wir es die ersten Male getestet haben war der Motor extrem laut und hat viele Vibrationen erzeugt. Da der Motor mit einem Winkel befestigt ist, gehen alle Vibrationen auf den Tubus über. Wir glauben, dass der Motor (17HS4401) überdeminsioniert ist. Wir haben Jumper Pins eingebaut, die die Pins M0, M1 und M2 auf high ziehen. So läuft der Treiber 1/32 Step Mode. Dadurch vibriert er kaum noch und ist sehr viel leiser.
Wenn wir die Riemen eng anlegen, rutschen sie nicht. Deswegen haben wir keine mit passendem Zahnabstand gekauft. Bei unserem ersten Versuch ist die Klebestelle des Riemens unter Spannung langsam auseinandergerissen. Wir haben nochmal neu geklebt und warten aktuell, dass der Kleber trocknet.

Clear Skies,
Felix
 

Anhänge

Kusifu

Mitglied
Hey Freunde,
Wir sind jetz soweit fertig.
Haben das passende Zahnrad/Scheibe heute bekommen und eingebaut funktioniert jetzt wie geschnitten Brot. Haben, das Board jetzt erstmal in einer Pappschachtel an den Telradsucher/Prismenschiene angeklebt.
Ich schau das ich nen kleinen leichten Holzkasten Baue und diesen an die Priesmenschiene Schraube, sieht aktuell nicht so toll aus aber das ist ein Luxusproblem. ^^

Clear Skies
Felix
 

Anhänge

Kusifu

Mitglied
Nabend Freunde,
Ich verlinke hier ein Video des Ergebnisses
(unterschiedliche Anzahl der Steps 1-100.000 er kan natürlich auch durchgehend fahren)
auf meinem Youtube Kanal.
Clear Skies
Felix
 

Kusifu

Mitglied
Hey Baubegeisterte Irgendwie ist, das nur noch ein Monolog.
Dennoch Bring ich das Thema zuende.

Wir haben jetzt eine holzbox für das Board angefertigt.
So hat es keinen Kontakt zum Metall.
Heute haben wir diese Box mit einem zweiten Winkel befestigt. Es funktioniert alles ziemlich gut.
Heute ist auch endlich der Adapter für meine Aufnahme Kamera angekommen.

Clear Skies
Felix
 

Anhänge

maximilian

Mitglied
Hallo!

bin aktuell nur Mitleser, sieht auf jeden Fall gut aus.
Ja, ein Superprojekt. Vor allem wenn man schaut, was für Mondpreise für gekaufte Motorfokussierer verlangt werden.

Als jahrelanger Arduino-Bastler habe ich natürlich ein paar Anmerkungen:

1. Wie Ihr selbst schon festgestellt habt, ist der Schrittmotor für diese Anwendung ungefähr um den Faktor 5 überdimensioniert. Da könnte man über einen kleineren nachdenken.
2. Den Lüfter braucht Ihr nicht. Der Motor läuft doch nur sekundenweise. Und selbst wenn er dauernd laufen würde, wie die jeweils vier Schrittmotoren in meinen zwei 3D Druckern, bräuchte man noch keinen. Der bringt nur Euer ganzes Teleskop zum Vibrieren und nervt mit seinem Geräusch.
3. Man könnte drüber nachdenken, die Box mit der Elektronik irgendwo am Stativ zu befestigen und nur das Kabel für den Motor beweglich anzuschliessen. So ist das nur totes Gewicht für die Montierung plus Vibration vom Lüfter.
4. Mich persönlich würde die Bedierung per Smartphone nerven. Da läuft bei mir nämlich schon SkySafari für die Steuerung der Montierung drauf und ich müsste dauernd zwischen zwei Apps wechseln. Mein Motorfokus (nicht selbstgemacht, sonder günstig beim eBay gefunden) hat eine kleine Steuerbox mit zwei Knöpfen (vor und zurück) und einem Potentiometer für die Geschwindigkeit, was für die Feineinstellung sehr praktisch ist. Sowas liesse sich bei Euch auch leicht anschliessen, der Microcontroller hat noch genug freie Beinchen. Es liesse sich auch parallel zur Handysteuerung verwenden.

Grüße
Maximilian
 

Kusifu

Mitglied
Hey Maximillian,

Zu 1. Den Motor besaßen wir bereits. Wiso extra Geld ausgeben in Zukunft vielleicht. Zu 2. Den Lüfter brauchen wir schon ohne wird die Plantine nämlich echt heiß die Vibrationen verschwinden komplett bei Feineistellungen. Ganz schwache sind noch da, wenn er mit voller geschwindigkeit läuft. Wenn das Teleskop draußen Steht hör ich kein Geräusch ansonsten ist es leise genug um nicht zu stören. Zu 3. Nette Idee aber Bisher ist Gewicht nicht mein Problem das Ganze (abgesehen vom Motor) wiegt eh nix vielleicht 40g. Zu 4. Das ganze läuft momentan über unser WLAN Ich kann es, also auch über meinen Computer steuern. Meine Montierung Steuer ich auch über meinen Computer.

Clear Skies
Felix
 

maximilian

Mitglied
Hallo!

Den Lüfter brauchen wir schon ohne wird die Plantine nämlich echt heiß
Wenn da was heiß wird stimmt irgendetwas nicht. Welche Platine wird heiß? Der NodeMCU wird normalerweise gar nicht warm. Und das kleine Schrittmotortreiberchen („Polulu“) mit dem aufgeklebten Kühlkörperchen verträgt es schon ein bisschen warm. Wie gesagt, beim 3D Drucker sitzen davon vier nebeneinander auf einer Platine und die Schrittmotoren laufen 10, 11, 12 Stunden pausenlos. Ganz ohne Lüfter! Die Schrittmotoren in meiner iOptron-Montierung (iEQ45) sind änlich groß und der für die Stundenachse läuft auch die ganze Nacht ohne Lüfter.

Zu 1. Den Motor besaßen wir bereits. Wiso extra Geld ausgeben in Zukunft vielleicht.
Manchmal sind 3 Euro (mehr kostet der passende Motor bei eBay nicht) richtig gut investiertes Geld :)

Grüße
Maximilian
 
Das Homepagetool mit der aktuellen Mondphase u.v.m.

(Alle Angaben für 10 Grad ö.L. Länge / 50 Grad n.B.)

In Kooperation mit www.Der-Mond.org Hole Dir jetzt das kostenlose Mondtool für Deine Homepage

Oben