Pixinsight: Problem beim Stacken mit dem Batch Preprocessing Skript PBB | Astronomie.de - Der Treffpunkt für Astronomie

Pixinsight: Problem beim Stacken mit dem Batch Preprocessing Skript PBB

Recoxx

Mitglied
Hallo erstmal (o:

leider habe ich das folgende Problem bei meiner Bildbearbeitung Pixinsight:
Ich habe 66 Lights, 41 Darks je 120 s und 51 Flats von M101 gemacht (als Masterbias benutze ich ein Bias welches aus 101 Bias erstellt wurde) und wollte diese jetzt mit den Batch Preprocessing Skript stacken, wie ich es schon viele Male mit anderen Bildern ohne Probleme gemacht habe. Aber jetzt bekomme die die auf den Bildern zu sehenden Fehlermeldungen. Mal bei einem Bild mal bei einem anderen Bild.
Ich habe noch ein paar Bilder mit meinen Einstellungen vom BPP ran gehangen.
Zum Einsatz kam das unten angegebene Equipment.
Ich hoffe, dass ihr mir weiterhelfen könnt.

CS
Andreas
 

Anhänge

  • BPP-PixInsight.png
    BPP-PixInsight.png
    69,6 KB · Aufrufe: 174
  • BPP-PixInsight2.png
    BPP-PixInsight2.png
    70,1 KB · Aufrufe: 189
  • BPP-PixInsight3.png
    BPP-PixInsight3.png
    66,6 KB · Aufrufe: 200
  • Fehlermeldung-PixInsight.png
    Fehlermeldung-PixInsight.png
    57,8 KB · Aufrufe: 198
  • Fehlermeldung-PixInsight2.png
    Fehlermeldung-PixInsight2.png
    63,3 KB · Aufrufe: 200

astro_alex80

Mitglied
Hallo Andreas,

die kalibrierten und registrierten Lights werden doch vom Script in einem separaten Ordner abgelegt. Schau sie da doch mal durch, ob beim Kalibrieren was schief ging.

Ansonsten kannst du sie ja auch via ImageIntegration stacken. Behebt zwar nicht die Ursache, hält aber erstmal deine weitere Bearbeitung nicht auf.

Grüße,
Alex
 

bulrichl

Mitglied
Hallo Andreas,

die Fehlermeldung "Zero or insignificant signal detected (empty image?)" weist in der Regel auf ein Problem bei der Kalibrierung der light frames hin. Diese Fehlermeldung ist aber sehr unspezifisch. Entweder ist das ein grundsätzliches Problem bei der Kalibrierung (z. B. falsche Einstellungen oder nicht passende Kalibrierungsaufnahmen) oder ein Problem einzelner light frames. Letzteres ist in Deinem Falle wahrscheinlicher, da das Problem nur bei einigen wenigen light frames auftritt. Vermutlich ist bei der Aufnahme dieser Bilder etwas schief gegangen. Ich würde die kalibrierten light frames im Blink-Prozess anschauen und auffällige Bilder im Histogramm bei hohem horizontalem Zoom (z. B. 100) auf Clipping untersuchen.

Das BPP-Skript hat übrigens einen Nachfplger: WBPP (Weighted Batch Preprocessing). In der nächsten Version wird es kein BPP mehr geben. WBPP hat aussagekräftigere Warn- und Fehlermeldungen. Ob WBPP in Deinem Falle bei der Fehlereingrenzung weiterhelfen könnte, ist aber nicht sicher.

Bernd
 

Recoxx

Mitglied
Hallo Bernd und Alex,
danke für eure Antworten. Ich werde mir jetzt erstmal die Bilder ansehen.
CS
Andreas
 

Recoxx

Mitglied
Also, ich habe jetzt die Sachen befolgt, die ihr geschrieben habt. Und ich habe auch ein Bild gefunden, welches doch sehr komisch aussah. Ich habe es entfernt, aber es geht nicht.
Ich habe auch mit dem neuen WBPP alles versucht, aber ich bekomme wieder die folgenden Fehlermeldungen (siehe Bilder). Und auch die folgende Warnung:

** Warning: Flat frames (filter = NoFilter, binning = 1, exposure = 0.01s, length = 53) will be calibrated with an OPTIMIZED master dark with a different exposure of 120 sec.

Diese Warnung verstehe ich nicht. Es ist doch ganz normal, dass die Flats nicht mit der gleichen Belichtungszeit, wie die Darks aufgenommen werden. Weiß da wer was?

Jetzt habe ich noch eine Frage: Ich würde gern die Funktion "Subframe Weighting" von WBPP benutzen. Ist sie gut? Ich habe sie, wie mit Bild WBPP zu sehen bewertet. Ist das so richtig? Unter "Weighting parameters..." habe ich Galaxie ausgewählt, da ich ja eine Galaxie (M101) aufgenommen habe. Das passt so oder muss ich noch was machen?

Ich habe auch mit den ersten 20 Lights, Darks und Flats den BPP und WBPP gemacht, um nur mal zu sehen, ob da was geht, aber ich bekomme immer Fehlermeldungen.

Hat da noch jemand eine Idee?

CS
Andreas
 

Anhänge

  • Fehlermeldung WBPP.png
    Fehlermeldung WBPP.png
    71,4 KB · Aufrufe: 174
  • Fehlermeldung WBPP2.png
    Fehlermeldung WBPP2.png
    77,2 KB · Aufrufe: 156
  • WBPP.png
    WBPP.png
    5,7 KB · Aufrufe: 152

zwent

Mitglied
Hi Andreas,

er möchte die Flats kalibrieren, dafür benötig er Darks mit der gleichen Belichtungszeit (FlatDarks) oder Bias Frames. Hast Du im Flats Tab von WBPP Calibrate with dark flats ausgegwählt?

Viele Grüße
Sven
 

zwent

Mitglied
Nachtrag:

Das ist aber gar nicht Dein Problem. Der Konsole nach stimmt immer noch mit etwas mit Deinen Lights nicht..

Viele Grüße
Sven
 

Recoxx

Mitglied
Hallo Sven,

nicht leider ist das nicht der Fehler, wie du auf dem Bild sehen kannst.

Die Warnung kommt immer wieder:

** Warning: Flat frames (filter = NoFilter, binning = 1, exposure = 0.01s, length = 53) will be calibrated with an OPTIMIZED master dark with a different exposure of 120 sec.
 

Anhänge

  • WBPP_flats.png
    WBPP_flats.png
    71,7 KB · Aufrufe: 149

Okke_Dillen

Mitglied
Moin,

hmm, was mir auffällt, wozu hast du das Häkchen bei "use bottom-up fits" gesetzt, du verwendest doch *.cr2 und nicht *.fits?
Vielleicht....

Gruß
Okke
 

Recoxx

Mitglied
Das war schon gesetzt und dürfte hier doch keine Rolle spielen, oder? Er soll doch "nur" das erste Pixel im Bild festlegen, oder?
 

Recoxx

Mitglied
Siehe Bilder und ja sie gehören dazu (es sind mehrere Bilder anscheint).
 

Anhänge

  • Fehlermeldung-PixInsight.png
    Fehlermeldung-PixInsight.png
    57,8 KB · Aufrufe: 161
  • Fehlermeldung-PixInsight2.png
    Fehlermeldung-PixInsight2.png
    63,3 KB · Aufrufe: 153

Recoxx

Mitglied
Wie meinst du das? Ich habe mir die Bilder angesehen und sie sehen, wie alle andern aus. Woran erkennt man, dass es "falsche Bilder" sind?
 

zwent

Mitglied
Ich meine die, die Du gepostet hast. Aufgrund der Fehlermeldung und ohne die tatsächlichen Frames können wir nur raten.

Also die Bidler die in der Fehlermeldung angegeben sidn, sehen so aus wie alle anderen? Selbe Orientierung, keine Wolken, Sterne sind sichtbar? hast Du die mal in Blink durchgeschaut? Ohne Anpassen der STF?

Ansonsten: einmal den Vorgang manuell durchkauen. Spar' die erstmal die Kalibrierung mit Flats und Darks. Also nur:

1. Star Alignment
2. Image Integration

auf die Lighs. Die Batch-Skripe haben manchmal (unter gewissen Umständen) Probleme und produzieren seltsame Ergebnisse und Fehlermeldungen.

Viele Grüße
Sven
 

Recoxx

Mitglied
Hier die drei Bilder. Das Bild 55 (links) ist das Referenzbild und die Bilder 56 und 67 werden als "Fehler" gemeldet. Beim Blinken sehen sie fast gleich aus. Sie schwanken nur sehr wenig in der Helligkeit.
 

Anhänge

  • 3 bilder.png
    3 bilder.png
    2 MB · Aufrufe: 187

echni

Mitglied
Hallo Andreas,

dieses Problem hatte ich auch schon mal. Da bleibt dir nichts anderes übrig, als die Bilder welche die Meldung verursachen, rauszuwerfen.
Bei mir sahen die beanstandeten Bilder auch nach einem STF vollkommen in Ordnung aus. Aber irgendwie wurden diese, sowohl im Script als auch im Prozess nicht richtig erkannt.
Also weg damit.
Weshalb hast du eigentlich "Optimize dark Frames" angehakt? Bringt m.E. nichts.

CS
Dieter
 

echni

Mitglied
...noch ein Nachtrag: habe auch versucht das in DSS, mit den PI beanstandeten Bildern, durchlaufen zu lassen. DSS brach zwar nicht ab, aber das Ergebnis sah dann doch sehr seltsam aus.

CS
Dieter
 

bulrichl

Mitglied
Hallo Andreas,

ei ei, viele Beiträge und immer noch keine Lösung?

Das primäre Problem ist offenbar die Subtraktion des MasterDark von den light frames, das sekundäre, dass WBPP die flat frames mit dem skalierten 120-s-MasterDark kalibriert (das MasterBias sollte stattdessen verwendet werden).

Hast Du denn mal, wie ich vorgeschlagen hatte, die kalibrierten light frames, die zu den Fehlermeldungen führen, im Histogramm bei hohem horizontalem Zoom (z. B. 100) auf Clipping untersucht? Ich würde gerne mal solch ein Histogramm sehen!

Das zweite Problem sollte verschwinden, wenn Du 'Calibrate with flat darks' aktivierst. In Deinem Fall (in der Abteilung 'Darks' werden keine passenden flat darks gefunden) sollte WBPP dann das MasterBias zur Kalibrierung der flat frames verwenden und eine entsprechende Warnung ausgeben. Das ist dann OK.

Bernd
 

Recoxx

Mitglied
Hallo Dieter und Bernd,

erstmal sorry für die späte Antwort.
Ich habe in der Zwischenzeit versuch über das Forum von PI meine Probleme zu lösen, aber bis jetzt wurde alles leider nur noch schlimmer. ))o:
@ Dieter:
Weshalb hast du eigentlich "Optimize dark Frames" angehakt? Bringt m.E. nichts.
Ich habe gehört, dass damit die unterschiedlich warmen Dark von PI "ausgeglichen" werden, somit soll das "richtig" Dunkelstromrauschen von den Lights abgezogen werden. Warum denkst du, dass das nichts bringt?

@ Bernd:
Ich denke mal, dass du der Bern bist, der mir auch schon im Forum von PI helfen will. Was leider noch nicht wirklich geklappt hat.
Jetzt zu deinen Anregungen:
Hast Du denn mal, wie ich vorgeschlagen hatte, die kalibrierten light frames, die zu den Fehlermeldungen führen, im Histogramm bei hohem horizontalem Zoom (z. B. 100) auf Clipping untersucht? Ich würde gerne mal solch ein Histogramm sehen!
Nein, dass habe ich noch nicht gemacht. Ich muss jetzt ja erst wieder mein PI hinbekommen. Du weißt ja, worum es geht. Ich habe jetzt, wie von dir vorgeschlagen, bei Juan angefragt.

Jetzt zum zweitem, was du geschrieben hast:
Das zweite Problem sollte verschwinden, wenn Du 'Calibrate with flat darks' aktivierst. In Deinem Fall (in der Abteilung 'Darks' werden keine passenden flat darks gefunden) sollte WBPP dann das MasterBias zur Kalibrierung der flat frames verwenden und eine entsprechende Warnung ausgeben. Das ist dann OK.
Ich denke, dass ich das verstanden habe, was zu machen ist, aber ich würde gern nochmal nachfragen.
1. Also wenn ich "Calibrate with flat darks" ankreuze, dann muss ich die Flat Darks im Ordner Darks "hinterlegen", also habe die dann in diesem Ordner die Darks und die Flat Darks und PI kann diese Dateien auseinanderhalten. Habe ich das richtig verstanden? Die Bais kommen in den "Bais-Ordner" ganz normal?

2. Und auch die Frage an dich: Ich habe gehört, dass mit "Optimize dark Frames" die unterschiedlich warmen Dark von PI "ausgeglichen" werden, somit soll das "richtig" Dunkelstromrauschen von den Lights abgezogen werden. Ist dem so?

CS
Andreas
 

bulrichl

Mitglied
@ Bernd:
Ich denke mal, dass du der Bern bist, der mir auch schon im Forum von PI helfen will. Was leider noch nicht wirklich geklappt hat.
Ja, der bin ich.

Jetzt zum zweitem, was du geschrieben hast:
Ich denke, dass ich das verstanden habe, was zu machen ist, aber ich würde gern nochmal nachfragen.
1. Also wenn ich "Calibrate with flat darks" ankreuze, dann muss ich die Flat Darks im Ordner Darks "hinterlegen", also habe die dann in diesem Ordner die Darks und die Flat Darks und PI kann diese Dateien auseinanderhalten. Habe ich das richtig verstanden? Die Bais kommen in den "Bais-Ordner" ganz normal?
Genau. WBPP geht noch einen Schritt weiter: wenn 'Calibrate with flat darks' angekreuzt ist, jedoch KEINE passenden flat darks im Tab 'Darks' gefunden werden, wird das MasterBias (so vorhanden) zur Kalibrierung der flat frames verwendet.

2. Und auch die Frage an dich: Ich habe gehört, dass mit "Optimize dark Frames" die unterschiedlich warmen Dark von PI "ausgeglichen" werden, somit soll das "richtig" Dunkelstromrauschen von den Lights abgezogen werden. Ist dem so?
Im Gegensatz zu der in diesem Forum öfter vertretenen Meinung gibt es durchaus Kameramodelle, bei denen die Anwendung von dark frame optimization vorteilhaft ist, meine Canon EOS 600D gehört zum Beispiel zu dieser Kategorie. Die pauschale Aussage "Bringt m.E. nichts" ist so nicht richtig. Vorteile kann man erwarten, wenn a) die Kamera kein "Verstärkerglühen" aufweist und b) die Kamera nicht geregelt kühlbar ist.

Man sollte allerdings versuchen, die dark frames bei konstanter und einigermaßen passenden Kameratemperatur aufzunehmen. Das könnte z. B. tagsüber in einem dunklen und kühlen Raum gemacht werden (Keller, Garage, manche verwenden einen Kühlschrank). Grundsätzlich bringt es überhaupt nichts, die Kamera lange zu akklimatisieren (abkühlen zu lassen), bevor man mit der Aufnahme der dark frames beginnt. Besser ist es, die Kamera aus einem wärmeren Raum zu holen und direkt die Aufnahme der dark frames direkt zu starten. Die Kamera heizt sich beim fortlaufenden Aufnehmen stark auf (Pausenzeiten bringen nichts; 5 s Pause zwischen den Aufnahmen sind mehr als ausreichend). Bei meiner 600D war die Temperaturdifferenz zwischen Außen- und Kameratemperatur (im Temperatur-Gleichgewicht) 14 grd! Wenn die Kamera bei Beginn kalt ist, dauert es daher nur viel länger, bis das Temperatur-Gleichgeicht erreicht ist. Die Kameratemperatur kann man sich hinterher in den Exif-Daten anschauen. Es ist sinnvoll, die ersten dark frames (bei denen das Temperatur-Gleichgeicht noch nicht erreicht ist) zu verwerfen. Das MasterDark wird dann nur aus dark frames mit sehr ähnlicher Kameratemperatur erzeugt. Bei diesem Vorgehen gleicht dark frame optimization die unterschiedlichen Temperaturen zwischen der Aufnahme der einzelnen light frames und der des MasterDarks aus. Bei meiner 600D ergab das ein besseres Kalibrierungsergebnis als ohne dark frame optimization. Es ist sinnvoll, ein MasterDark mit gleicher oder etwas höherer Kameratemperatur als die höchste Kameratemperatur bei der Aufnahme der light frames zu verwenden.

Bernd
 

echni

Mitglied
Hallo Andreas,

die Flatdarks gehören in den Container "Bias".
Habe das auch schon mal ausprobiert, dass ich die Flatdarks in einen Container mit den Darks geworfen habe. PI kann das aber nicht auseinanderhalten!
Also Flatdarks in Bias, Darks in Dark usw. Ein gesondertes Bias benötigst du nicht, da ja im Dark das Bias schon vorhanden ist und bei der Kalibration im Script dann auch entsprechend berücksichtigt wird.
Hat bei mir auch etwas gedauert, bis ich das kapiert hatte.

CS
Dieter
 

echni

Mitglied
Hallo Bernd,

ich bezog mich auf das "normale" BPP-Script. Ist mir irgendiwe nicht aufgefallen, dass hier von WBPP die Rede ist.

Gruß
Dieter
 

Recoxx

Mitglied
Hallo Bernd,

erstmal wieder ein Dank für deine ausführlich Antwort. Das mit der Dark-Erstellung werde ich mal machen (müssen), denn wenn ich jetzt alles richtig verstanden habe, muss ich jetzt all meine vorhandenen Master-Bias, -Darks und -Flats neu erstellen oder? Siehe folgende Ansätze!

Ich habe jetzt von Juan eine Antwort bekommen und alles gemacht, was er geschrieben hat. Jetzt funktioniert mein PI wieder. ((o:
Jetzt fällt es mir schwer anzufangen, denn ich bin jetzt doch sehr verunsichert, was jetzt im einzelnen die Fehler waren, denn zu all den Sachen, die ich hier schon aufgeschrieben habe, habe ich auch noch an Juan die Frage gestellt, warum ich aus 200 Biases kein Masterbias erstellen kann.
Er hat mir geantwortet, dass ich die einzelnen Biases in das PI-Format umwandeln muss, da mein Laptop mit dem CR2-Canon-Format zu große "Dateien" erstellt, die es nicht verarbeiten kann, aber mit dem PI-Format können diese "gestückelt" werden und daher gibt es keine Probleme mehr. Und das stimmt, denn ich habe die 200 Biases ins PI-Format konvertiert und ein Masterbbias erzeugt. Es hat auf anhieb geklappt!

Also jetzt wieder zurück zu den o. g. Fehlern.
Ich weis jetzt gar nicht mehr, wann ich welche Dateien in welchem Format verwende kann, denn Juan hat auch noch geschrieben, das wohl die Höhe und Breite unterschiedlich ist. Wo und wie auch immer. Ich verstehe nicht wo und wie ich das Format geändert haben soll. Wahrscheinlich änder PI das Format und mein altes Master-Bias passt nicht mehr, aber das ist nur eine Vermutung. Ich bin verwirrt!
Daher jetzt meine Frage:
Wenn ich jetzt alle meine Dateien (Lights, Darks, Flats und Biases) immer zuerst ins PI-Format umwandle und alle meine Master-Bilder neu erzeuge und dann erst mit der PI-Bearbeitung anfange, habe ich dann keine Probleme mehr oder was muss ich machen, damit ich wieder (wie vor ca. 2 Monaten) ganz normal mit PI arbeiten kann?
Kannst da mir bitte dazu, was schreiben? Ich bin ganz schön verwirrt.

Wenn du noch Lust hast, dann kannst du mir auch noch die folgende Frage beantworten: Was ist eine SLOPE-Datei? Ich verstehe die Beschreibung von PI nicht. Denn ich habe mit dieser Datei wahrscheinlich auch Probleme, zu mindestens verstehe ich sie nicht. Sie wird wohl bei bestimmten Einstellung vom Stacking-Prozess erstellt.

So nun kann ich nur hoffen, dass du oder jemand anderes mir weiterhilft.

CS
Andreas
 

bulrichl

Mitglied
Hallo Andreas,

zuallererst solltest Du im Format Explorer einen Doppelklick auf 'RAW' ausführen, in den 'RAW Format Preferences' auf 'Pure Raw' klicken und anschließend auf 'OK'. Diese Einstellung bewirkt, dass Aufnahmen im proprietären Raw-Format (also bei Canon: CR2- oder CR3-Format) als CFA-Daten geöffnet werden, also NICHT debayert werden.

Ob Deine alten Master-Kalibrierungsdateien verwendbar sind oder nicht, hängt davon ab, ob sie mit einer PixInsight-Version 1.8.7 oder früher erzeugt wurden. Wenn das nicht der Fall ist, sollten sie funktionieren.

Da die Fehlermeldung sich auf geometrische Inkompatibilität bezieht, lassen sich die fraglichen Master-Dateien am einfachsten überprüfen, indem man sie in Pixinsight lädt und die Breite, Höhe und die Anzahl der Farbkanäle vergleicht. Die richtigen Werte sind: w=5202, h=3464, n=1.

h=3465 zeigt eine alte, nicht kompatible Master-Datei an. n=3 bedeutet, dass keine CFA-Datei, sondern eine RGB-Datei vorliegt. Die Kalibrierung soll grundsätzlich mit CFA-Dateien durchgeführt werden (debayert wird nach Kalibrierung und ggf. CosmeticCorrection, aber vor der Registrierung der Aufnahmen).

Eine vorherige Umwandlung von Aufnahmen im CR2-Format in das XISF-Format ist nur dann sinnvoll, wenn sie unmittelbar integriert werden sollen. Das heißt also: bias frames, dark frames oder flat-darks sollten umgewandelt werden, bevor man sie zu den entsprechenden Master-Dateien integriert.

Slope-Dateien werden erzeugt, wenn man beim ImageIntegration-Prozess den Pixel Rejection Algorithmus 'Linear Fit' auswählt. Slope-Dateien dienen dazu, zu überprüfen, ob die Pixel Rejection Parameter richtig eingestellt wurden.

Bernd
 

Recoxx

Mitglied
Hallo Bernd,

wirklich vielen Dank für deine klärenden Worte!!!
Ich werde jetzt erstmal alles so einstellen bzw. befolgen. Ich hoffe, dass jetzt alles wieder klappt.

CS
Andreas
 
Oben