PSS Installationsproblem | Seite 2 | Astronomie.de - Der Treffpunkt für Astronomie

PSS Installationsproblem

fpheim

Mitglied
Moin Olaf,

freut mich, dass das geklappt hat........

Übrigens: die ctrl-Taste ist am Mac die command-Taste.

Bin was die Anwendung anbelangt auch ein Neuling.
Ich abe vorgestern mal versucht den Saturn mit dem Tele zu erwischen.
Das erste Ergebniss mit PSS habe ich mal angefügt.

Ist nicht Hubble................... und der Saturn ist ja auch ziemlich weit wech.

Gruss
Fritz
 

Anhänge

  • Saturn.png
    Saturn.png
    136,5 KB · Aufrufe: 33

nordkap

Mitglied
Hallo Rolf,
und ein Hallo an alle PSS-Nutzer,

vielen herzlichen Dank für dein tollen Onlinevortrag zum PSS
und ein dickes Danke an die Veranstalter der Sternwarte Hof.

Ich benutzte schon seit geraumer Zeit den PSS 0.8.0 auf meinen Rechner mit Win10 x64.
Nun wollte ich die neue Version 0.8.15 herunterladen. Leider habe ich ein Installationsproblem
mit Python. Python ist für mich ein absolutes „Neuland“.
Installiert habe ich Python 3.6.8 und Pip 18.1, die ich auf 20.3.1 upgegradet habe (wurde in der WinPowerShell dazu aufgefordert).

Die Installation von PSS funktioniert, auch das Upgrade auf 0.8.15 klappt.
Wenn ich Jedoch das Programm „Planetarysystemstacker“ aufrufe,
kommt auf allen meiner WinRechner die folgende Fehlermeldung:
……………
…………….
Requirement already satisfied: numpy>=1.16 in c:\program files\python36\lib\site-packages (from astropy->planetary-system-stacker) (1.19.4)


PS C:\WINDOWS\system32> planetarysystemstacker

** On entry to DGEBAL parameter number 3 had an illegal value

** On entry to DGEHRD parameter number 2 had an illegal value

** On entry to DORGHR DORGQR parameter number 2 had an illegal value

** On entry to DHSEQR parameter number 4 had an illegal value

ImportError: numpy.core.multiarray failed to import

Traceback (most recent call last):

File "c:\program files\python36\lib\runpy.py", line 193, in _run_module_as_main

"__main__", mod_spec)

File "c:\program files\python36\lib\runpy.py", line 85, in _run_code

exec(code, run_globals)

File "C:\Program Files\Python36\Scripts\PlanetarySystemStacker.exe\__main__.py", line 5, in <module>

File "c:\program files\python36\lib\site-packages\planetary_system_stacker\planetary_system_stacker.py", line 37, in <module>

import cv2

File "c:\program files\python36\lib\site-packages\cv2\__init__.py", line 5, in <module>

from .cv2 import *

ImportError: numpy.core.multiarray failed to import

PS C:\WINDOWS\system32>



Auch nach einem Upgrade der Numpy-Datei auf 1.19.4 erfolgt die gleiche Fehlermeldung.
Wo liegt mein Fehler.
Bin leider bei der Python-Version etwas unbedarft.

Viele Grüße

Jürgen

PS: Hoffentlich steht das nicht im Handbuch, wo ich das überlesen habe 😉
 

Rolf_Hempel

Mitglied
Hallo Jürgen,

nein, im Handbuch steht das nicht. Aber diese Probleme mit inkompatiblen Bibliotheksversionen sind schon ganz oft aufgetreten. Es gibt einfach zu viele Kombinationen von Betriebssystemen und Softwareständen.

Dein Problem scheint an der "numpy"-Bibliothek zu liegen. Der Rechner meldet, dass er die alte Version 1.16 gefunden hat, und gibt sich damit zufrieden. Auf meinem Rechner habe ich die Version 1.18.4. Versuche doch mal bitte folgende Eingaben in der Eingabeaufforderung:
Code:
pip3 uninstall numpy
pip3 install numpy==1.18.4
Dann sollte dieselbe Version an Bord sein wie bei mir. Hoffentlich hilft das.

Schöne Grüße
Rolf
 

nordkap

Mitglied
:y::y::y:
Hallo Rolf,

das hat auf meine 2 Rechner funktioniert !!!
PSS läuft mit 0.8.15

Herzlichen Dank für die schnelle Problemlösung
Viele Grüße aus der Wetterau
Jürgen
 

Rolf_Hempel

Mitglied
Hallo Jürgen,

es freut mich, dass mein Tipp funktioniert hat. Es ist wirklich ein Kreuz mit den Bibliotheksversionen. Am schönsten wäre die Welt, wenn auf jedem Rechner alles gleich wäre. :)

Na, dann herzlichen Glückwunsch! Du bist vermutlich der erste Nutzer außer mir, der schon die neueste Version "Null acht fuffzehn" installiert hat. Ich werde gleich mal eine Nachricht dazu posten.

Schöne Grüße
Rolf
 

Wario

Mitglied
Hi,
nochmal zum numpy-Versionswirrwarr.
Ich hatte das gleiche Problem, ein downgrade auf 1.18.4 hat das gelöst.

Jetzt habe ich aber mal ein Upgrade gestartet (pip3 install --upgrade planetary-system-stacker), und dabei hat er 1.18.4 wieder durch 1.19.4 ersetzt - mit dem Ergebnis das PSS wieder nicht startet.
Manuell numpy dann wieder auf 1.18.4 downzugraden hat dann aber wieder geholfen ;-).

Viele Grüße, Mario
 

Rolf_Hempel

Mitglied
Hallo Mario,

bei der nächsten Version kann ich ja mal versuchen, pip dazu zu bewegen, auf Windows automatisch numpy 1.18.4 zu installieren bzw. eventuell eine andere Version durch diese zu ersetzen. Das müsste eigentlich gehen. Dann braucht Ihr das nicht mehr händisch zu machen.

Schöne Grüße
Rolf
 

maximilian

Mitglied
Hallo!

Ich habe jetzt alles versucht, wozu hier und anderswo geraten wird, und was mir sonst noch so eingefallen ist. Mein Macintosh mag Planetary System Stacker trotzdem nicht installieren. Zwischendrin habe ich sogar Python selbst de- und wieder neuinstalliert, sämtliche Library Einträge gelöscht, alles gelöscht, was nur entfernt nach Python aussieht. Es lässt sich einfach bei mir nicht installieren.

Die Daten:

MacBook Pro 17 Zoll 3,06 GHz Intel Core 2 Duo
OS X Version 10.11.6 (El Capitan)
Python Version: Python 3.9.1 (v3.9.1:1e5d33e9b9, Dec 7 2020, 12:10:52)
pip Version: pip 20.3.3 from /Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/pip (python 3.9)

Andere Python Programme, die ich installiert und ausprobiert habe, funktionieren. Für diese habe ich auch NumPy installieren müssen und zwar
NumPy Version 1.19.5

Jeder Versuch, mittels „pip3 install planetary-system-stacker“ PSS zu installieren endet mehr oder weniger auf diese Weise:

Code:
pip3 install planetary-system-stacker
Collecting planetary-system-stacker
  Downloading planetary_system_stacker-0.8.17-py3-none-macosx_10_6_intel.whl (228 kB)
     |████████████████████████████████| 228 kB 1.2 MB/s
  Downloading planetary_system_stacker-0.8.16-py3-none-macosx_10_6_intel.whl (227 kB)
     |████████████████████████████████| 227 kB 586 kB/s
  Downloading planetary_system_stacker-0.8.15-py3-none-macosx_10_6_intel.whl (214 kB)
     |████████████████████████████████| 214 kB 1.3 MB/s
  Downloading planetary_system_stacker-0.8.14-py3-none-macosx_10_6_intel.whl (209 kB)
     |████████████████████████████████| 209 kB 1.5 MB/s
  Downloading planetary_system_stacker-0.8.13-py3-none-macosx_10_6_intel.whl (208 kB)
     |████████████████████████████████| 208 kB 1.5 MB/s
  Downloading planetary_system_stacker-0.8.12-py3-none-macosx_10_6_intel.whl (208 kB)
     |████████████████████████████████| 208 kB 1.4 MB/s
  Downloading planetary_system_stacker-0.8.11-py3-none-macosx_10_6_intel.whl (208 kB)
     |████████████████████████████████| 208 kB 1.2 MB/s
  Downloading planetary_system_stacker-0.8.10-py3-none-macosx_10_6_intel.whl (208 kB)
     |████████████████████████████████| 208 kB 1.4 MB/s
  Downloading planetary_system_stacker-0.8.9-py3-none-macosx_10_6_intel.whl (208 kB)
     |████████████████████████████████| 208 kB 1.8 MB/s
  Downloading planetary_system_stacker-0.8.8-py3-none-macosx_10_6_intel.whl (208 kB)
     |████████████████████████████████| 208 kB 1.4 MB/s
  Downloading planetary_system_stacker-0.8.7-py3-none-macosx_10_6_intel.whl (207 kB)
     |████████████████████████████████| 207 kB 853 kB/s
  Downloading planetary_system_stacker-0.8.6-py3-none-macosx_10_6_intel.whl (207 kB)
     |████████████████████████████████| 207 kB 1.1 MB/s
  Downloading planetary_system_stacker-0.8.5-py3-none-macosx_10_6_intel.whl (206 kB)
     |████████████████████████████████| 206 kB 1.1 MB/s
  Downloading planetary_system_stacker-0.8.4-py3-none-macosx_10_6_intel.whl (205 kB)
     |████████████████████████████████| 205 kB 1.5 MB/s
  Downloading planetary_system_stacker-0.8.3-py3-none-macosx_10_6_intel.whl (204 kB)
     |████████████████████████████████| 204 kB 1.3 MB/s
  Downloading planetary_system_stacker-0.8.2-py3-none-macosx_10_6_intel.whl (204 kB)
     |████████████████████████████████| 204 kB 1.5 MB/s
  Downloading planetary_system_stacker-0.8.1-py3-none-macosx_10_6_intel.whl (204 kB)
     |████████████████████████████████| 204 kB 1.5 MB/s
  Downloading planetary_system_stacker-0.8.0-py3-none-macosx_10_6_intel.whl (204 kB)
     |████████████████████████████████| 204 kB 1.3 MB/s
ERROR: Cannot install planetary-system-stacker==0.8.0, planetary-system-stacker==0.8.1, planetary-system-stacker==0.8.10, planetary-system-stacker==0.8.11, planetary-system-stacker==0.8.12, planetary-system-stacker==0.8.13, planetary-system-stacker==0.8.14, planetary-system-stacker==0.8.15, planetary-system-stacker==0.8.16, planetary-system-stacker==0.8.17, planetary-system-stacker==0.8.2, planetary-system-stacker==0.8.3, planetary-system-stacker==0.8.4, planetary-system-stacker==0.8.5, planetary-system-stacker==0.8.6, planetary-system-stacker==0.8.7, planetary-system-stacker==0.8.8 and planetary-system-stacker==0.8.9 because these package versions have conflicting dependencies.

The conflict is caused by:
    planetary-system-stacker 0.8.17 depends on mkl
    planetary-system-stacker 0.8.16 depends on mkl
    planetary-system-stacker 0.8.15 depends on mkl
    planetary-system-stacker 0.8.14 depends on mkl
    planetary-system-stacker 0.8.13 depends on mkl
    planetary-system-stacker 0.8.12 depends on mkl
    planetary-system-stacker 0.8.11 depends on mkl
    planetary-system-stacker 0.8.10 depends on mkl
    planetary-system-stacker 0.8.9 depends on mkl
    planetary-system-stacker 0.8.8 depends on mkl
    planetary-system-stacker 0.8.7 depends on mkl
    planetary-system-stacker 0.8.6 depends on mkl
    planetary-system-stacker 0.8.5 depends on mkl
    planetary-system-stacker 0.8.4 depends on mkl
    planetary-system-stacker 0.8.3 depends on mkl
    planetary-system-stacker 0.8.2 depends on mkl
    planetary-system-stacker 0.8.1 depends on mkl
    planetary-system-stacker 0.8.0 depends on mkl

To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict

ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/user_guide/#fixing-conflicting-dependencies

Ich habe auch schon versucht, eine bestimmte Version direkt zu installieren. In einem anderen Thread hier steht zu lesen: „Ich habe jedenfalls Wheel-Dateien auch für Mac bis zur neuesten Version 0.8.23 auf PyPI hochgeladen“

Also: pip3 install planetary-system-stacker==0.8.23

was auf diese Weise endet:
MaximilansMBP2:~ max$ pip3 install planetary-system-stacker==0.8.23
ERROR: Could not find a version that satisfies the requirement planetary-system-stacker==0.8.23
ERROR: No matching distribution found for planetary-system-stacker==0.8.23

Mit allen Nummern zwischen 18 und 23 geht es genauso.

Jetzt bin ich leider mit meinem Latein am Ende, noch mehr Stunden kann ich nicht investieren... Entweder ich mache etwas gundlegendes falsch oder es gibt hier irgendein Macintosh Kompatibilitätsproblem.

Viele Grüße
Maximilian
 

Cpt.Boiler

Mitglied
Hi,
bin leider kein MAC-Experte, aber das Problem mit Library Dependencies kenne ich von Linux. (MAC ist auch UNIX-basiert, also ist das im Grunde dasselbe, auch wenn's im komplett anderen Gewand daherkommt.)
Es sieht so aus, als ob dir ein grundlegendes Paket/Programm bzw. Bibliothek fehlt, nämlich dieses ominöse 'mk1', was vom PSS anscheinend gebraucht wird. Versuche mal, dich auf die Suche danach zu begeben (Google, od. sicher gibts für MAC auch eine Art Paket/Software-Manager, mit dem du Zeugs installieren/deinstallieren kannst.)
-cb
 

Rolf_Hempel

Mitglied
Hallo Maximilian,

tatsächlich ist die "mkl" (Math Kernel Library) erforderlich. Sie wird von numpy, einer von PSS verwendeten Bibliothek, gebraucht.

Leider habe ich noch nie einen Mac auch nur in der Hand gehabt. Daher kann ich dazu auch nicht viel sagen. Hast Du mal auf Cloudy Nights geschaut? In dem dortigen Thread zu PSS haben einige Mac - User sich über Installationsprobleme und deren Lösung ausgetauscht.

Ansonsten: Ist hier im Forum vielleicht ein Mac-User, der es geschafft hat?

Schöne Grüße
Rolf
 

maximilian

Mitglied
Hallo Rolf,
Hallo Maximilian,

tatsächlich ist die "mkl" (Math Kernel Library) erforderlich. Sie wird von numpy, einer von PSS verwendeten Bibliothek, gebraucht.

Leider habe ich noch nie einen Mac auch nur in der Hand gehabt. Daher kann ich dazu auch nicht viel sagen. Hast Du mal auf Cloudy Nights geschaut? In dem dortigen Thread zu PSS haben einige Mac - User sich über Installationsprobleme und deren Lösung ausgetauscht.
Vielen Dank schonmal für die schnelle Antwort. „Mach Kernel Library“ hilft sicher weiter, ebenso wie Cloudy Nights. Was ich bisher rauskriegen konnte ist, dass diese Bibliothek direkt von Intel kommt und für Windows und unix umsonst ist. Für den Macintosh benötigt man leider eine Lizenz. Die kostet zwar für Privatanwender nichts, man muss sich dafür aber bei Intel registieren (wer es probieren will - hier:
Intel® Distribution for Python*), was bei mir aber nur zu dieser Fehlermeldung führt: „Error: We have experienced a critical system error.“ Vielleicht die Rache dafür, dass Apple an sofort keine Prozessoren von Intel mehr einsetzt...

Mal sehen, was ich bei Cloud Nights finde.

Viele Grüße
Maximilian

PS: Interessanterweise laufen andere Python-Programme bei mir, die ebenfalls numpy benötigen. Offenbar greifen nur manche Funktionen innerhalb von numpy auf die Mach Kernel Libary zu.
 

maximilian

Mitglied
Hallo!

Für die übrigen Macintosh Benutzer hier noch ein kurzes Update von mir. Leider nach wie vor keine Erfolgsmeldung. Nachdem ich doch noch ein halbes Wochenende invesrtiert habe, konnte ich immerhin einen Teilerfolg erzielen, der aber leider nicht weiterhilft.

Irgendwo im Internet fand ich folgenden Hinweis:
# numpy 1.18.0 breaks builds on MacOSX

Aus irgendeinem Grund ist aber genau diese Version bei der Installation von PSS „mitgezogen“ worden.

Durch endloses „trial&error“ (das scheint, wenn man in Internetforen über das Installieren von Pythonprogrammen liest, Teil des Vergnügens zu sein...) habe ich eine Version finden können, die einigermassen vertäglich ist und sich manuell so installieren lässt:
pip3 install planetary-system-stacker numpy==1.19.5

Danach muss man dann nur noch das hier manuell nachinstallieren:
pip3 install scikit-image==0.16.1

und man erhält einen Planetary System Stacker auf dem Macintosh, der ohne Fehlermeldungen installiert wird.

Ausführen lässt sich das Programm bei mir leider trotzdem nicht, der Programmstart endet in einer seitenlangen Liste von Fehlermeldungen, von denen mir diese hier die Hauptursache zu sein scheint:
Referenced from: /Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/skimage/_shared/../.dylibs/libomp.dylib (which was built for Mac OS X 10.15)

Ich ein Freund von 17-Zoll MacBooks, denn damit erspare ich mir einen Arbeitsplatzrechner bzw. externen Bildschirm. Das letzte dieser Art wurde leider 2011 hergestellt und die höchste Betriebssystemversion, die sich darauf installieren läst, ist OS X 10.13. Damit ist das Thema „Planetary System Stacker“ für mich wohl leider erledigt. Aber falls jemand einen Macintosh mit 10.15 oder höher hat, helfen ihr oder ihm vielleicht die beiden gelb markierten Zeilen oben weiter.

Viele Grüße
Maximilian

PS: Wenn Python sich irgendwann wirklich auf breiter Front durchsetzen soll, dann muss dieses grausliche Durcheinander von Versionen und Abhängigkeiten irgendwie entwirrt werden.
 

Cpt.Boiler

Mitglied
Hi,
die Problematik mit den Libraries und Abhängigkeiten ist leider nicht Python-spezifisch, sondern allgemein. Die ursprüngliche Idee, schneller voranzukommen wenn man auf Entwicklungen anderer aufbauen kann, geht v.a. im OpenSource Bereich nur teilweise auf, da jede(r) (od.jedes Team) an seinem Kram frickelt und nach eigenem Gutdünken Versionen produziert, ohne jegliche Koordination. Sind oft ja auch Freaks unterwegs, mit , sagen wir mal, ausbaufähigem Kooperationsgeist :). Bei grösseren Projekten wird versucht, 'stable releases' bereitzustellen und dgl., aber eine wirkliche Verlässlichkeit ist trotzdem nicht gegeben. Ausserden ist die Komplexität enorm gestiegen, wenn man sich einmal in gewisse Abhängigkeiten begeben hat, kann man das nicht mal einfach so z.B. durch Eigenentwicklungen ersetzen. Und schon hat man den Salat. Und da ist auch keine Chance auf Entwirrung in Sicht, im Gegenteil ...:(
Bei MAC-Anwendungen kommt dann noch das Problem der Produktphilosophie hinzu. Auch wenn Apple für sein OS XYZ.. irgendwann mal auf Unix-Basis umgestiegen ist, ist die Kundenzielgruppe eine andere. Die ganze Linux-Freaks mit ihren selbstkonfigurierten Mutterbrettern oder sonstigen El-Cheapo-Solutions, die schnell mal einen Fix nach dem anderen 'raushauen, fehlen in der MAC-Welt weitgehend.
-cb
 
Oben