Platinenherstellung für Motorfokus

Hi Edgar,

ich denke das Interesse wird schon noch kommen. Ein paar bejahende PNs habe ich hinter den Kulissen schon erhalten.

Ich werde mir mal ein wenig Gedanken machen und dann sollte man eine mögliche Neuauflage in einem ganz neuen Thread anstoßen.

Grüße,
JD
 
Hi Leute

Ich habe ein Problem den Nanotec ST4209M1704-A zu besorgen. Der Hersteller verkauft ja bekanntlich nicht an Endkunden und er hat mich an Farnell verwiesen aber auch dort kann man als Endverbraucher nicht einkaufen. Farnell hat mich auf einen Einzelhändler aufmerksam gemacht welcher das Sortiment von Farnell anbietet. Auf der HP des Händlers habe ich aber leider den gesuchten Motor nicht gefunden zumal die dort angebotenen Exemplare s.. teuer waren. Jetzt wollte ich gerne von Euch erfahren wo ein Normalsterblicher den Schrittmotor zu einem vernünftigen Preis bestellen kann. Wäre schön wenn Ihr mir helfen könnt.

CS, Tom
 
Zuletzt von einem Moderator bearbeitet:
Hi Tom,

der Motor ist aber schon richtig fett. Mit den 1,7A kannst du damit ein ganzes Teleskop bewegen ;-)
Wenn du die Steuerung von Jan verwenden willst, wäre, von den Wickeldaten, dieser etwas besser geeinet ->
hier
Das entspricht dem Nanotec ST4209M1206.


 
Hallo Edgar

Vielen Dank für die rasche Antwort. OK, ich habe diese Woche die Platine nach Vorgabe fertig gestellt. Als Lastwiderstand habe ich die angegebenen Widerstände mit 4,7 Ohm verwendet da ich es vermeiden möchte irgend etwas neu berechnen zu müssen.
Kann ich beidem von Dir genannten Motor die Lastwiderstand so belassen oder muss ich aufgrund anderer Motordaten etwas anpassen? Der Preis ist sehr günstig und wenn er auch nur 200 Schritte für eine Umdrehung braucht denke ich das die Funktion für den eigentlichen Zweck erfüllt wird. Wenn ich ihn einfach so einbauen könnte wäre das super. Bei dem von mir benannten Motor gehe ich davon aus das es der Motor ist der auch hier im Forum favorisiert wurde. allerdings habe ich mich auch bewundert das der Motor 1,7 Amp. ziehen soll obwohl ja von einer 5V / 1 Amp. Stromversorgung als ausreichend gesprochen wurde. Irgend wie passte das für mich nicht zusammen aber ich habe einfach blind auf die Angaben vertraut. Nochmals vielen Dank für deine Antwort.

CS, Tom
 
Den von Edgar verlinkten Motor kann ich nicht empfehlen, da bei einem Betrieb unterhalb der angegebenen Nennspannung (das wäre hier der Fall, wenn Du nicht auf eine Spannungsversorgung >>5V gehst) Schrittverlust wahrscheinlich ist, Stichwort Induktivität.

Wir hatten damals den ST4209M1206 aufgrund der niedrigen Nennspannung gewählt und ihn entsprechend in der Stromaufnahme durch Vorwiderstände gedrosselt, damit er mit dem Schrittmotortreiber harmoniert. Wie oben schon erwähnt war ein Chopping nicht möglich. Der Motor zieht in der angesprochenen Konfiguration (mit Spannungsabfall durch den Treiber) so ca. 400 mA pro Phase. Insofern passt das schon alles zusammen.

Fazit: Du kannst den Motor von Reichelt ausprobieren, er muss aber nicht zwangsläufig mit 5 V zuverlässig funktionieren, da sich der Strom in der Spule wg. der Induktivität ggfs. zu langsam aufbaut (besonders bei schnellen Schrittfolgen), was zu Schrittverlust führen kann! Grundsätzlich ist eine niedrige Induktivität zu wählen. Der Nanotec Motor hat z.B. 4 mH.

Grüße,
Jan-David



 
Hallo Jan-David

Auch Dir ein Danke schön. Heißt das nun das ich den von Dir zuletzt genannten Motor benötige und nicht den in der Bestellliste aufgeführte? Hab mir zudem so etwas schon gedacht das es vielleicht Probleme gibt aber nun habe ich das Problem das ich den Motor aus der Bestellliste anscheinend nirgens bestellen kann. Beim Farnelleinzelhändler lagen die Preise der Schrittmotoren zudem jenseits der 150.-€ Grenze was für mich einfach zu heftig ist. Wenn die Mitleser noch eine andere Quelle haben würde ich sie gerne nutzen.

CS, Tom
 
Zuletzt von einem Moderator bearbeitet:
Ei, ja das ist wirklich ein Problem mit Nanotec.

150 Euro sind klar zu viel. Der Motor kostet knapp 30 Euro bei Nanotec (meine ich mich zu erinnern). Ich würde ja sagen, dass ich Dir den bestelle, aber das lohnt sich auch nicht recht mit dem Mindermengenzuschlag und und und.

Bist Du darauf angewiesen nur mit den 5 V am Motorfokus auszukommen, oder bist Du stationär, sodass Du 5 V über USB und bspw. 9 V separat zuführen könntest?

Egal wie es ist, ich würde es auf jeden Fall mal mit dem Reichelt-Motor, auch bei 5 V probieren. Kalkulier aber nochmal die Widerstände durch. (Berechnung ist im Handbuch exemplarisch vollzogen)

Viele Grüße,
Jan-David
 
Hi Tom,

dieser kommt dem Nanotec noch näher (3.3R, 2.8mH, o,3Nm bei 1,2A) -> hier
Ich kenne die Standard-Auslegung der Widerstände bei Jan nicht, ich denke aber, das sollte schon pssen?
 
Gerade nochmal nachgesehen, der Phasenstrom ist oben auf 550 mA berechnet.

Der von Edgar neu vorgeschlagene Motor funktioniert eher.
http://www.watterott.com/de/Schrittmotor-Unipolar/Bipolar-200-Steps/Rev-42x48mm-40V-1200mA-NEMA-17

Man hat mit der Steuerung ca. 3,5 V Spannung am Motor. Das ist immer noch eine leichte Unterspannung, die (ohne Gewähr) aber wohl zu verschmerzen ist. Als Widerstände würde ich dann die 2,7 Ohm Widerstände statt der 4,7 verwenden (Gibt es beim großen C in der gleichen Bauform), es würden aber in dem Fall auch 1 W Widerstände, oder 2,5 W genügen. Conrad-Artikelnummer: 458731-62.

Grüße,
Jan-David


EDIT: Gerade noch gesehen, wie wärs mit dem hier?
http://www.watterott.com/de/Schrittmotor-Bipolar-200-Steps/Rev-20x30mm-39V-600mA-Nema-8
(Ganz ohne zusätzliche Widerstände)

Oder besser noch dem hier:
http://www.watterott.com/de/Schrittmotor-Bipolar-200-Steps/Rev-35x36mm-27V-1000mA-NEMA-14

Dieser Motor ist meiner Meinung nach wohl die beste Wahl momentan.
Dann bitte z.B. mit folgenden Widerständen Conrad: 458773 - 62


 
Hallo Jan-David, hallo Edgar

Einfach genial von euch beiden wie Ihr mich unterstützt.
Ganz ganz großes DANKE schön.
Wie hoch sollte das Haltemoment den sein? An mein Teleskop hängen bis zu 2kg an Equipmemt und da sollte der Motor sicherlich ein entsprechendes Moment besitzen, wobei durch das Getriebe kommt schon ein starkes Moment zusammen. Ich hoffe dies zumindest :blush:
Ich werde wohl den letzten Vorschlag von Jan-David aufgreifen und die Lastwiderstände entsprechend anpassen.
Wenn ich es richtig verstanden habe muss ich jetzt nur noch eine 5V Stromquelle mit min. 1A an Strom in meinen Powerkoffer einbauen und alles müsste laufen!?

CS, Tom
 
Mach mal besser 2 A aus dem Netzteil.

Welchen HalteSTROM Du einstellst (per Software ist das frei wählbar) musst Du wissen, bzw. austesten. Das angegebene Haltemoment bezieht sich auf 100% Spulenstrom, also quasi einen Kurzschluss des Motors. => Keine gute Idee! Der Motortreiber würde in ganz kurzer Zeit extrem heiß werden und letztlich durchbrennen.
Also besser nicht über ~40% Haltestrom gehen. Generell eher vorsichtig den Haltestrom erhöhen bis zu einem Wert der ausreichend ist und immer schön die Erwärmung des Motortreibers im auge behalten. (Kühlkörper nicht vergessen)

Ich z.B. muss bei meinem Okularauszug keinen Haltestrom einstellen, denn die Reibung des Planetengetriebes das ich nutze reicht aus um quasi jede Last zu halten. Natürlich ist es auch stark vom OAZ abhängig, z.B. wie stark beim Crayford der Anpressdruck der Welle ist. Irgendwann rutscht ein Crayford auch durch und dann ist es völlig egal wie hoch Dein Haltemoment ist.

Auch wenn Du z.B. einen Schreckentrieb als Untersetzung für den Motor nutzt musst/solltest Du keinen Haltestrom einstellen. (Warum, ist hoffentlich leicht ersichtlich.)

Noch ein Argument: Je weniger Haltestrom, desto länger lebt der Motortreiber.

Grüße,
Jan-David
 
Hallo Jan und Tom,

mit der Software von Thomas (und damit auch mit Jan's Lösung) kann man den Haltestrom nicht beliebig einstellen.
In RoboFokus kann nur ein "Duty-Cycle" (= Haltestrom) eingestellt werden und da hat Thomas ein wenig getrickst: Wenn der DutyCycle auf <50% eingestellt ist, wird der Motor nach dem fokussieren ganz abgeschalten. Bei > 50% bleibt er an.
Der eigenttliche Strom durch den Motor wird nur durch die Widerstände bestimmt.
Die Widerstände sollte man daher so groß machen, dass die Elektronik auch im Dauerbetrieb nicht allzu heiß wird.

@Tom
Ich mache gerade Test für meinen Motor (so ein ähnlicher, wie Jan zu allerletzt vorgeschlagen hat). Um 2,5Kg zu heben brauche ich eine 1:3 Übersetzung (an meinem 2,5" AMP OAZ). Du solltes aber eine höhere Übersetzung wählen, so 1:8, damit du im Halbschrittbetrieb feinfühlig fokussieren kannst (ich plane eine Lösung mit Mikroschrittbetrieb). Du hast dann auch noch genug Reserven, um die Widerstände evtl. doch ein wenig größer zu machen (oder so zu lassen, wie in Jan's ursprünglichen Design).
 
Hallo Jan,

ich bin gerade dabei, die Firmware auf einen Arduino zu portieren.
Dabei ist mir noch ein Bug aufgefallen: Das Goto und die Schrittanzeige gehen nur bis 32768 und springen dann auf irgendein negativen Wert. RoboFokus kann bis 65000 Zählen, was aber nur im Mikroschritt Betrieb relevant sein dürfte.
Außerdem geht die Stopp Funktion nicht (oder hab ich da beim portieren was verbugt...).
 
Tatsache, da stehts:

Code:
 If Dutycycle < 50 Then
   Reset Stepperenable
 Else
   Set Stepperenable
Ja das mit den Schritten ist mir auch schon aufgefallen! Ist aber logisch warum das so ist und sicherlich kein Bug, sondern eher ein Feature. Der Speicherbereich läuft Dir einfach über. ;-)
Frei nach Wikipedia:
BYTE:Ganzzahlen von 0 bis 255
WORD: 16 Bit, Ganzzahlen von 0 bis 65535
INTEGER: 16 Bit, Ganzzahlen von -32768 bis +32767
LONG:32 Bit, Ganzzahlen von -2147483648 bis 2147483647
Die Lösung wäre also die Variable als WORD zu definieren statt als INTEGER, bzw., wenn sie negative Werte können muss dann eben als LONG.

Du meinst "Dostop"? Funktioniert ganz sicher, denn sonst würde der innere ELS den Auszug nicht stoppen.

Grüße,
Jan-David
 
Hallo Jan,

die Enlagenschalter funktioniere.
Wenn man aber in RoboFokus auf Stop clickt, während der Motor noch fährt, passiert nicht. Der Motor läuft einfach weiter.
 
Hallo Jan-David,

ich bin per Zufall an die Abhandlung "Stepperfocuser-Platine" von Thomas Westerhoff gestossen und, nachdem ich recht viel hinsichtlich Elektronik bastle, möchte ich so etwas nicht nur für die Fokussierung des Teleskopes sondern auch für die Winkelverstellung des Gitters bei meinem Eigenbauspektroskop http://spektroskopieforum.vdsastro.de/viewtopic.php?t=3780&start=0
(Erweiterung eines Projektes von Daniel Sablowski) anstatt der Micrometerschraube einsetzen.
Vielleicht habe ich jetzt in der Begeisterung Einiges übersehen, aber mir fehlt zu dem Konzept die Firmware. Das Flashen wäre kein Problem für mich. Könntest Du mir da ein wenig weiterhelfen?
Ich kann zwar in BASCOM so leidlich gut programmieren (Foucault-Tester z.B.), aber, wenn ich die Schraube nicht ein zweites Mal erfinden müsste, wäre das sehr fein. ;-)

Mit besten Grüssen

Gerhard
 
Hallo Jan-David, nur kurz in Bezug auf Arduino wieder zu kommen.
Zitat von JDF:
ich verstehe auch Deine Argumente. So eine Arduino + Motorshield-Konstruktion, die einfach und funktionell ist, ist aber eher ein ich sag mal "fliegender Aufbau" für den Basteltisch, weil man ja schon recht viele lose Leitungen, Steckverbindungen, etc. hat.
Bin ich nicht deine Meinung, die Platinen werden immer zusammen gesteckt und zum Schluss hat man genau so viel Leitungen wie bei deine Platine.

Zitat von JDF:
Open Source Teleskopsteuerungen auf Basis von Arduino gab es ja schon, die aber meines Wissens nach alle nicht so wirklich gut durchgestartet sind (bitte berichtige mich hier, wenn das nicht stimmt). Alles was ich bisher gesehen haben waren irgendwelche losen Platinen, die irgendwie verkabelt, oder über Stiftleisten verbunden waren und mit einem mäßig großen Kabelgewirr dann verbastelt wurden. Das hat zwar funktioniert, aber "schön" und vor allem "mobil" geht anders.
Da muss ich wiedersprechen!

Ich betreibe schon seit Jahren die komplette Steuerung mit Arduino. Zurzeit schon die zweite Version.
Als Handsteuerung benutze ich einen Nunchuk von Wii.

Die erste Version war Arduino mit L293D Huckepack Treiber.

Diese Version hat die normale Nachführung sowie Guideing implementiert.
Alles mit 64 Mikroschritten Betrieb
Hier hat mich etwas der unangenehmer Sound bei 64 Mikroschritte genervt.
Mit diese Steuerung habe ich von 2010 bis ende 2012 gearbeitet.

Meine 2-te Version is wieder Arduino aber diesmal mit L6470 Treiber.
Wieder mit Wii Nunchuk, guideing und heute Abend habe ich die erste erfolge bei goto mit Stellarium gehabt.

Hier ist die Platine:


128 Mikroschritte Betrieb!
Bis 2 Amper Motoren sind dran.

Und hier an die Montierung dran, es ist der kleine Kasten unten Links wo die 3 Kabel rein gehen.



Grüße
Igor

PS: Eine Arduino Platine aus HK kostet 9€
http://www.ebay.de/itm/390507501386
Unschlagbar!



 
Zuletzt von einem Moderator bearbeitet:
Hallo Gerhard,

sorry, dass ich Deinen Beitrag gerade jetzt erst sehe.
Wo liegt denn genau Dein Problem?
Du kannst ja prinzipiell die Mikrometerschraube durch einen Linearaktuator ersetzen, der sich dann wie ein Schrittmotor steuern lässt.

Ich bin übrigens in dem von Dir verlinkten Forum auch mit dabei. ;-)

Grüße,
Jan-David

 
Ich muss diesen Thread leider noch mal ans Tageslicht befördern.

In der Vergangenheit erreichten mich ab und an ein paar Anfragen bzgl. der begrenzten Fahrwege des Stepperfocusers.

Der Robofocus unterstützt softwareseitig maximal 99999 Schritte. Beim Stepperfocuser war bislang bei 32767 Schritten Schluss, was besonders bei drastischer Getriebeuntersetzung manchmal problematisch war.
Ich habe die Firmware etwas angepasst und kann sie nun mit der maximalen Schrittanzahl zur Verfügung stellen. Alle weiteren Funktionen, wie Endlagenschalter und der Temperatursensor, bleiben natürlich erhalten.

Bitte die jeweilige Datei wie gewohnt per Programmer auf den Atmega8 übertragen:

Datei 1: StepFoc_Robo_ELS20(19200)_long.bin
Datei 2: StepFoc_Robo_ELS20(19200)_long.hex

Viele Grüße,
Jan-David

PS: Wer bereits einen Stepperfocuser aus dieser Serie hat, die angepasste Firmware dringend benötigt und nicht selbst einspielen kann, der nimmt bitte mit mir Kontakt auf.
 
Hallo Jan-David,
ich hab ja auch den Stepperfocuser am meinem Steeltrack.
Was mich aber etwas stört, ist der etwas "schwache" L293D.
(mir sind schon 2 gestorben)
Ist es möglich die L297/L293D duch ein A4988 zu tauschen?


Gruß
Exi

 
Hallo Exi,

ich habe seit 6 Jahren in unserer Vereinssternwarte den L293D in Betrieb. Da ist noch nie etwas gestorben. Was machst Du mit den Teilen? Hast Du einen Kühlkörper drauf?
Hast Du eventuell den "Duty Cycle" in der Software an? Dann wird der Baustein natürlich sehr heiß.

Grundsätzlich könnte man darüber nachdenken den A4988 gegen die L297/L293D Kombi zu tauschen. Ich weiß aber gerade nicht ob das einfach durch Umklemmen funktioniert. Pinkompatibel sind die Bauteile ja auf gar keinen Fall.
Zudem braucht der A4988 wohl eine zweite höhere Motorspannung. Man müsste dann die Widerstände ggfs. neu berechnen.
Unmöglich ist der Umbau sicher nicht, allerdings habe ich gerade keine Zeit dabei Hilfestellung zu geben. Da müsstest Du dann leider allein durch.

Grüße,
Jan-David
 
Hallo Jan-David,
ja, Duty-Cycle ist an und trotz Kühler wird der sehr sehr warm....(Habe leider kein Getriebe am Stepper)

Mit dem A4988 könnten dann auch die Widerstände weg.

Ich versuch mal ein "Test-Aufbau"...das kann ja maximal nur abrauchen! :schwitz:

Wenn es laufen sollte, könnte ich das "layout" bekommen?
Ich würde dann die Platine ändern wollen.

Gruß
Exi


 
Dann würde ich mal empfehlen den Dutycycle auszuschalten, oder vielleicht sind auch die Widerstände falsch dimensioniert? ;-)

Ja, Layout ist kein Problem. Schreib mir mal ne Mail.
 
Zuletzt von einem Moderator bearbeitet:
Hallo zusammen,
ich habe die Platine auch vor einiger Zeit zusammengebaut. Ein Dank an dieser Stelle!
Bei meinen Testläufen ist mir folgender (nerviger) Bug aufgefallen:

Wenn ich mit meiner Aufnahmesoftware nach der Initialisierung (Position 1) versuche ein
Goto Befehl (absolute Position) abzusetzen, dann fährt der Motor nicht an diese Position.
Wenn ich einfach nur eine Anzahl an Schritten verfahre (relative Position), dann
funktioniert dies und ich kann danach auch einen absoluten Wert anfahren.

Hier eine Aufzeicnnung des Datenverkehrs zur Verdeutlichung:
Code:
FG002500´  ->   FD000001«    # Goto auf Position 2500 direkt nach Initialisierung (FG)
FO000500º  ->   FD000501°    # Es werden 500 Schritte relativ verfahren (FO)
FG002500´  ->   FD002500±    # Goto auf Position 2500
Ich habe schon viel nach diesem Phänomen gesucht aber nichts dazu gefunden.

Über eine Hilfestellung würde ich mich sehr freuen.


Viele Grüße,

Dirk
 
Hallo Dirk

ist bei mir auch so. Ich drücke kurz Richtung aussen (sind bei mir zum Feinfokusieren 10 eingestellt) und gebe danach die absolute Position ein 2500 und danch kann man den abend feste Positionen anfahren.

Gruß Rolf
 

Diese Seite empfehlen

Oben