[DIY] AllSky Kamera mit Raspberry Pi – Mein Bauprojekt & Anleitung (All Sky Camera) | Seite 11 | Astronomie.de - Der Treffpunkt für Astronomie

[DIY] AllSky Kamera mit Raspberry Pi – Mein Bauprojekt & Anleitung (All Sky Camera)

drone1_de

Mitglied
Für alle, die sich über die vielen Hotpixel bei der ASI120 MC ärgern und diese auch mit einem Dark nicht wegbekommen....ich habe nun ein fehlerfreies Bild! Unterschied: das Dark habe ich erst erstellt, nachdem die Kamera schon eine halbe Stunde gelaufen war...also schön auf Betriebstemperatur! Vorher hatte ich mit dem Dark keine vernünftige Korrektur, vielleicht probiert Ihr das auch mal?
Grüsse,
Lars
 

Torakin

Mitglied
Danke für die Info, wie mach ich das, wo ist die Datei? Kann ich auch ein Dunkelbild von meiner 290 er einfügen ?
 

Torakin

Mitglied
Hallo zusammen, hab jetzt folgendes Problem. Hab ein Dark Bild erstellt und es im Ordner eingefügt.Nun wird mir bei Tag als Livebild ein Schwarzes angezeigt (Exposure 0.000 und Gain 0 ) erst wenn das Programm startet bekomm ich ein Livebild. Das war aber vorher nicht. Ich glaub nicht , das das mit dem Dark zu tun hat. Habe das System über Fernzugriff neu installiert und kein Dark hinzugefügt, bleibt aber das gleiche . Gibt es dafür eine Lösung?
 

Torakin

Mitglied
Glaub die Lösung gefunden zu haben Hab die Usb Bandbreite von 40 auf 50 erhöht. Musste ich vorher aber nicht 🤔
 

Torakin

Mitglied
Hallo, ich nochmals, das Problem hat sich doch nicht gelöst. Bei USB Speed 40 nur ein schwarzes Bild bei 52 ist ein Bild aber nach einer Weile ist das Bild dann 2 geteilt oder 4 Teile manchmal nur Streifen . Nutze die Asi 120 Color und den Raspberry 3B+ Ich bin bis Ende Juli noch in der Schweiz das Projekt ist aber bei mir zu Hause in Deutschland. Gibt es eventuell Ratschläge. Danke schon mal
 

chriskosmos

Mitglied
Hallo, ich nochmals, das Problem hat sich doch nicht gelöst. Bei USB Speed 40 nur ein schwarzes Bild bei 52 ist ein Bild aber nach einer Weile ist das Bild dann 2 geteilt oder 4 Teile manchmal nur Streifen . Nutze die Asi 120 Color und den Raspberry 3B+ Ich bin bis Ende Juli noch in der Schweiz das Projekt ist aber bei mir zu Hause in Deutschland. Gibt es eventuell Ratschläge. Danke schon mal

Im laufenden Betrieb (bei Nacht) habe ich auch im Livebild teilweise ein geteiltes Bild und auch Streifen. Die Bilddateien haben aber nicht die Fehler, somit liegt es nur an der Livewiedergabe. Überprüfe mal, ob die Bilddateien die beschriebenen Fehler zeigen.

Gruß Chris
 

Torakin

Mitglied
Danke erstmal, die Verzerrungen, Streifen und geteilten Bilder sind auch auf den Aufnahmen enthalten , mit den Browser Cache kann es glaub ich nichts zu tun haben. Das mit den Fehlern ist auch zu sehen wenn ich mit der Software AsiCap arbeite und Videos vom Mond erstelle , bei der 120er sowie bei der 290er
 

GanymedRN

Mitglied
OK dann scheint das Problem in der Kombination Kamera/Kameratreiber zu liegen.
Ich habe keine 120 oder 290 sondern arbeite mit der 178MM.
Ein häufiges Problem ist die USB Kommunikation. Bei Firecapture und Sharpcap gibt es einen Regler mit dem man den USB Traffic regulieren kann.
 

hubivo

Mitglied
Hallo Ivo,
Da sind 6 100Ohm Widerstände parallel das ergibt 16,7Ohm. Bei 5V ergibt das eine Leistung von 1,5W.
Das sollte man relativ schnell merken.
Was ich nicht verstehe warum man ein teures und fehleranfälliges Relais verwendet. Ein NMOS Transistor für wenige Cent macht das sehr viel effizienter. Bei so geringen Spannungen und Strömen macht ein Relais nicht wirklich Sinn.
Ich habe mal gelernt "Wenn der Ingenieur nicht weiter weiß, dann nimmt er ein Relais".

Hi Roger,

würde denn die Heizungssteuerung analog der Lüftersteuerung von hier funktionieren, also mit einem Transistor BC547? Anstatt des Lüfters nur die Widerstände?
Die Lüftersteuerung funktioniert bei mir und die Bauteile hab ich alle noch da.
 

GanymedRN

Mitglied
Hallo Ivo,

Klar das funktioniert, ist ja genau dasselbe Prinzip. Bei der Heizung kann man aber auch einfach mit Ein/Aus arbeiten.
Die Frage ist wie man entscheidet ob man heizen muss oder nicht. Da hilft ein Temperatursensor.
Mit Temperatursensor kann man auch einfach mit Aus/Ein arbeiten also z.B. ab 5° einschalten bei 10° wieder aus.
Da braucht man keine PWM das die Temperatur konstant hält. Wir machen hier ja kein Deepsky ;)
 

Astrohellmi

Mitglied
Hallo zusammen,
ich bin leider am Ende mit diesem Projekt. Es werden einfach keine Bilder gespeichert. Live View funtioniert mit meiner ASI 178 MC wunderbar. Koordinaten und Zeit stimmen auch. Ich habe die grafische Oberfläche welche auch läuft. Unter dem Punkt "Images" wird (egal was ich anklicke) nichts an Bilddateien angezeigt.
Kann mir hier einer von Euch helfen? Was mache ich falsch? Hab ich was übersehen?

Über Eure Hilfe würde ich mich echt freuen.
 

hubivo

Mitglied
Hi Helmi,

also Bilder werden generell nur dann gespeichert, wenn die Sonne abends unter den Winkel sinkt, welchen Du in den Camera Settings unter "angle" eingestellt hast ( Altitude of the sun above or below the horizon at which capture should start/stop. Can be negative (sun below horizon) or positive (sun above horizon). 0=Sunset, -6=Civil twilight, -12=Nautical twilight, -18=Astronomical twilight.).
Wann das ist, wird durch die korrekte Angabe deiner Latitute und Longitude berechnet (so verstehe ich das zumindest). Genauso morgens, wenn die Sonne über den angegebenen Winkel steigt, wird das capturing wieder gestoppt. Tagsüber erfolgt generell keine Speicherung der Bilder.

Du kannst auch nochmal auf dem Pi schauen, ob das Verzeichnis /home/pi/allsky/images korrekt angelegt ist und die richtigen Rechte hat (Bsp.):
drwxr-xr-x 8 pi pi 4096 Jun 21 05:55 images

Der Nutzer pi muss Schreibrechte auf das Verzeichnis haben.
 

hubivo

Mitglied
Hallo Ivo,

Klar das funktioniert, ist ja genau dasselbe Prinzip. Bei der Heizung kann man aber auch einfach mit Ein/Aus arbeiten.
Die Frage ist wie man entscheidet ob man heizen muss oder nicht. Da hilft ein Temperatursensor.
Mit Temperatursensor kann man auch einfach mit Aus/Ein arbeiten also z.B. ab 5° einschalten bei 10° wieder aus.
Da braucht man keine PWM das die Temperatur konstant hält. Wir machen hier ja kein Deepsky ;)

Hi Roger,

ich hab das jetzt analog der Lüftersteuerung gebaut. Einfaches manuelles Ein-/Ausschalten bzw. über cron, mit jeweils einem kleinen Skript (gpio15.on.py, gpio15off.py).
Allerdings überzeugt mich die Temperatur meiner Konstruktion überhaupt nicht. Ich hab 10 x 100 Ohm Widerstände parallel geschalten, sollte also 2,5 Watt Heizleistung ergeben. Aber die Dinger werden nur lau- bzw. handwarm. Sollte das denn bei straffen Minusgraden im Winter ausreichen?
 

Astrohellmi

Mitglied
Hi Helmi,

also Bilder werden generell nur dann gespeichert, wenn die Sonne abends unter den Winkel sinkt, welchen Du in den Camera Settings unter "angle" eingestellt hast ( Altitude of the sun above or below the horizon at which capture should start/stop. Can be negative (sun below horizon) or positive (sun above horizon). 0=Sunset, -6=Civil twilight, -12=Nautical twilight, -18=Astronomical twilight.).
Wann das ist, wird durch die korrekte Angabe deiner Latitute und Longitude berechnet (so verstehe ich das zumindest). Genauso morgens, wenn die Sonne über den angegebenen Winkel steigt, wird das capturing wieder gestoppt. Tagsüber erfolgt generell keine Speicherung der Bilder.

Du kannst auch nochmal auf dem Pi schauen, ob das Verzeichnis /home/pi/allsky/images korrekt angelegt ist und die richtigen Rechte hat (Bsp.):
drwxr-xr-x 8 pi pi 4096 Jun 21 05:55 images

Der Nutzer pi muss Schreibrechte auf das Verzeichnis haben.
HI Ivo,

vielen Dank.
Das hat mir schon mal sehr geholfen. Ich habe das ganze System noch mal neu installiert. Und siehe da, jetzt geht es. Hab mal auf 0° gestellt und letzte Nacht laufen lassen. Alles Supi jetzt.

1 Frage hätte ich noch. Vielleicht kannst Du mir die ja noch beantworten.
Das Bild ist oben und unten abgeschnitten.
Mit den Bildeinstellungen "Width" & "Height" ändert sich nichts.

Gruß: Helmi
 

Anhänge

  • image-20200710051532.jpg
    image-20200710051532.jpg
    130,9 KB · Aufrufe: 82

michelastrolo

Mitglied
Hallo Zusammen,
ich habe mich gestern ebenfalls an das Allsky-Projekt auf Raspbi-Basis gemacht. Ich habe mich auch an alle Anleitungen gehalten und es technisch realisiert. Zum testen habe ich sie mal aufs Dach gestellt (keine endgültige Position!). Dabei habe ich folgende Probleme festgestellt und hoffe auf Lösungsmöglichkeiten hier durch Euch. Im gesamten Thread habe ich dazu noch keine lösenden Hinweise gefunden.

Zunächst meine Basis:
Raspbi 3B mir 32GB Karte, eine ASI 178 MC, Allsky von Thomas Jacquin mit GUI.
Fragen:
  • Die Bilder haben eine Teilung. Diese verschwindet zwar ab und an, aber ich habe auch durch spielen an den Parametern nicht herausgefunden woran das liegt.
  • Könnte jemand mit vergleichbarem und stabil laufendem Setting mal seine Kamerakonfig posten?
  • Muss ich irgendwo den Kameratyp angeben? Im Protokoll steht immer die ASI 120 als Kamera.
  • Wie kann ich die Hotpixel reduzieren?
Danke für Eure Hilfe im Voraus.

Gruß
Michael

1594532940881.png

Meine aktuelle Config:
1594533152709.png


1594533179545.png


1594533204256.png
 

Centes

Mitglied
Hallo Zusammen,
ich bekomme bei meiner ZWO ASI 120MC - USB2 und meinem Raspberry PI4 - 2GB kein Livebild.

Ich habe die Programme der Anleitung installiert; soweit funktioniert auch alles. Nur bekomme ich zum Test schon einmal kein Livebild.

Wenn ich den Befehl sudo service allsky status eingebe zeigt es mir an
"active ( running ) since...."

allsky system[1]: Started All Sky Camera
allsky allsky.sh[2117]: can´t get debug descriptor: Resource temporarily unavailable


Hat jemand eine Idee?

Schon einmal Danke im voraus.

Grüße
Jürgen
 

michelastrolo

Mitglied
Hallo Jürgen,

hast Du die GUI ebenfalls installiert?
Die GUI soll erst installiert werden, wenn allsky einmal vernünftig mit Kamera lief. Erst dann das GUI installieren. Falls Du die GUI installiert hast, bevor du die Kamera getestet hast, solltest du eine Neu-Installation machen, mittel Config.sh usw. die Einstellungen vornehmen und dann erst die GUI installieren. Ich hatte das gleiche Problem und bei mir hat es dann funktioniert! Und unbedingt vorher den Pi updaten und upgraden "sudo apt upgrade".

Gruß Micha
 

Centes

Mitglied
Hallo Micha,

ja, ich habe erst Alles ( auch die GUI ) installiert und dann die Kamera getestet.
Sollte ich eine komplette Neuinstallation machen; alles nochmals komplett "runterschmeißen"
und neu installieren?
Wie lösche ich die installierten Dateien. Bin mit der Software und der Befehlsstruktur des RaspberryPI
noch nicht so vertraut.

Werde ich in den nächsten Tagen machen.

Schon mal Danke.

Gruß
Jürgen
 

michelastrolo

Mitglied
Ich bin auch kein Profi. Meines Wissens nach reicht es den allsky Ordner zu löschen. Müsste mit rm -r allsky gehen. Evtl. Sudo voranstellen!

Dann erst den pi upgraden und dann allsky über Github installieren.
config anpassen bis er im Protokoll alles sauber erkennt. Dann erst die GUI installieren!

Hoffe es hilft Dir weiter...
 

hubivo

Mitglied

michelastrolo

Mitglied
Hallo Zusammen,

noch mal die Bitte: Kann jemand, der eine stabile Variante von allsky betreibt, mal seine Config posten? Screenshot oder config.sh.

Vielen Dank im Voraus.
 

hubivo

Mitglied
Hi michelastro,

here we are:

config.sh
Code:
#!/bin/bash
source /home/pi/allsky/scripts/ftp-settings.sh

# Set to true to upload current image to your website
UPLOAD_IMG=true

# Set to true to upload timelapse video to your website at the end of each night
UPLOAD_VIDEO=true

# Set to true to send data to your server at the end of each night
POST_END_OF_NIGHT_DATA=true

# Set to true to generate a timelapse at the end of the night
TIMELAPSE=true

# Set to true to generate a keogram at the end of the night (image summary of the night)
KEOGRAM=true

# Set to true to upload the keogram after it has been generated
UPLOAD_KEOGRAM=true

# Set to true to generate a startrails image of the night. Will skip brighter images to avoid over-exposure
STARTRAILS=true

# Images with a brightness higher than the threshold will be skipped for startrails image generation
BRIGHTNESS_THRESHOLD=0.27

# Set to true to upload the startrails after it has been generated
UPLOAD_STARTRAILS=true

# Set to true to enable automatic deletion of archived data (images + videos)
AUTO_DELETE=true

# Set this value to the number of archived nights you want to keep. Needs AUTO_DELETE=true to work
NIGHTS_TO_KEEP=21

# Path to the dark frame for hot pixels subtraction. Can be jpg or png.
DARK_FRAME="dark.png"

# Set to 0 to disable Daytime Capture
DAYTIME="1"

# Path to the camera settings (exposure, gain, delay, overlay, etc)
CAMERA_SETTINGS="/etc/raspap/settings.json"

Solltest Du jedoch die Kameraeinstellungen benötigen, bräuchtest Du die "settings.json" aus /etc/raspap/, wenn die GUI installiert ist.
 

hubivo

Mitglied
Hab ich mir schon fast gedacht ;).

Ich habe allerdings für den Tag (RGB24, farbig)- u. Nachtbetrieb (RAW8, s/w) unterschiedliche Konfigurationen, welche aus Erfahrungswerten mit der Zwo ASI 120 MC-S her rühren.

settings_color.json für den Tagbetrieb:
Code:
{"width":"0","height":"0","exposure":"10000","maxexposure":"20000","autoexposure":"1","gain":"50","maxgain":"200","autogain":"0","gamma":"50","brightness":"50","wbr":"53","wbb":"90","bin":"1","delay":"10","daytimeDelay":"5000","type":"1","quality":"95","usb":"40","filename":"image.jpg","flip":"0","text":"Sternwarte R\u00f6thenbach","textx":"15","texty":"35","fontname":"0","fontcolor":"255 255 255","smallfontcolor":"255 255 255","fonttype":"0","fontsize":"1","fontline":"1","outlinefont":"0","latitude":"50.3N","longitude":"12.25E","angle":"-6","time":"1","darkframe":"0","showDetails":"1"}

settings_sw.json für den Nachtbetrieb:
Code:
{"width":"0","height":"0","exposure":"10000","maxexposure":"20000","autoexposure":"1","gain":"50","maxgain":"200","autogain":"0","gamma":"50","brightness":"50","wbr":"53","wbb":"90","bin":"1","delay":"10","daytimeDelay":"5000","type":"0","quality":"95","usb":"40","filename":"image.jpg","flip":"0","text":"Sternwarte R\u00f6thenbach","textx":"15","texty":"35","fontname":"0","fontcolor":"255 255 255","smallfontcolor":"255 255 255","fonttype":"0","fontsize":"1","fontline":"1","outlinefont":"0","latitude":"50.3N","longitude":"12.25E","angle":"-6","time":"1","darkframe":"0","showDetails":"1"}

Ich hoffe, es hilft Dir!
 
Oben