Neues Stacking-Software-Projekt "PlanetarySystemStacker" | Seite 3 | Astronomie.de - Der Treffpunkt für Astronomie

Neues Stacking-Software-Projekt "PlanetarySystemStacker"

Rolf_Hempel

Mitglied
Hallo Heiko,

Hallo Rolf,

Du mußt nicht unbedingt für mich jetzt das Problem mit den Artefakten lösen. Dein Programm ist ja noch im Entwicklungsstatus und wird bestimmt noch weiter "entwanzt". Ich werde das verfolgen und auch benutzen.
Wie Du sagst, scheint es Probleme mit den AVIs zu geben. Da steigt das Programm bei mir auch ab und zu aus - auch unter 4 GB.
Ich habe das mit den Artefakten auch an einem anderen (zugegebenermaßen qualitativ schlechten) Video festgestellt und das ganze noch mal mit AS3! verglichen. AP-Größe bei PSS war 100 und bei AS3! 104. Geschärft haben ich mit Wavelets in Fitswork. Beide mit einem kleinen 3" Kugelspiegel mit 2,67" Pixelmaßstab gemacht. Ich würde meine unsystematische Rumprobiererei aber nicht zu hoch gewichten. Ich bin kein erfahrener Softwaretester. Vielleicht kommt hier noch qualifizierteres Feedback.

Ich wollte mal sehen, wie sich PSS an einem schwierigen Fall schlägt. Mein Eindruck ist, daß man mit PSS sogar etwas mehr Detail rückgewinnen kann, als mit AS3! (bis auf die Artefakte).

Gruß

Heiko

es geht mir nicht darum, "für Dich" ein Problem zu lösen. Wenn das Programm aber solche Artefakte wie bei Dir produziert, finde ich es wichtig, die Ursache (für uns alle) zu finden. Das "Entwanzen", wie Du es nennst, funktioniert ja nur, wenn das Programm mit Szenarien konfrontiert wird, die ich bei der Entwicklung nicht berücksichtigt habe. Bei meinen Testdaten gibt es ja keinerlei Probleme mehr. Sonst hätte ich das Programm überhaupt nicht auf die Allgemeinheit losgelassen. Nur kann ich aus Deinen Angaben keinen Anhaltspunkt für die Fehlersuche finden.

Ich kann jetzt also nur abwarten, ob andere Nutzer dasselbe Problem haben und mir eine genauere Situationsbeschreibung schicken bzw. den Inputfile zur Verfügung stellen.

Schöne Grüße
Rolf
 

Rolf_Hempel

Mitglied
Hallo Ronald,

Hallo Rolf,

auch ich habe mich mal an PSS0.5.0 versucht. Wenn man bereits mit dem Thema Stackingsoftware Kontakt hat, ist dein PSS sehr intuitiv zu bedienen und bei den einzustellenden Parametern enstehen keine Fragen - besonders wenn man viel mit AviStack gerarbeitet hat.
Auf meinem (mobilem) Testsystem keine Probleme:
i3, 4Gb, 250Gb SSD, 1366*768. Aufnahmedatei: 4000Bilder von ASI120M-S, SER-File per PIPP in AVI gewandelt, Videogröße 4,8Gb - also wären Dateigrößen >4Gb wahrscheinlich kein Problem.

Eine Frage habe ich: kann man auch ein einzelnes TIFF in den PSS laden, um ausschließlich die Waveletschärfung zu nutzen?

vielen Dank für Deine Arbeit - meine letzten Programmieraktivitäten fanden unter Turbopascal, dBase und sogar noch aus Spaß Fortran77 statt :D - Ronald
vielen Dank für das positive Feedback! Es freut mich, dass Du die Bedienung intuitiv findest. Genau das war mein Ziel bei der GUI-Entwicklung!

Hast Du das Ergebnisbild (nach der Schärfung) daraufhin angeschaut, ob es solche Artefakte wie bei Heiko gibt? Das wäre extrem wichtig für mich zu wissen.

Und ja: Du kannst einzelne TIFFs als Jobs laden. PSS erkennt sie automatisch als "Postprocessing"-Jobs. Schließlich kann man ein einzelnes Bild ja nicht stacken. Wenn Du dann auf "Start / Continue" drückst, öffnet sich sofort der Schärfungs-Dialog. All das ist im User-Guide im Detail beschrieben.

Schöne Grüße
Rolf
 

Ronald_Stenzel

Mitglied
lange_wand_pss_050.jpg

hier mal des erste Ergebnis mit dem PSS 0.5.0. - fokale Aufnahme mit dem Intes MK67
 

Rolf_Hempel

Mitglied
Hallo Ronald,

vielen Dank für das schnelle Feedback! Da fällt mir ja ein Stein vom Herzen. Dein Bild sieht gut aus! Wirklich keinerlei sichtbare Artefakte.

Dann warten wir mal ab, was die anderen schreiben.

Schöne Grüße
Rolf
 

DocHighCo

Mitglied
Hallo Rolf,

es ist mir klar, daß Du das Problem nicht nur für mich lösen willst. Ich will nur nicht den Eindruck erwecken, daß ich hier eine schnelle Antwort erwarte. Wenn Du mir über PN ein e-mail-adresse gibst, könnte ich Dir zumindest ein verkürztes Video, einen Rohstack davon, ein stark geschärftes Bild auf dem man die Artefakte schon am Rand sieht, das Stacking-log und das .PlanetarySystemStacker.ini-file schicken. Würde das helfen? Vielleicht sonst noch eine Information?
Privat Zugriff auf einen Server habe ich nicht.

Gruß

Heiko
 

Ronald_Stenzel

Mitglied
Hallo Rolf, hallo Heiko,

ich habe mal versucht, Heikos Problem zu provozieren, da ich einen Verdacht hatte - und ja, ich kann dieses Raster, bzw. die sichtbaren AP-Überlappungen mit entsprechendem Rohmaterial auch "erzeugen"
Es scheint eine Kombination aus schlechtem (Seeing/Schärfe) während der Aufnahme und fixen Strukturen, welche objektunabhängig sind - z.B. Staubkringel, Sensorschmutz.
Ich habe mal ein eher unterdurchschnittliches (mießes Nachmittagsseeing über aufgeheizter Stadt) Ha-Sonnenvideo mit gut erkennbaren Sensorfenster-Staubflecken durch den PSS geschickt.
Dabei habe ich dann mal die automatisch kreierte AP-Map dahingehend geändert, dass ich die Staubkringel manuell deselektiert, bis auf einen den ich übersah. Das Ergebnis - um den nicht deselektierten Fleck ist erkennbar der Effekt von Heiko aufgetreten.
Unterhalb der aktiven Region/Sonnenfleck ist der nicht deselektierte Staubkringel, links weiter unten der manuell deselektierte Staubkringel. Ich habe das Bild mal in FW übertrieben geschärft um den Effekt deutlicher zu machen. Und es ist im original nur ein Staubkringel - im Endbild erscheint er doppelt. Aber auch neben den, aus der automatischen AP-Map deaktivierten Kringel ist irgendwie ein "Geisterkringel" zu erahnen.

Ich hoffe, die Ausführungen helfen weiter, dem Effekt auf die Schliche zu kommen.

viele Grüße - Ronald
Sonne Ha_171328_pipp_pss_gpp_2.jpg
 

komposer

Mitglied
Hallo Rolf,

erst einmal meinen Respekt und Annerkennung für Dein tolles Projekt.
Ich bin heute zum Testen gekommen. Ich hatte dafür extra ein Avi vom Krater Copernicus 13.05.19 auf der Fetsplatte gelassen.

1. Installation
Lief unter Windows 7 64bit prof. ohne Probleme ab.

2. Testavi
Das Avi ist direkt von der Aufnahme mit Firecapture und meiner Asi120mm.
Auswählen und klicken auf OK geht aber wenn ich dann auf Start drücke stürzt das Programm ab.
Umweg über Pipp - Absturz
Umweg über virualdub
video color depth
1. same as decompression format - Absturz
2. greyscale oder Luminanz (Y8) - Absturz
3. 24bit RGB - Fängt an einzulesen aber bei 89% wieder Absturz. Datei hatte durch umwandeln in RGB ca 3fache Größe um die 2 GB.
4. Ein paar schlechtere Frames manuell entfernt dann abgespeichert als 24bit RGB ca. 1,5GB - Läuft durch ohne Absturz.

Jetzt habe ich das direkt mit autostakkert2 verglichen. APs jeweils 70 und 41% gestackt. Dann in fitswork identisch bearbeitet.
Ergebnis:
1. autostakkert
Moon_221727_130519test_g3_b3_ap152_6.jpg

2. PSS
Moon_221727_130519testrgb_pss_6.jpg


Ziemlich ähnliche Ergebnisse.

Anmerkungen:
Warum das umgewandelte RGB läuft aber Mono nicht ist natürlich problematisch. Das Umwandeln kostet Zeit und die Datei wird 3mal so groß.
Eigentlich wollte ich 40% stacken, ging aber nicht egal wie sanft ich den Regler bewegt habe.

Gruß,
Holger
 

Rolf_Hempel

Mitglied
Hallo Freunde,

vielen Dank für Eure interessanten Beiträge!

Zunächst zum Sonne-Beispiel von Ronald: Das ist wirklich interessant. Ehrlich gesagt weiß ich noch nicht so recht, wie ich mit diesen riesigen ortsfesten Staubkringeln umgehen soll. Gerade bei einer ansonsten wenig strukturierten Fläche wie der Sonne dominieren sie natürlich einen AP, so dass die lokale Verschiebungsmessung unweigerlich 0 liefert (weil sich der Kringel ja nicht bewegt). Das könnte prinzipiell auch die Linienartefakte erklären, weil immer exakt dieselben Pixel aufaddiert werden, was sonst praktisch nicht vorkommt. Ich habe ein paar Ideen, wie mein Programm das automatisch erkennt. Aber das wird nicht mal so eben gehen. Was passiert eigentlich bei den "etablierten" Programmen wie AutoStakkert!3 oder AviStack2 in diesem Fall? Wenn da alles gutgeht, müssen die Autoren ja eine Lösung gefunden haben. Oder hast Du da auch manuell die entsprechenden APs gelöscht?

Hallo Holger: Wie jetzt vielfach diskutiert wurde, ist der Videoimport in PSS bisher wirklich nur ein erster Schnellschuss. Nur .avi, und dann auch nicht alle Varianten. Hier muss ein deutlich schlaueres Importmodul entwickelt werden. Insbesondere betrifft das den Mono-Import. Die einfache OpenCV-Routine, die ich zum Import verwende, erstellt automatisch ein Dreikanalbild im Speicher, so dass mein Programm von da an im RGB-Modus arbeitet. Wären die importierten Frames reine Graustufenbilder, würde mein Programm bis zum Speichern des Ergebnisses durchgehend monochrom arbeiten. Also: Nur der Import muss korrigiert werden.

Übrigens kannst Du den Parameter "Percentage of best frames to be stacked" (wie alle anderen Parameter auch) nicht nur mit dem Slider grob verstellen. Wenn Du mit der Maus links oder rechts von dem Slider-Knopf klickst, verstellt sich der Wert in minimalen (in diesem Fall 1%) Schritten. Im interaktiven Modus kannst Du später in dem View, wo die Frames nach Qualität sortiert angezeigt werden, auch die Stacking-Prozentzahl ("Percentage") eingeben. Hier kannst Du entweder die kleinen Pfeile zur Verstellung verwenden, oder die Zahlanzeige mit dem Mausrad vor- bzw. zurückstellen, oder in der Zahlanzeige einfach eine andere Zahl eintippen. Also viele Möglichkeiten, die 40% einzugeben.

Zumindest ist es ja beruhigend zu sehen, dass bei Deinem schönen Kopernikusbild die Qualität von PSS und AS3 praktisch identisch ist. Das gibt mir Hoffnung, dass es sich bei den aktuellen Problemen wirklich nur um "Kinderkrankheiten" handelt.

Interessant wäre übrigens die Frage, ob Ihr den Parameter "Data Buffering Level" auf 0 gesetzt hattet, wenn es zu Abstürzen beim Import kam. In diesem Fall könnte man wenigstens einen Memory-Überlauf ausschließen.

Hallo Heiko: Ich werde Dir gleich eine PN mit meiner E-Mailadresse schicken. Die Informationen, die Du nanntest, würden mir schon weiterhelfen.

Schöne Grüße
Rolf
 

komposer

Mitglied
Hallo Rolf,

nein den Data Buffering Level hatte ich nicht verstellt aber daran lag es bei mir nicht, mit dem viel größeren RGB File ging es ja.

Die erzeugte Tif Datei war übrigens nur halb so groß wie bei autostakkert. Hat die anscheinend verwendete LZW Komprimierung keine Auswirkung auf die weitere Bearbeitung.

Gruß,
Holger
 

Ronald_Stenzel

Mitglied
Hallo Rolf,

ich habe das Ha-Sonnenvideo jetzt mal durch AS3 geschickt, ebenfalls Verwendungsrate 5% und AP-Feld von 40px. Ich habe bewusst keine Änderung an der automatisch generierten AP-Map gemacht - also nichts manuell deselektiert:
AS_stack_check_settings_2.jpg

viele Grüße - Ronald
 

Rolf_Hempel

Mitglied
Hallo Ronald,

vielen Dank für das Vergleichsbild. Ich nehme mal an, dass Du hier die Schärfung deutlich schwächer eingestellt hast als bei PSS. Ein Vergleich mit identischen Einstellungen wäre (ganz unabhängig vom Problem der Staubkringel) auch bei der Sonne mal interessant zu sehen.

Das mit den Staubkringeln in diesem Bild ist merkwürdig: Sie sind auch hier zu sehen, allerdings nicht doppelt. Ich vermute, dass mein Programm bei diesen APs Probleme mit der Verschiebungsberechnung hatte. Könntest Du bitte mal den Protokoll-Level auf 2 stellen und mir den Protokollfile zu diesem Beispiel schicken?

Durch Dein Beispiel habe ich übrigens noch einen Import-Fehler gefunden: Ich habe versucht, Dein Sonnenbild in meinen Postprozessor zu laden. Das ging schief, weil es sich um ein Graustufenbild handelt. Mein Importmodul geht im Moment auch hier noch von einem 3-Kanalbild aus. Intern ist aber alles auf S/W und Farbe vorbereitet. Ist also auch keine große Sache.,

Schöne Grüße
Rolf
 

Rolf_Hempel

Mitglied
Hallo Ronald,

so, jetzt habe ich auf die Schnelle den Postprocessing-Import gefixt: Dort kann man jetzt sowohl Grayscale als auch Farbe, jeweils mit 8 und 16 Bit Tiefe einlesen. Funktioniert auch in den weiteren Funktionen des Postprocessings.

Wieder ein kleiner Schritt vorwärts!

Schöne Grüße
Rolf
 

Ronald_Stenzel

Mitglied
Hallo Rolf,

ich wollte jetzt nochmal den Ha-Film mit dem PSS stacken - daBei ist mir etwas aufgefallen:
AS3 verlangt einen manuell markierten Ankerpunkt für die "Bildstabilisierung", PSS scheint sich ja da selbst zu kümmern - und das könnte der Krux sein. Ich habe mir mal das stabilisierte Bild näher angeschaut - es wurde augenscheinlich auf die Sensorflecken alignet :O
Das dürfte auch die Ursache für das unschärfere Bild aus dem PSS ggü dem AS3-Bild sein, da ich eigentlich beide ähnlich geschärft hatte.
Ich habe mal einen Screenshot nach erfolgtem Alignement angehangen.
screen_pss.jpg

könnte das eventuell die Ursache für die Artefakte sein?

viele Grüße - Ronald
 

Ronald_Stenzel

Mitglied
hier das Stackingergebnis - ohne Waveletschärfung, nur in FW eine Gauss-Schärfung, identische Werte wie beim AS3-Bild:
Sonne Ha_171328_pipp_pss_2.jpg
keine Artefakte sichtbar :)
Vllt. sollte das automatische Alignment standardmäßig besser deaktiviert sein?
Ich habe übrigens diesmal die automatische AP-Map NICHT manuell manipuliert/deselektiert.

viele Grüße - Ronald
 

Ronald_Stenzel

Mitglied
und hier nochmal ein Ergebnis aus dem PSS, Blick auf die Appeninnen, Kaukasus und die Alpen - wieder fokal mit dem MK67 :
Moon_201229_pipp_pss_gpp.jpg

Also ich habe nichts mehr auszusetzen :) - außer, dass ich nach dem Stacken eines Bildes den PSS schließen muss, bevor ich ein neues Bild bearbeiten möchte - sonst stürzt das Programm während des Ranking ab.

viele Grüße
 

Rolf_Hempel

Mitglied
Hallo Ronald,

schön, dass Du so erfolgreich warst! Hier ein paar Anmerkungen meinerseits:
  • Die automatische Frame-Stabilisierung war für mich der Anlass zur Entwicklung meines eigenen Programms. Ich hatte darüber mit dem Autor von AutoStakkert!3 korrespondiert. Er wollte es nicht in sein Programm einbauen, weil er nicht wüsste, wie es geht. Ich habe ihm dann sogar einen Algorithmus geschickt, darauf kam keine Antwort mehr. Für mich war das ein Problem, wenn ich ein riesiges Mondpanorama im Batch-Mode stacke und bei einigen Kacheln der Ankerbereich völlig daneben lag. Da AutoStakkert!3 Closed-Source ist, konnte ich die Änderungen auch nicht selbst machen. Nur deswegen gibt es jetzt PSS!
  • In allen meinen Tests hat die automatische Ankerpunktwahl bestens funktioniert. Sie ist sogar adaptiv: Wenn es mit einem Anker nicht klappt, versucht es PSS mit dem nächstschlechteren. Aber trotzdem habe ich die Option hinzugefügt, den Anker manuell zu setzen. Ich denke, der Default sollte "Automatik" bleiben. Nur die Leute (wie Du), die genau wissen, was sie tun, sollten das ausschalten können. (Ich bekomme dann weniger Problemmeldungen.)
  • Der Programmabsturz, den Du bekommst, wenn Du sofort ein zweites Bild bearbeiten möchtest, sollte natürlich nicht sein. In der "Produktionsversion" muss ich sowas noch abfangen. Ich könnte mir vorstellen, dass dieses Problem nicht auftritt, wenn du den Buffering-Level heruntersetzt.
  • Eine Nutzerin auf Cloudy Nights hat übrigens über sehr positive Erfahrungen im Vergleich zu AutoStakkert!3 bei der Sonne berichtet. So etwas baut richtig auf! Ein sehr guter Punkt in ihrem Bericht: Ich muss unbedingt noch den Support von Flats / Darks etc. hinzufügen. Mit Flats könnten z.B. die Staubkringel eliminiert werden, bevor sie Unheil beim Stacking anrichten! Was meinst Du? Ich denke natürlich zusätzlich nach algorithmischen Tricks nach, mit denen ich PSS robuster gegen solche Störungen mache.
Schöne Grüße
Rolf
 

Optikus

Mitglied
Hallo Rolf,

ich bin nur Mitleser, aber das ging mir bei dem Thema "Staubkringel" sofort durch den Kopf, ich hatte fragen wollen. Ich denke der Ansatz mit der adaptiven "Verankerung" des Stacks ist sehr spannend, gerade bei Videos, aber das Kalibrieren der Bilder sollte Dir da elementar helfen, auch weil es pixelgebundene Fehler allgemein reduzieren sollte.

CS
Jörg
 

Rolf_Hempel

Mitglied
Hallo Jörg,

vielen Dank für den Hinweis. Du hast sicher recht, dass ein Kalibrieren der Frames mit Flats die beste Lösung ist. Die Frage ist aber, was PSS tut, wenn der Nutzer dies nicht macht. Wenn es dann keinen Plan B gibt, bekomme ich "schlechte Presse". Daher denke ich, dass ich APs, wo die Shiftberechnung nicht richtig klappt, identifizieren und sie beim Ergebnis nicht berücksichtigen werde. Das sollte irgendwie gehen.

Schöne Grüße
Rolf
 

Optikus

Mitglied
Moin,

man könnte eine Art "Hintergrunds- oder Kontinuumsubtraktion" durchführen, quasi einen Offset bestimmen und abziehen, das könnte funktionieren, auch wenn es ein gewisses Maß an Signal kostet. Beim Stacken würden die wiederkehrenden Signale letztlich gewinnen.

CS
Jörg
 

Ronald_Stenzel

Mitglied
Hallo Rolf,

ein "Flatframe-Zwang" wäre eher ein Rückschritt.
Wenn es die Zeit und das Wetter hergibt, mache ich z.B. automatische Flatkorrektur bei Detail-Ha-Aufnahmen der Sonne - schon alleine um die Newtonringe zu reduzieren, während(!) der Aufnahme (das bedingt aber einen entsprechend großen und möglichst strukturlosen Bereich auf der Sonne). Bei Mondaufnahmen verzichte ich komplett auf Flatkorrekturen.
Interessant wäre, wenn Heiko sich nochmal äußern würde, ob die Artefakte bei Nutzung eines manuellen Ankers sich reduzieren...
Eine Möglichkeit wäre ja evtl., dass nach dem Ranking das schlechteste Bild ausgewählt wird (da sind diese Probleme am besten sichtbar) und man dort die Möglichkeit hat, sichtbare statische Sensorkringel zu markieren und diese "Kringel-Map" dann für alle AVIs, welche sich im Jobmanager befinden angewandt wird und somit als Alignmentanker nicht genutzt werden?

viele Grüße - Ronald
 

DocHighCo

Mitglied
Hallo Rolf,

mir gelingt es beim besten Willen nicht mehr mit einem Ausschnitt die Artefakte im Stack für das bessere Video zu reproduzieren. Aber ich habe einen Verdacht. Wenn ich das .ser-file mit PIPP ohne Anker nach Qualität sortiere und als .avi abspeichere, dann hüpfen die Frames relativ stark von Bild zu Bild hin und her. PSS kommt gar nicht bis zum Alignment-Punkte setzen, sondern steigt vorher aus. Mit Anker läuft alles gut durch. Könnten es daran liegen, daß, wenn die Frames etwas weniger hüpfen, es dann zu den beobachteten Artefakten kommt?

Gruß

Heiko
 

Rolf_Hempel

Mitglied
Hallo Heiko,

schade, dass sich das Problem mit den Linien im besseren Video nicht mehr reproduzieren lässt. Das war ja schon ein besonderes Problembeispiel, das ich bisher nirgendwo sonst beobachtet habe.

Ich glaube nicht, dass PSS Probleme bekommt, wenn die Frames zu wenig hüpfen. Tatsächlich ist es eher problematisch, wenn der Versatz zwischen zwei Frames sehr groß ist. Ich messe immer nur den Versatz zwischen zwei direkt hintereinander aufgenommenen Frames. Da die ja kaum eine Fünfzigstelsekunde auseinderliegen können, sollte der nicht sehr groß sein. Wenn aber doch, kann die Framestabilisierung im "Surface"-Mode unter Umständen in ein lokales Optimum rutschen. Ist mir bei meinen Videos noch nie passiert, würde aber die "Doppelkrater" erklären.

Schöne Grüße
Rolf
 

DocHighCo

Mitglied
Ich glaube nicht, dass PSS Probleme bekommt, wenn die Frames zu wenig hüpfen. Tatsächlich ist es eher problematisch, wenn der Versatz zwischen zwei Frames sehr groß ist ...

Hallo Rolf,

ja genau das meine ich ja. Die Frames hüpfen stark. Das kommt durch das Sortieren der Frames nach Qualität im PIPP. Da kommt dann eventuell ein Frame vom Anfang des Videos neben einem Frame vom Ende des Videos zum Liegen und der Versatz ist sehr groß.

Gruß

Heiko
 

Rolf_Hempel

Mitglied
Hallo Ronald, hallo Jörg,

vielen Dank für Eure Überlegungen. Ganz so einfach ist das mit der Staubkringelelimination nicht. Vor allem muss ich dabei auch bedenken, dass die Prozessierung nicht sehr viel mehr Zeit kosten darf. Es ist jetzt schon so, dass AutoStakkert!3 etwas schneller ist als PSS. Solange die Bildqualität bei PSS etwas besser ist, werden Nutzer das akzeptieren. Viel langsamer darf PSS aber nicht werden.

Ich denke, dass ich mir den Umstand zunutze machen werde, dass die globale Frame-Stabilisierung und die lokalen AP-Verschiebungsmessungen unterschiedliche Mechanismen benutzen. Wenn in einem AP die Messung von einem Staubkringel dominiert wird, sollte die Verschiebungsmessung die Frame-Stabilisierung genau aufheben. Und das in jedem Frame. Die Wahrscheinlichkeit, dass dies durch das Seeing kommt, ist praktisch gleich Null. Das könnte ich leicht und schnell herausfinden und dann den AP eliminieren. Irgendwann probiere ich das mal aus.

Morgen muss ich allerdings erstmal für drei Tage auf Dienstreise nach Oberpfaffenhofen. Also Pause für PSS.

Schöne Grüße
Rolf
 

Rolf_Hempel

Mitglied
Hallo Heiko,

Hallo Rolf,

ja genau das meine ich ja. Die Frames hüpfen stark. Das kommt durch das Sortieren der Frames nach Qualität im PIPP. Da kommt dann eventuell ein Frame vom Anfang des Videos neben einem Frame vom Ende des Videos zum Liegen und der Versatz ist sehr groß.

Gruß

Heiko
dann hatten wir aneinander vorbeigeschrieben. Das ist in der Tat ein gravierendes Problem! PSS funktioniert nur, wenn die Frames im Video nicht umsortiert werden. Kann man die Sortierung in PIPP nicht ausschalten?

Schöne Grüße
Rolf
 

DocHighCo

Mitglied
Hallo Rolf,

ja das kann man einstellen. Ich mache das ab jetzt und schaue, daß ich einen geeigneten Anker zur Bildstabilisierung in PIPP auswähle. Das macht es den nachfolgenden Stackingprogrammen einfacher.
PSS ist jetzt schon sehr gut. Ich freue mich darauf, es weiter auszuprobieren.

Gruß

Heiko
 

komposer

Mitglied
Hallo,

bei schlechten Bedingungen nehme ich viel mit Pause / Rec im Wechsel auf und warte auch mal mehrere Sekunden auf bessere Momente. Durch meine manuelle Nachführplattform kann da dann schon mal ein plötzlicher Versatz entstehen. Oder wenn Wind mit ins Spiel kommt. Da hüpft das Bild auch mal hin und her.
Insgesamt kommt es aber bei mir recht selten vor, dass ein Avi so schlecht ist und Autostakkert damit nicht klar kommt und dann hilft mir immer der Umweg über Pipp. Die Surface Stabilisation arbeitet da sehr gut.
Das muss also PSS eigentlich nicht leisten können und wäre für mich nicht so wichtig.

Gruß,
Holger
 

Rolf_Hempel

Mitglied
Hallo Heiko, hallo Holger,

natürlich könnt Ihr die Stabilisierung auch in PIPP machen. Aber es wäre für PSS-Tests natürlich auch interessant zu erfahren, wo die Grenzen von dessen Stabilisierung liegen. Ich hatte eine Weile mit verschiedenen Algorithmen experimentiert. Die einfachste und robusteste Stabilisierungsmethode ist "Planet", aber da muss das Objekt überall von Himmel umgeben sein. Bei Mond und Sonne verwenden die meisten Programme eine einfache Kreuzkorrelation. Der Vorteil ist, dass dies auch bei größeren Sprüngen gut funktioniert. Der Nachteil, dass es manchmal zu Fehlern kommt, insbesondere wenn ein abrupter Rand durchs Bild läuft. Deswegen hatte ich mich schließlich für einen lokalen Optimierungsalgorithmus mit "Steepest-Descent"-Technik entschieden. Der ist sehr robust, solange die Verschiebungen klein sind. Die perfekte Methode für alle Fälle ist schwer zu finden.

An den Fall, dass Benutzer die Videos mit der Pause-Taste unterbrechen könnten, habe ich ehrlich gesagt nicht gedacht. Schon wieder etwas gelernt!

Was die automatische / manuelle Ankerauswahl angeht, würde ich empfehlen, es erstmal mit der Automatik zu probieren. Ich glaube nicht, dass die Probleme, die Ihr hattet, damit zu tun hatten. Im übrigen kann man sich ja in PSS den stabilisierten Film anschauen. Wen es da keine Sprünge gibt, hat die Stabilisierung funktioniert.

Schöne Grüße
Rolf
 
Oben