Raspberry Pi 5 - Fallstricke bei Installation

Für den Einbau einer 2280 SSD unter dem RPI 5 gibt es bald eine Platine, hält einen USB 3 Port frei und stört nicht im Bereich der Hats. Jeff Geerling beschreibt auch, wie man PCIe auf Gen 3 umstellen kann und was es im Benchmark bringt. 4 TB SSD sind ja bereits recht bezahlbar geworden.
 
Klingt verlockend. Gibt's irgendwo auch ein Gehäuse dafür? Denn das Teil komplett offen draußen lassen - hmm...
 
4 TB SSD sind ja bereits recht bezahlbar geworden.
Hallo Arnold,
wie viele Wochen willst du denn da ablichten? Das dauert, bis die voll sind. :cool:

BTW: Alleine meine selbstgebaute HAT vom Pi4 passt ohne Probleme auf dem Pi 5, fehlt nur noch die runde SW ala Kstars. Dann wird umgebaut. Selbst das Uhrenproblem ist keines, muss nur darauf achten, welche RTC ich ansprechen muss.
Einzig das Nachrüsten der UFL Buchse für Wlan und BT Antenne extern wird wieder eine elende Fummelei :ROFLMAO::ROFLMAO::ROFLMAO:
 
Zuletzt bearbeitet:
Hallo Thomas,

falls es mit der Sonnenbeobachtung am RPI 5 klappt, fallen bei mir große Datenmengen an. Ein Scan der Sonne mit dem Sol'Ex (16x sideral) dauert etwa 10 sec und liefert über 2 GB an Daten: 10sec * 300fps * 3000 * 120 pixel * 2 Byte/pixel. Selbst wenn ich verdichte und nur über Wellenlänge und Ort speichere, sind es immer noch etwa 1 GB pro 3D Spektrum. Da kommt schnell was zusammen, Video ist unersättlich :cool::cool:.
@openfuture:
Es gibt kein spezielles Gehäuse, aber wenn man beim GeekPi Kühler unter der RPI5 Platine die M.2 Platine mit kurzen Spacer befestigt, wird der seitliche Schlitz nur etwas größer. Da sowieso für Spannungswandler, Sonderelektronik und Kabelführung noch ein engmaschiges Schutzgitter darüberkommt sollte es passen. Bilder gibt es erst gegen Jahresende, die M.2 Platine geht erst in Fertigung ;).
 
Hallo!

Um die Steuerung der Taukappenheizung weiter zu nutzen, musste ich die Bibliothek von rpi.GPIO auf GPIOZERO wechseln. Die Ansteuerung ist dabei einfacher geworden, den Code musste ich anpassen. Grund dafür war, dass rpi.GPIO noch nicht wirklich auf dem 5-er nutzbar ist.

Bei beiden Beispielen Tastverhältnis 50% mit 100Hz Takt. (100Hz sind bei GPIOZERO Vorgabe

Beispiel rpi.GPIO:
Python:
import RPi.GPIO as GPIO
K1 = 6    #GPIO 6
FRQ=100  #PWM-Frequenz
K1DC=50  #(Tastverhältniss)

GPIO.setmode(GPIO.BCM)
GPIO.setup(K1,GPIO.OUT)
K1W = GPIO.PWM(K1,FRQ)
K1W.start(K1DC)

Beispiel gpiozero:
Python:
from gpiozero import PWMLED
K1 = 6  #Kanal 1 - GPIO6
K1DC= 50  #Tastverhältniss

K1W = PWMLED(K1) # K1
K1W.value = K1DC/100
 
Hallo!
Weitere Baustellen tun sich da auf. Die Wetterstation läuft unter Bullseye problemlos über Bluetooth. Schnittstelle rfcomm einrichten, Kstars/EKOS starten, Verbindungen der einzelnen konfigurierten Geräte initiieren, Wetterstation verbindet sich unterm Pi4 automatisch wie gewohnt.
Beim 5-er klappt das aktuell nur mit den GPS Quellen. Ein cat /dev/rfcomm0 (Wetterstation) führt auch zur einer Verbindung, kann sie aber nicht mit EKOS nutzen. Mal sehen woran das nun wieder liegt.
 
Thema NVME:
Beim Amazon gibt es mittlerweile auch ein M.2 HAT, zwar noch nicht lieferbar, aber immerhin. Für Testzwecke ideal, mal sehen ob diese auch als Unterbau zu verwenden ist.
 
Sollte mit kurzen Spacern eigentlich funktionieren, hätte die SSD im Stapel innen. Aber die will man eh nicht öfter tauschen. Sonst ist von Geekworm für unten das Bottom Board gedacht. Bei den passiven Gehäusen geht es auch weiter, jetzt mit allen Öffnungen. Bin aber im Moment froh, das mein RPI5 vom Pine Board bootet und mit der 2TB SSD Platz und Geschwindigkeit bietet. SD Karte ein- und ausstecken ist aber lustig und das Board 5mm länger als der passive Kühlkörper. Explaining Computers zeigt das Ausstecken am Ende des Videos.
Clear Sky, Arnold
 
Wie sieht es eigentlich mit dem Wlan aus? Das ist ja beim Pi4 nicht wirklich toll...

Gruss David
 
Wie sieht es eigentlich mit dem Wlan aus? Das ist ja beim Pi4 nicht wirklich toll...
WLAN habe ich bisher keine Einbußen entdeckt, muss aber auch gestehen, dass Mangels vernünftig funktionierender Plattform und Witterungsmöglichkeiten ein Test unter Realbedingungen noch nicht stattgefunden hat.
Seit Weihnachten mussten wir uns hier 2x mal mit sowas (siehe Anhang)beschäftigen, zum Glück alles privat händelbar, die Betroffenen in Niedersachsen und Nordthüringen haben es da wesentlich schlimmer erwischt
 

Anhänge

  • IMG_20231224_081611.jpg
    IMG_20231224_081611.jpg
    163,8 KB · Aufrufe: 42
  • IMG_20240104_115757.jpg
    IMG_20240104_115757.jpg
    566,6 KB · Aufrufe: 46
Die NVME HAT's für den Pi5 werden zahlreicher.
Mittlerweile gibt es auch einen für die Montage unten. Man kann dann somit sogar passiv kühlen.
 
Versuch NVME zu booten:
Ging aktuell voll nach hinten los. :unsure::cry::eek:
Folgende Vorbereitungen getroffen:
1. /boot/firmware/config.txt folgende Zeilen hinzugefügt: dtparam=pciex1 zuerst auf der SD-Card, nach einem Neustart wird dann die NVME als /dev/nvme0n1 erkannt und kann angesprochen werden (siehe Anleitung hier)
2. mit SD-Card-Kopier die SD-Card auf die SSD geklont
3. Neueste Boot-Firmware 2712 installiert und aktiviert (Hinweise hier)
4. Bootfolge geändert mit raspi-config
5. nach "sudo poweroff " SD-Card entfernt
6. voller Erwartungen versucht neu zu booten mit einer WD SN 570, tja und das war's dann

Vermutlich hängt es an der WD SSD, probiere ich mal mit einer anderen SSD, oder der HAT ist dafür nicht geeignet ...

BTW: Anbei die Bilder vom HAT mit einem neuen passiven Kühlkörper, der Hammer war ein Kupferaufsatz für den Prozessor, so was ungenaues flog gleich in die Ecke, selbst ein Abschleifen machte es nicht pass konformer, mehrere Zehntel Luftspalt machten einen geringen Wärmewiderstand im Ansatz gleich zu nichte.
 

Anhänge

  • IMG_20240130_184011.jpg
    IMG_20240130_184011.jpg
    255,1 KB · Aufrufe: 29
  • IMG_20240130_183941.jpg
    IMG_20240130_183941.jpg
    203 KB · Aufrufe: 29
  • IMG_20240130_183931.jpg
    IMG_20240130_183931.jpg
    281,6 KB · Aufrufe: 26
  • IMG_20240130_183919.jpg
    IMG_20240130_183919.jpg
    171,4 KB · Aufrufe: 30
Auf der Geekworm Wiki Seite sind einige SSDs gelistet, die mit dem Geekworm Interface inkompatibel sind, davon 3 WD SSDs. Es wird vom Phison Kontroller gewarnt, die SN570 sollte aber den SanDisk 20-82-10048-A1 drinnen haben :unsure:. Wenn der Tausch der SSD nichts bringt, könnte ich kurzfristig mit dem X1001 HAT und der KIOXIA EXCERIA SSD testen. Derzeit läuft sie am Pineberry Bottom HAT, muss mir noch ein paar Spacer und Schrauben besorgen.
 
Zum Vorbereitung auf NVME Einsatz mit dem RPI5, habe Ich bereits meine RPI5 Firmware, aufs neueste Stand ( neuer als Dezember 2023 ) upgedated und damit muss Ich wohl nicht mehr mit "config files" hantieren, nun warte Ich auf die Verfügbarkeit von NVME Base für meine RPI5, am liebsten will Ich direkt im Geschäft/Händler direkt kaufen ( nicht bestellen ).. CS Martin
 
2. Versuch booten von MVE: :):):)
eine Samsung EVO 970 plus, läuft, ergo Finger weg von WD SSD, solange das Thema nicht wirklich gelöst ist.
 
Fazit: Nutzen der SSD:
Die Bootzeit wird kaum verbessert, aber das System fühlt sich wesentlich flüssiger an. Die Startzeiten von Kstars, Chromium etc. sind wesentlich kürzer.
Nur der Energiespareffekt ist nun nicht mehr so gegeben, gegenüber der micro-SD Karte.
 
Hi Thomas,
welche Probleme hast Du mit dem internen Guider? Bei mir funktionierts normal (zumindest in 3.6.8 und davor).

Ich hatte, als ich von PHD2 zum Internen gewechselt hatte, das Gefühl, dass die Werte im Internen als schlechter angezeigt werden. Ich hatte mich da vorher schon mal drüber gewundert, weil im direkten Vergleich die Werte in PHD2 besser waren als die gleichzeitig in EKOS angezeigten Werte (wird ja im Analyzer und im "Guiding"-Tab angezeigt). Ich hab da aber keine Wissenschaft draus gemacht. Meine Sterne sind rund und fluffig :ROFLMAO: , passt ;)
 
Hallo Sepp,
ich nutze aktuell nur die Simulatoren, da man gefühlt zur Zeit nicht vor die Tür kann, es regnet mal wieder, der Werrapegel ist hoch, Wolken, Wolken, bedeckt, und das gefühlt seit Ende Oktober. Sobald Astroberry auf dem 5-er geht, baue ich einen AstroRaspi um und teste ihn im Feld.
Mit dem Guidingsimulator bekomme ich eine saubere Nachführung nicht gebacken, PHD2 läuft aber anstandslos.
 
Hi Thomas,
ach so, im Simulator. Da nutze ich das Guiding gar nicht, ich hatte da nur die Tage mal endlich den Scheduler getestet und vor zwei Wochen (da war einigermaßen klar und natürlich Vollmond) live getestet. Lief sogar ;-)

Und beim interenen Guider mußte ich mich etwas umgewöhnen, aber Gott sei Dank sind die Einstellmöglichkeiten zumindest ähnlich zu PHD2...

Ansonsten gehts mir wie Dir, ich hatte Mitte Januar mal zwei Tage ohne Vollmond, davor im Mitte September....
 
Ach so eins noch: Thomas, Du bist doch auch mit Opensuse unterwegs, oder täusche ich mich da? Wie/Wo installiert man da den GSC-Katalog für Kstars? Im Opensuse Repo von Astrophotography ist das nicht enthalten...
 
Hallo Sepp,
gsc kann man sich als .deb oder .rpm ziehen. Als .dep fehlt nocht dpkg, welche über Yast oder Zypper man nachinstallieren muss. Ich nutze dann zur Installation den Midnight Commander, gestartet mit root rechten.
Da kann man in die RPM oder DEP Files hineingehen und den Installationsprozess von Hand starten. Auf die Abhängigkeiten wird dabei geachtet, gsc data zuerst installieren. Leider taucht gsc nicht Installationskatalog auf. Muss wohl doch wohl mal ein gsc*.rpm von einer Feodora Distri holen.
Das Problem ist dabei immer, gegen welche glibc diese verlinkt ist. Da OpenSuSE leicht konservativ ist, muss man da mitunter suchen.
1707660609755.png

Die Version von gsc aus Ubuntu 20.04. läuft mit OpenSuSE 15.5
 
Ok, bis hier bin ich gekommen (starting Indi services):
20240211_15h04m33s_grim.png


weiter geht's da leider nicht.

Ich habe KStars über "Add/Remove Software" installiert.


Gruss David
 
Hi David,
astrometry sollte auch installiert sein und die gesamten Tycho Bibliotheken.
Du musst, bevor du unter EKOS die INDI Dienste startest, erstmals ein bisschen Equipment Anlegen.
Minimum ein Simulator Teleskop, Camera, Giuding,
1707664302666.png


Sonst wird das nix.
BTW: Dies ist aber wohl nicht so richtig ein Problem vom Pi 5, denn das System, wenn auch selbst compilert, läuft.
So sollte das dann aussehen:
1707664629464.png
 

Anhänge

  • 1707664615743.png
    1707664615743.png
    92,8 KB · Aufrufe: 17
Zuletzt bearbeitet:
Ich werde das ausprobieren. Ich war etwas erstaunt, dass die Installation gemäss den Instruktionen von der Indilib-Seite nicht funktionierte. Bei der Installation der Indi library kamen Fehlermeldungen. Beim Raspi 4 (leider ist der abgeraucht...) funktionierte das einwandfrei. Ok, es beruhigt mich zu wissen, dass es auf dem Raspi 5 läuft.

Gruss David
 
Oben