[Software] GRAVES Radar mit Spectrum Lab - automatisch loggen | Seite 4 | Astronomie.de - Der Treffpunkt für Astronomie
  • Wartungsarbeiten am 24.09.2021 von 20.00 Uhr bis 21.00 Uhr

    Am Samstag, den 24.09.2021 wird in der Zeit von 20.00 bis 21.00 Uhr ein neues Update (Patchday) der Forensoftware eingespielt.
    In diesem Zeitraum wird das Forum in den Wartungsmodus versetzt.

    Vielen Dank für Euer Verständnis
    Euer Moderatorenteam

[Software] GRAVES Radar mit Spectrum Lab - automatisch loggen

JTorhoff

Mitglied
Moin Okke,

am Laptop hatte ich es auch schon, dass der SDR Stick nur an dem Port erkannt wurde, an dem er erstmalig angemeldet wurde. Auf den anderen Ports "stellt er sich tot".

Wie du schon sagtest: PC ist wenn es trotzdem funktioniert :rolleyes:
 

Optikus

Mitglied
Moin,

das liegt teilweise an den Treibern. Manche Geräte hinterlassen nach der Installation Dateien die die erstmalige Anmeldung quasi protokollieren und die Kommunikationsdaten hinterlegen. Bei mir hilft (Win10) dann, das betreffende Gerät zu entfernen und dann neu zu installieren bzw. einzustöpseln, installieren wird es sich i.d.R. ja von selbst bzw. seinen Installationsdatenträger anfordern.

CS
Jörg
 

Okke_Dillen

Mitglied
Hmm, es gibt sie mit i5ern und i7ern, aber mit 15W TDP... weiß nicht, ob die Prözze heutzutage so effizient sind... könnte sein... oder auch nicht :unsure: Bin da echt nicht up to date... und teuer. Dann Windoof10...:rolleyes: Obwohl, Ubuntu läuft auch. War da nicht was mit SpecLab und Linux?

Wenn aber dein Echoes auf PI läuft und loggen kann (mit Screenshot und Zeitstempel) und noch ein paar analytische Möglichkeiten mitbringt, wäre das mein Favorit.

Z.Zt. isses SpecLab. Das ist zwar etwas "sperrig", aber sehr mächtig. Braucht halt Windows...

LG Okke
 

Optikus

Mitglied
Moin,

die NUC's gibts mit unterschiedlichen Prozessoren, da musst Du mal sehen was Du bekommen kannst. Ich denke ein "i" muss es sein, ein Atom dürfte nicht reichen. Selbst ein I3 oder I5 hat mehr Rechenleistung als ein normaler PI, wobei ich den aktuellen PI4 schlecht einschätzen kann.

CS
Jörg
 

Okke_Dillen

Mitglied
Jou, deswegen habsch gleich Richtung i5..i7 gesucht. Die waren mit um 15W TDP angegeben :oops:
Das ist wenig, mein Läppi will 40W, wenn SL läuft. Um 10W wenn nicht. Ok, isn alter i5, 4 Kerne. Ich denke, daß die umfangreiche Signalanalyse-"Maschine" die vielen Resourcen schluckt. Weswegen sie auf einem PI auch nicht laufen dürfte, wie du ja schon schriebst.

Na, da hab ich noch Input-Bedarf. Jedenfalls muß die Kiste 24/7 rennen können, ohne mich mit Lüftern desnächtens vollzudröhnen ;)

Grüße
Okke
 

JTorhoff

Mitglied
Moin Okke,

ich Sachen PC Technik habe ich vor ca. 10 Jahren aufgehört den Markt zu verfolgen. Daher habe ich einen Kollegen (IT'ler) um Rat gebeten und der hat vom NUC abgeraten. Meine ersten Überlegungen für einen "GRAVES-PC" gingen nämlich auch in Richtung NUC. Aber vernünftig ausgestattet sind die Teile einfach zu teuer. Es ist dann ein DELL Optiplex 3070 geworden, der auch nicht viel mehr gekostet hat (<100 Euro Differenz), aber richtig Dampf hat. Da läuft Speclab im Hintergrund und man kann ohne jegliche Verzögerung andere Dinge abarbeiten, bzw. sein Geld im Home Office verdienen ;)
 

Optikus

Mitglied
Moin,

aktuell gibt's ziemlich günstig von Panasonic gebrauchte Laptops marke Wetterfest, so um die 200€, die kann man im Dauerbetrieb laufen lassen und die sollte das Programm sicher abarbeiten können. Gibt's auch als Win-Tablets. Die kann man dann sogar draußen irgendwo unterbringen, sofern sie nicht gerade den Wetter ausgesetzt sind.

CS
Jörg
 

JTorhoff

Mitglied
...
Wenn aber dein Echoes auf PI läuft und loggen kann (mit Screenshot und Zeitstempel) und noch ein paar analytische Möglichkeiten mitbringt, wäre das mein Favorit.
...
Nur um das eben klarzustellen, damit keine Missverständnisse entstehen: Echoes ist nicht von mir, ich teste das nur ;)

Das Programm ist das beste in Sachen Logging was man sich vorstellen kann. So wird z.B. immer um Mitternacht ein Report Ordner für den vergangenen Tag angelegt. Dort befinden sich Unterordner für z.B. Screenshots und CSV Files. Die Screenshots werden unterteilt in "underdense", "overdense" und "fake". So wird einem das lästige Sortieren abgenommen. Insgesamt sehr mächtig, aber viel einfacher in Betrieb zu nehmen als SpecLab - UND: es läuft absolut flüssig auf dem Pi4
 

Okke_Dillen

Mitglied
Ahjetztja :cool:

Sodele, ich hab Echoes mal installiert aufm Atömchen und es läuft schomma. Stick und Antenne angestöpselt gleich erkannt, Signal da. Fein, soweit sogut.
Leider ist die Empfindlichkeit und die Abtastung nicht auf dem Niveau von SpecLab, sowohl mit "AutoGain" als auch auf 49,60. Kann aber auch sein, daß ich noch nicht die richtigen Knöppe gefunden hab.

Und, oh Wunder, es braucht mehr CPU als SL :oops::oops::oops:
58% mit Echoes und 48% mit SL... echt jetzt?
Hab SL wieder laufen 😇

Ok, der darf jetzt mal ne Nacht durchrennen, makukn, ob er's durchhält, ohne überzukochen...

Achja, weiß jemand, wie man SL sagen kann, es möge bitte ALLE Kerne/Threads benutzen und nicht nur 3/4?

MG Okke
 

Optikus

Mitglied
Ah...

Es gibt Freeware, die startest Du per AutoExec-Ordner beim Hochfahren, die kann jedem danach startenden Programm Kerne zuweisen, ob das aber für Dein Problem eine Lösung darstellt... Gute Frage. Wenn das ne Art Exklusivzuweisung ist muss ja zumindestens ein Kern übrig bleiben der das System fährt. TimeSharing wäre ja weniger kritisch, je nach dem wie viel Prozent der "Nutzprozess" und wie viel der "Rest" abgearbeitet wird. Dann könnten alle Kerne dran werkeln.

CS
Jörg
 

Okke_Dillen

Mitglied
Moin,

so, hab jünstich nen i5 auf ITX-Board in der Bucht geschossen - MIT Soundchip... :rolleyes: (mein vorhandener hat ja keinen... nix Soundchip, nix SpecLab!).

* an der Stelle ne Frage: es gibt auch diese ext. Soundkarten als USB-Stick. Würde das auch funktionieren? Oder muß die direkt aufm "großen" Bus sitzen?

---

Kommen wir aber jetzt zu etwas völlig anderem: Zeitstempel - mal wieder 🤣 Ich hab mich gestern nochmal mit dem Settingsfenster befasst und das Feld "Source" entdeckt. Die Bubble-Help meinte "frei lassen, wenn die default Zeitquelle verwendet werden soll" - sinngemäß. D.h. man kann hier auch andere Quellen angeben.

Gedacht, getan. Die Quelle ist die Variable "now" und darunter kann man das beliebig formatiert im WF ausgeben. Ohne das "now" träumt sich die Zeitangabe weg von der Realität und "hh:mm:ss" gibt irgendeine Zeit aus. MIT "now" wird die richtige Zeitangabe driftfrei angegeben:

es werde die korrekte Zeit.jpg


Voilà :geek:

MG Okke
 

Optikus

Mitglied
Gratulation.

Es gibt/gab auch Soundkarten mit PCI-Bus - in wie fern die noch am Markt sind UND zu Deinem Board passen kann ich Dir leider nicht sagen. Als USB kenne ich sowas nicht. Es gibt sowas wie man beim großen "A" oder auch in der Bucht feststellen kann, ob die aber die Systemfunktionen einer on Board Soundkarte abbilden weiß ich nicht.

CS
Jörg
 

Optikus

Mitglied
Moin,

ich denke aber die brauchts, damit man die Systemfunktionen nutzen kann. Muss aber zugeben, dass ich das auch noch nie in der Praxis versucht habe.

CS
Jörg
 

JTorhoff

Mitglied
...
Kommen wir aber jetzt zu etwas völlig anderem: Zeitstempel - mal wieder 🤣 Ich hab mich gestern nochmal mit dem Settingsfenster befasst und das Feld "Source" entdeckt. Die Bubble-Help meinte "frei lassen, wenn die default Zeitquelle verwendet werden soll" - sinngemäß. D.h. man kann hier auch andere Quellen angeben.

Gedacht, getan. Die Quelle ist die Variable "now" und darunter kann man das beliebig formatiert im WF ausgeben. Ohne das "now" träumt sich die Zeitangabe weg von der Realität und "hh:mm:ss" gibt irgendeine Zeit aus. MIT "now" wird die richtige Zeitangabe driftfrei angegeben:

...

Das ist interessant. Bei mir klappt es auch ohne "now" driftfrei. Aber wenn das Problem mal wieder auftaucht, weiß ich wo ich zuerst ansetzen werde ;)
Bedankt.
 

Okke_Dillen

Mitglied
Ha! Hab eine erwischt! Arlt hatte eine ASUS Xonar SE PCIe 5.1 mit angeblichen 116dB (!) SNR..... nunja, glauben ist ja erlaubt...:sneaky:

Ejaal, dat Dingen funzt und SpecLab flutscht nur so auf dem i5-Board. Ist ein i5-6500 @ 2,3GHz. SpecLab-Anzeigen laufen alle sehr flüssig und rund, gut!!
TskMgr meldet 19..20% Last unter SpecLab (nur der SL-Prozess) und so 21..22% Gesamtlast. Das klingt ja schön entspannt :cool:

Juhuuuu!!! :love:

Ok, 24/7-Logging ist nun eeendlich möglich!

Sodann, MG Okke
 

Okke_Dillen

Mitglied
Hallo Jörg (@JTorhoff ), sachma du hattest doch anfangs Gezuchtel mit der Plotausgabe, daß die zwar da war, aber nix anzeigte. Genau DAS hab ich grad auch, als letzte Baustelle. Weißt du noch, woran das lag?

Bei beiden anderen PCs (Läppi und Atom) liefs auf Anhieb...
Es ist alles tupfengleich eingestellt, jedes Häkchen etc verglichen. Nix... :unsure:

Häddschd e'mal 'en Tipp?
MG Okke
 

JTorhoff

Mitglied
Hi Okke,

nein da habe ich leider auch keinen Tipp für dich. Bei mir laufen weder der Plotter noch die Amplitude Bar vernünftig.
Deswegen habe ich beide ausgeblendet.

Vielleicht finden wir da ja gemeinsam eine Lösung ;)
 

Okke_Dillen

Mitglied
Hmmm.... 64bit? :oops:

Auf den 32ern gehts, aufm 64er nicht. Koinzidenz oder Signifikanz? :unsure: Das wäre aber schon schräg....
Isses bei dir etwa auchn 64bitterer?

Die Werte kommen ja rein in der Watchlist, es zappelt fröhlich. Nur die graf.Ausgabe will nicht......
 

JTorhoff

Mitglied
Genau so ist es bei mir auch, ebenfalls auf 64 bit.

Das kuriose ist ja, dass es funktioniert wenn man die original Comprehensive Settings nimmt. Normalerweise müsste es deswegen bei dir auch laufen. Meine Settings beruhen ja auf den einfachen Settings ;)
 

JTorhoff

Mitglied
PS: Ein klein wenig läuft es schon:
plotter.png

Blöd nur, dass die Linie kurz nach der Momentaufnahme verschwindet und von neuem beginnt. Es werden also nur ca. 20% des Fensters genutzt. Mir ist nicht klar wodurch das ausgelöst wird :unsure:

Der Trick war eigentlich nur im Watchlist Reiter die Scale "Min" / "Max" Werte anzupassen. Vielleicht ist es bei dir ja ähnlich.

Bin den Rest des Tages AFK.
 

Okke_Dillen

Mitglied
ich hab so das Gefühl, daß da ein externes Tool à la "NtGraph.ocx" oder so verwendet wird, um den Graph zu plotten und solche Konsorten können schomma zicken, wenn sie auf 32/64bit Unterschiede stoßen (SL ist ein 32bit Applikation)...
 
Oben