Projekt Raspberry 4 B gestartet | Seite 3 | Astronomie.de - Der Treffpunkt für Astronomie

Projekt Raspberry 4 B gestartet

Wintergatan

Mitglied
@elythomaslumber VNC ist sehr schlicht, dafür auf zahlreichen Betriebssystemen als Client und Server funktional. Solange man eine TCP-Verbindung hinbekommt, wird auch das VNC sich darin übertragen lassen. Der Weg über den Browser ist eher ein Plan-B, Zertifikate sind nicht nötig bei HTTP. Kannst du einen nativen VNC-Client einrichten, so wäre das zu bevorzugen. VNC läuft unabhängig von SSH. Mit SSH kannst du aber quasi alle Verbindungen tunneln und somit bei Bedarf auch Verschlüsseln.
Der Weg mittels X-Forwarding und SSH (ssh -XC)hat den Nachteil dass es weniger effizient ist und abgebrochene Verbindungen auch den Zustand des laufenden Programm verlieren lassen. XPRA löst dieses Problem und kann abgebrochene Verbindungen fortsetzen.
x11vnc lässt dich sowohl den gesamten Desktop bereit stellen, du kannst aber auch nur einzelne Fenster freigeben. Wenn dein Programmfenster dann aber weitere Fenster/Pop-Ups aufmacht, wirst du diese nicht sehen (es sei denn du nutzt spezielle Parameter.
Kurzum: VNC ist relativ narrensicher, robust und erfüllt seinen Zweck in fast allen Szenarios, die Lernkurve ist anfangs ein bisserl steil für Neulinge.
Wenn auf dem Ziel VMs im Einsatz sind, bevorzuge ich das SPICE-Protokoll;
Sehr einfach und extrem performant finde ich immer noch NoMachine. In meinen Augen sogar einfacher als VNC für Neulinge.
 

mbba18

Mitglied
Der Weg mittels X-Forwarding und SSH (ssh -XC)hat den Nachteil dass es weniger effizient ist
Sollte auch nur wegen der Vollständigkeit erwähnt werden.
Ist schon, soweit ich das in Erinnerung habe, etwas lahm.
Einzelne Fenster freigeben fand dich damals ganz witzig ;) .

Mit noMachine hab ich auch mal rumexperimentiert, warum ich davon abgekommen bin weiß ich dann auch nicht mehr.

Kurzum: VNC ist relativ narrensicher, robust und erfüllt seinen Zweck in fast allen Szenarios, die Lernkurve ist anfangs ein bisserl steil für Neulinge.
VNC ist wohl die beste Lösung und funktioniert gut.
Sollte auch für die Zwecke mit Astroberry o.ä. voll und ganz ausreichen.
 
@Wintergarten
ich glaube, ich muß mir das mal einfach installieren, damit ich das nachvollziehen kann. Bin nicht der LINUX / IT Crack. Primär geht es mir auch um den EInsatz von VNC speziell mit Astroberry, sprich simpel ausgedrückt "Was wird besser und was verliere ich ggf.?".
Bevor ich da VNC installiere, werde ich mir erst mal ein IMAGE machen; ich glaube, ein einmal installiertes VNC krieg ich nie wieder weg, falls es doch mehr Nachteile bringt. :rolleyes:

Da hier aber offensichtlich ein paar Linux Experten rumschwirren, möchte ich hierzu noch eine Frage loswerden, die noch wichtiger ist als die VNC Geschichte am Astroberry.
Nachdem ich mich da mühsam durchkämpfe bin ich nun beim essientiellen angekommen :rolleyes:

Ich habe erstmals meine EQ6R-PRO per USB an den RPi4 angeschlossen.
Leider kann ich den Anschluss in INDI nicht aktivieren. Bei näherer Untersuchung mithilfe von "dmesg -w" konnte ich herausfinden, dass beim EInstecken des RS232 nach USB Wandlers (mein GPS) dieses dem USB Port "ttyUSB0" (screenshot oben) zugewiesen worden ist (sehr schön).

Beim rausziehen und Einstecken des USB Kabels (direkt) von der Montierung in den RPi jedoch wird zwar das EInstecken registriert, aber kein USB Port zugewisen. (Screenshot unten)
Was kann man da machen?

(Stecke ich gleiches Kabel in meinen WIN10 und nutze eine ASCOM Treiber läuft alles wunderbar.)

Grüße
Hartmut
USB-seriell.jpgUSB-Montierung.jpg
 

GanymedRN

Mitglied
Ich habe das Gefühl das VNC auf dem Raspi flüssiger läuft als Teamviewer. Die Funktionalität ist sehr ähnlich wobei Teamviewer etwas einfacher zu verwenden ist wenn das Remotesystem außerhalb des eigenen Netzwerks ist.
Man muss bei Headless Systemen (also ohne Monitor) in der Datei /boot/config.txt ein paar Konfigurationswerte ändern/hinzufügen um sicherzustellen das der Desktop auch gestartet wird aber dann funktioniert es recht gut.
EKOS auf dem Raspi lässt sich auch direkt von EKOS auf einem PC steuern. Habe das schon ein paar mal gemacht, allerdings nur im eigenen Netzwerk.
Dazu gibt man in EKOS Profileditor die IP Adresse des Remotesystems (Fremdgerät) an.
 

Wintergatan

Mitglied
Beim rausziehen und Einstecken des USB Kabels (direkt) von der Montierung in den RPi jedoch wird zwar das EInstecken registriert, aber kein USB Port zugewisen. (Screenshot unten)
Code:
modprobe eqmod
Wenn man Trouble with the EQ6R-Pro USB Port and EQMOD verfolgt solltest du auch schauen mindestens einen 5.5er Kernel zu benutzen.
 
Danke Dir!!! :y: Ich war zwar in dem Forum, hab aber wohl die falschen Schlüsselwörter zur Suche genutzt.
Also so wie das aussieht, besteht noch die Chance durch ein rpi-update.

Da mach ich mir jetzt erst mal wieder ein BackUp....

Wenns dann nicht geht, ist mein Astroberry Projekt gestorben.:cry:
 
Sooooo, Projekt kann weitergehen... :) :sonnig::y::) rpi-update auf eines neues Kernel und die Montierung hat sich beim RPi erfolgreich angemeldet und läßt sich steuern! SUPI!

Grüße und nochmals Danke!
Hartmut
 

mbba18

Mitglied
Dann habe ich ja noch Hoffnung das meine EQ-6 R bei mir auch läuft.
Und.... das Beste... :y: mir ist die Lieferung meines Kabels angekündigt worden.
 
@mbba18
Ja, falls Du Deine Moni auch an einen Astroberry anschliessen willst, probier die Verbindung zur Monti mal als erstes aus, bevor Du Dich um irgendwas anderes wie GPS oder sowas kümmerst.

Mein Weg bis zu den 95% an features, die jetzt funktionieren, dauerte ein paar Tage mithilfe dieses und den INDI Forums.
Aber jeder Schritt zum Erfolg macht Spass. Hab es eben geschafft, auch SkySafari auf meinem iPAD mit der Monti über den Astroberry zu verbinden.
Die Einstellungen sind ziemlich "schräg" (Montierung MEADE LX200/GPS!).

Damit läßt sich meine EQ6 jetzt über INDI, EKOS, K-STARS, SkySafari, HandController sowie über WIN10 ASCOM steuern.
Man muß den HC übrigens gar nicht auf "PC-Betrieb" stellen. Das USB IF ist parallel aktiv und man kann es parallel bedienen, zumindest die Teleskopbewegung. Den Rest hab ich n.n. probiert. Die GPS Parameter werden aber leider nicht in den HC übernommen. :cautious: Da bastel ich aber noch dran...

So, mal sehen, auf welche Steuerungsvariante ich mich später mal in der Praxis einschiesse... :LOL: :saturn:

CS
Hartmut
 

mbba18

Mitglied
Hallo Hartmut,
Ja, falls Du Deine Moni auch an einen Astroberry anschliessen willst, probier die Verbindung zur Monti mal als erstes aus, bevor Du Dich um irgendwas anderes wie GPS oder sowas kümmerst.
Das war meine Idee, beide Montierungen über den Pi zu steuern und das über mein "Heim"netzwerk.
Die iOptron und die Asi funktionieren ja schon bestens.
Die iOptron ist richtig gut, die kann ich in beiden Modi, HotSpot (also eigenes Netzwerk) und WLAN (mein Heim-WLAN), betreiben. Hat ein schönes Webinterface in dem man das sauber konfigurieren kann.
Bin ich auf dem Acker, Tablet einfach auf den HotSpot einstellen, zu Hause auf dem Balkon alles übers WLAN-Netzwerk, sowohl Tablet wie Notebook aus dem Zimmer heraus.


Der SkyWatcher WiFi-Adapter bietet diese Funktion(en) grundsätzlich auch. Blos nicht beide Modi zusammen, wenn ich die Anleitung dazu recht verstanden habe.
HotSpot, also das eigen Netzwerk, funktioniert gut, aber ich bekomme den WiFi-Adapter nicht in mein WLAN.
Alle möglichen und unmöglichen ;) Variationen schon ausprobiert.
Deshalb die Hoffnung auf das Kabel :D, wenns dann funktioniert, solls mir auch recht sein.

GPS und evtl. andere Wünsche werden daran anschließend angegangen.
 

Wintergatan

Mitglied
HotSpot, also das eigen Netzwerk, funktioniert gut, aber ich bekomme den WiFi-Adapter nicht in mein WLAN.
Wenn du im 2,4GHz Bereich dein WLAN betreibst, prüfe ggf. ob du Kanal 12/13 aktiv hast - wenn ja, dann deaktiviere 12/13. Habe viele Produkte mit WLAN gesehen die bei internationaler Vermarktung sich nur bis Kanal 11 betreiben lassen. Die "sehen" dann zwar das Heimnetz, aber es kommt nie zu einer erfolgreichen Verbindung mit Datentransfer.
Und natürlich ist da noch die Frage, welchen Standard dein Access-Point als Minimum erwartet (Stichwort 802.11/b/g/n) und etwaiger MAC-Filter.
 
Problem mit dem WiFi Adapter, ja davon hab ich schon gehört... und guter Tip von @Wintergatan

Hier hab ich bei meinem Astroberry auch noch eine kleine Baustelle. Trotz Umstellung in den Einstellungen von 5GHz auf 2,4GHz bleibt er im 5GHz Netz.
Problem ist hier, dass der RPi4 einen sehr schwachen Pegel am Router liefert (denke, es ist die schlechte Antenne auf dem board). Da kommt er bei mir je nach Position nur mit -83dBm an. Beweg ich mich dann durchs Funkfeld, gibts schon mal einen Abbruch. Am Heimnetz will ich nichts ändern. Ich hab das mal im INDI Forum gepostet, den eigentlich sollte er sich umstellen lassen.
 

Wintergatan

Mitglied
Trotz Umstellung in den Einstellungen von 5GHz auf 2,4GHz bleibt er im 5GHz Netz.
Wenn die SSID in deinem Access-Point für 2,4GHz und 5GHz gleich benannt bleiben soll, ist das auch ok. Um deinen Astroberry-Client dennoch in einen bestimmten Modus zu zwingen, prüfe doch mal ob du in den Einstellungen (nm-connection-editor) die BSSID eintragen kannst. Denn typischerweise hat ein Access-Point für jedes Interface eine einmalige BSSID, also eine konkrete Möglichkeit der Unterscheidung von dem 2,4GHz und dem 5GHz Interface. Andere Wege können sein, dass du das Modul für deinen Wifi-Adapter in einen Modus per Parameter zwingst.
Was ist deine Ausgabe bei
Code:
grep ^REGDOMAIN /etc/default/crda
?
 

mbba18

Mitglied
Hallo zusammen,

danke für die Tipps :y:.

Wenn du im 2,4GHz Bereich dein WLAN betreibst,
das passt alles.

Grundsätzlich funktioniert das Teil ja über seinen AP Modus, in dem die IP ja fest verdrahtet ist.
Wie es scheint nimmt er die Daten für den Stations Modus nicht an, also SSID und Passwort für mein WLAN.
Weder in Kombination über DHCP oder über fester IP.
Entfernung Router SW-WiFi-Adapter keine 2m.
Notebook zu SW-WiFi-Adapter auch keine 2m.
Der Pi liegt fast auf der Montierung :D.

Das Netzwerk vom AP Modus ist und bleibt immer zu "sehen".

Firmware update ist auch schon eingespielt ;).

Das war mit meiner iOptron einfacher.
Rein in ihr Netzwerk, Webinterface aufgerufen, gemischten Modus eingestellt, Daten für den Router vergeben, feste IP verpasst und alles fluppte auf Anhieb.
Wie gesagt, wenn ich raus auf den Acker geh Tablet auf das Netzwerk der iOptron verbinden, heimisches WLAN ist ja nicht vorhanden, und ab geht die Post.
Zurück zu Hause brauch ich gar nichts zu tun, da ist die Montierung sofort im WLAN zu erreichen.

Da bastel ich auch nicht mehr weiter dran rum. Wenn es mit dem Kabel funktioniert ist gut.
 
Wenn die SSID in deinem Access-Point für 2,4GHz und 5GHz gleich benannt bleiben soll, ist das auch ok. Um deinen Astroberry-Client dennoch in einen bestimmten Modus zu zwingen, prüfe doch mal ob du in den Einstellungen (nm-connection-editor) die BSSID eintragen kannst. Denn typischerweise hat ein Access-Point für jedes Interface eine einmalige BSSID, also eine konkrete Möglichkeit der Unterscheidung von dem 2,4GHz und dem 5GHz Interface. Andere Wege können sein, dass du das Modul für deinen Wifi-Adapter in einen Modus per Parameter zwingst.
Was ist deine Ausgabe bei
Code:
grep ^REGDOMAIN /etc/default/crda
?

So, die Ausgabe von "grep ^REGDOMAIN /etc/default/crda" ist "REGDOMAIN=" , also nichts zu sehen.
Meine beiden SSID für 2,4 und 5 sind in der Tat identisch.

Ich habe die MAC Adresse aus der FritzBox ausgelesen und als BSSID in der Astroberry Konfiguration eingetragen.
Ich hatte zunächst fälschlicherweise die MAC der 5GHz dort eingetragen, Ergebnis war, keine Verbindung zum Heimnetz, aber Aktivierung als 5GHz Access point (sow wie ich es eingetragen habe).

Dann die 2,4GHz MAC eingetragen und trotzdem hat er sich nach dem booten wieder ins 5Ghz Heimnetz eingeloggt.
Dannn noch mal zusätzlich bei "Gerät" die vorgegebene MAC Adresse wlan0 des RPi ausgewählt:44:4E:xx:xx:xx:xx
Leider wieder erfolglos. Er will ins 5GHz Netz... :confused:
 

Anhänge

  • Funknetz-mod.jpg
    Funknetz-mod.jpg
    29,4 KB · Aufrufe: 14

mbba18

Mitglied
So, jetzt hab ich doch noch mal etwas rumgespielt :LOL:.

Was lustig ist, den Gastzugang meines Routers, also SSID und Passwort wird klaglos vom SW WiFi-Adapter angenommen :rolleyes:, landet also dort im Netzwerk.
Also funktioniert das Teil anscheinend ordnungsgemäß.
Das ganze veranlasst mich jetzt zu der Vermutung, dass entweder die SSID meines WLANs zu lang ist oder das Passwort, da beides im Gastnetzwerk kürzer ist.
Eine andere Möglichkeit wäre noch, das das Teil nicht mit Sonderzeichen oder Leerzeichen umgehen kann.

Wäre schon traurig, dass der SW WiFi Adapter nicht damit umgehen kann, besonders bei dem Preis :cry:.
 

Wintergatan

Mitglied
SW WiFi Adapter nicht damit umgehen kann, besonders bei dem Preis
Hat dein AP zufällig Optionen wie PMKID oder PMF auf spezielle Weise gesetzt? Manche Treiber bei Clients können nicht damit umgehen wenn die PMKID deaktiviert wird. PMF (Protected Management Frames) und WPA3 sind zwar standardisiert, aber das heißt ja nicht dass der Treiber im Client sauber darauf hin programmiert ist.
Wenn Die Länge von SSID und/oder Passwort der Grund sind, dann wäre das ein harter Schnitzer!

Dann bitte ein REGDOMAIN=DE daraus machen und rebooten.
Code:
iw reg get
Die Bundesnetzagenturen der verschiedenen Länder geben vor auf welchen Kanälen mit welcher Stärke gefunkt werden darf. Idealerweise halten sich Client und AP an die gleichen regionalen Vorgaben.
 
Zuletzt bearbeitet:
Dann bitte ein REGDOMAIN=DE daraus machen und rebooten.
Code:
iw reg get
Die Bundesnetzagenturen der verschiedenen Länder geben vor auf welchen Kanälen mit welcher Stärke gefunkt werden darf. Idealerweise halten sich Client und AP an die gleichen regionalen Vorgaben.
Hatte ich eigentlich über die raspi-config auf DE gesetzt.

Habs nun manuell /etc/default/crda eingetragen und ausgelesen "REGDOMAIN=DE" ist nun aktiv.... aber bringt immer noch nichts.
Inzwischen habe den RPi ein wenig woanders positioniert und er hat sich direkt mit einem Wechsel von WiFi4 nach 5 bedankt und die Übertragungsrate hochgesetzt.

Falls Du noch eine Idee hast, immer gerne.


Wenns nicht klappt, gibts 3 Scenarien für mich:
- testen, wie die Verbindung draussen auf der Terrasse ist und hoffen, dass 5GHz stabil genug bleibt
- über Eth verbinden, nochn :cautious: Kabel...
- Astroberry als Hotspot :cautious::( ohne Heimnetzzugang
 

Wintergatan

Mitglied
Falls Du noch eine Idee hast, immer gerne.
Die Luft wird dünn. Bluetooth und 2,4GHz sind nicht zu 100% beste Freunde. Vor allem wenn der WiFi-Chip integriert oder nahe am BT-Chip ist. Mit
Code:
rfkill
BT darauf prüfen dass es deaktiviert ist wäre mein vorerst letzer Schritt. Habe selber keinen PI, aber ist das Modul brcmfmac für WiFi zuständig? Guck nach ob es Parameter dafür gibt um einen Modus zu erzwingen. Stromsparmodi für die Chips aktiviert?
 

mbba18

Mitglied
Nein... alles viel einfacher... und meine eigene Duseligkeit o_O.

Wer tagelang seine SSID nicht korrekt eingeben kann :eek:, dem gehörts nicht anders, als das er tagelang Fehler suchen muss.

Oh, man wie blöd kann man sein :rolleyes:.

Jetzt funktioniert alles.
 

Wintergatan

Mitglied
Wer tagelang seine SSID nicht korrekt eingeben kann :eek:, dem gehörts nicht anders, als das er tagelang Fehler suchen muss.
Aber gut dass du es gefunden hast :) Mein persönlicher Favorit sind unsichtbare Steuerzeichen die sich bei copy&paste einschleichen.
Als ich in Astro-Fotografie hineinschnuppern wollte, hatte ich erst nach zwei Nächten herausgefunden dass ein Herd mit Ceran-Feld die Ursache für "Blaue Pixel" und Geflacker in meinen Aufnahmen war (IR-Spektrum Spiegelung im Fenster).
 
@Wintergatan
Kann ich noch probieren, aber das sollte schon funktionieren, sonst hätten die x Tausend / Millionen RPi4 User schon gemeckert... ;)

Parallel habe ich aber geschafft, EKOS/K-STARS den Meridian Flip wieder beizubringen. Der hatte sich heute mal sowas von verabschiedet mit merkwürdigen Meldungen...

@mbba18
...also voller Erfolg! Sowas braucht man zwischendurch....
 

mbba18

Mitglied
Das Auffinden von solchen Fehlern kenne ich von früher.
bash-scripte geschrieben und die wollten partout nicht so laufen wie ich es wollte.
Kleines "l" statt großem "I", Bindestrich statt Unterstrich... ... ...
Auf so was suchst Du Dich blöde. Man überliest das immer und immer wieder.
copy&paste kann einen manchmal schon in den Wahnsinn treiben.

Hier hab ich zwei Buchstaben groß geschrieben anstatt klein, sollte eigentlich sofort auffallen :oops:.
 

steins-ursel

Mitglied
Die Luft wird dünn. Bluetooth und 2,4GHz sind nicht zu 100% beste Freunde. Vor allem wenn der WiFi-Chip integriert oder nahe am BT-Chip ist. Mit
Code:
rfkill
BT darauf prüfen dass es deaktiviert ist wäre mein vorerst letzer Schritt. Habe selber keinen PI, aber ist das Modul brcmfmac für WiFi zuständig? Guck nach ob es Parameter dafür gibt um einen Modus zu erzwingen. Stromsparmodi für die Chips aktiviert?
Hallo Wintergatan,
Bluetooth und 5GHz WLAN geht beides gleichzeitig. Da aber die Antenne vom Raspi nur eine "Notlösung" ist, ist eine wirkliche Durchdringung von Mauern nicht das Wahre. Hier hilft nur eine Nachrüstung einer angepassten externen Antenne, um die Reichweite zu vergrößern. Ein Repeater erhöht die Latenz, da kommt es auf einen Versuch an.
2,4GHz und Bluetooth geht definitiv nicht zusammen
 
Zuletzt bearbeitet:
Interessante Diskussion in dem Link, bin also nicht der erste... und ja, Band Steering in der FB war autokonfiguriert :LOL:

Damit müßte ja der Pi eigentlich vom 5Ghz ins 2.4GHz Netz wechseln, wenn die Übertragungswerte zu schlecht sind.
Möglichereise hatte er das ursprünglich auch gemacht, als der noch bei mir in der schlechten Location lag (-83dBm), aber durch die plötzliche Verschlechterung (ich bin durch die LOS (Line of sight) in der Wohnung gewandert und hab den RPi quasi abgedeckt), muß es zum kurzzeitigen Ausfall gekommen sein und die Umschaltung hat nicht schnell genug gewirkt. Mußte mich wieder einloggen.

Jetzt am neuen Standort, nicht viel weiter weg ist der RX Pegel bei -63dBm. Hab keine Abbrüche mehr. Nur ist das nicht der später Beobachtung-/EInsatzort.
Weitere Lösung wäre dann auch noch die Umstellung auf 2 separate SSID. Davon wären nur meine kommerziellen Geräte mit 5GHz Option (Notebooks, IPads, SMartphones,... sowie der einzige RPi4) betroffen, nicht aber meine (nur 2.4GHz) Bastelrechner (WEMOS, alte RPi´s,...). Bei denen ist der Umstellungsaufwand viel zu groß.

Schaun mehr mal... auf jeden Fall viel gelernt! Danke nochmals!

CS und Grüße
Hartmut
 

tomltom

Mitglied
Damit läßt sich meine EQ6 jetzt über INDI, EKOS, K-STARS, SkySafari, HandController sowie über WIN10 ASCOM steuern.
Hallo, darf ich da mal kurz fragen ?
Die EQ6 wird mit Win 10 ASCOM gesteuert, aber diese ist dann sicherlich direkt am Windows PC angeschlossen?
Oder gibt es eine Möglichkeit mit ASCOM die am Raspberry angeschlossene Hardware anzusprechen?

Grüße
Tom
 

mbba18

Mitglied
Hallo Tom,

bei mir wird die EQ-6 R über den SkyWatcher WiFi-Adapter über (heimische) WLANnetz vom Raspberry 4B (Pi4B) aus angesprochen. Das ganze über INDI.
Der Pi4B wird per VNC von meinem Notebook aus "ferngesteuert", ebenfalls über WLAN.
So gesehen ist die EQ-6 R direkt am Pi4B angeschlossen. Das ganze geht auch mit einem passenden Kabel.
Bei der neuen EQ-6 R mit USB geht es direkt über USB, soweit ich weiß.

Den Pi4B kannst Du auch per Tablet oder SmyrtPhone (bissi popeliges Display dafür) mit passender Software steuern.

Das ganze mit dem Pi4B hat halt den Vorteil das Du kein Notebook mit rausschleppen musst und somit auch nicht der ganze Umstand mit dem Kabelgedönse.
Den Pi4B befestigst Du mittels Klettband am Tubus oder an der Montierung.
Die einzige kabelgebundene Verbindung dich ich jetzt noch habe ist meine Asi224. Aber der Weg Kamera / Pi ist wesentlich kürzer als zu einem Notebook.
Der Pi bewegt sich mit der Montierung oder dem Tubus mit und somit treten keine Kabelspannungen auf.
Das gleiche würde für Kabelverbindung Montierung / Pi gelten.

Auch habe ich den Vorteil, wenn es mir zuuuu kalt auf meinem Balkon ist, kann ich bequem vom Sessel aus alles steuern.
 
Oben