Projekt Raspberry 4 B gestartet | Seite 5 | Astronomie.de - Der Treffpunkt für Astronomie

Projekt Raspberry 4 B gestartet

mbba18

Mitglied
Hallo zusammen,

so der erste Feldversuch, oder besser, Balkonversuch ist vollbracht.
Abgesehen davon das es sch****kalt ist, -13,2° :eek:,
scheine ich das gleiche Problem zu haben wie hier schon erwähnt wurde:
die WLAN-Verbindung ist grottenschlecht.
Da muss ich wohl auch den Pi auf 2,4GHz zwingen.
 

steins-ursel

Mitglied
Hallo Mathias,
ich hoffe der wird auch unterstützt. Die Hardwareunterstützung ist ja nicht zu vergleichen mit dem "großen Linux" auf einem x86 System.
 
Da sich hier ja einige Linux Experten rumtreiben ;), stelle ich hier mal eine Frage dazu ein.

Ich betreibe einen RPi4 mit Astroberry. Immer wenn ich in meinem Desktop PC Browser die GUI des Astroberry aufrufe, bekomme ich die unten gezeigten "Mausspuren" zu sehen. mal sind mehr, mal weniger. Ist nur ein Schönheitsfehler, aber wie kann ich die vermeiden? Ich habe schon mit den Einstellungen der Maus im RPi rumgespielt, aber da ändert sich nichts. Auch wenn ich das zurzeit laufende Fenster von KStars schliesse, bleiben die Spuren auf dem Desktop Screen stehen. Schliesse ich mein lokales Browser-Fenster, sind sie weg, bis ich wieder den Browser öffne. Die Spuren sind also auf dem RPi GUI Desktop.

CS
Hartmut
 

Anhänge

  • Mausspuren.jpg
    Mausspuren.jpg
    116,1 KB · Aufrufe: 34

Wintergatan

Mitglied
Das Tool
Code:
unclutter
kannst du auf dem RPi4 starten; es macht den Mauszeiger unsichtbar. Ansonsten liegt es wohl daran dass es bei VNC absolute und relative Zeigerpositionen gibt. Halt Ausschaue nach Optionen im VNC-Client wie "show remote cursor" oder ähnliches.
 
So, besten Dank! "Unclutter" wollte sich aber nicht installieren lassen. Unclutter will wohl die Zeit auf "0" setzen und bekommt bei mir den gpsd Service nicht angehalten. Daraufhin gibts dann einen Fehlercode.
Da ich GPSD bzw. meinen GPS RX mit Mühe ans laufen gebarcht habe, wollte ich da jetzt nicht zu tief rumfummeln und Prozesse stoppen, etc.
Aber Dein Typ mit Unclutter hat mich auf diesen Post gebracht: How to permanently hide mouse pointer or cursor on Raspberry PI?

Ich hab nun die Lösung neben Punkt 14 eingebracht.

14 I simply added a nocursor option as follows in the file (/etc/lightdm/lightdm.conf)
xserver-command = X -nocursor


Zumindest nach dem ersten ReBoot des Pi hat es funktioniert :D
Hoffe, das ist von Dauer, sonst muß ich mich doch intensiver mit dem Unclutter beschäftigen.:cool:
 

mbba18

Mitglied
Hallo und guten Abend zusammen,

mal ein kurzes Update von mir.

Mein Pi läuft jetzt auf Astroberry und wird über VNC bedient.
Das WLAN-Problem ist etwas besser geworden durch einen passenden USB-WLAN-Stick mit Stabantenne.
Besser als mit dem integrierten Chip des Pi, aber immer noch nicht so wie ich es gern hätte.
Das Problem sind wohl die baulichen Bedingungen meiner Wohnung.
Allein das telefonieren mit dem SmartPhone ist schon ein Abenteuer.
Evtl. hilft ein Repeater, mal sehen.

Heute mit meiner iOptron, 120/1000 FH, Asi224, Pi 4B und Powerbank für den Pi alles auf dem Balkon aufgebaut.
Nach der Initalisierungroutine der iOptron nur noch mittels KStars und/oder Stellarium die Montierung gesteuert.
Funktioniert gut.

Dann mit FireCapture auf M42 gehalten.
Hier mal ein Bild:
DSO_203149_0000.jpg

An der Qualität lässt sich sicherlich noch schrauben.
Aber für den ersten Versuch ist das schon mal was.
Ich glaub auch, dass es was bringt, wenn ich ohne Zenitspiegel die Asi224 direkt an den OAZ adaptiere.
Was etwas "lästig" ist, das ich für das Fokussieren der Asi immer wieder raus muss. Fehlt halt noch der Motor-Fokussierer. Aber mei, man kann nicht alles auf einmal haben ;).

Zu der Powerbank kann ich sagen das sie nach 3,5 Stunden noch 50% Füllung angezeigt hat. Find ich schon mal recht gut. OK, die Temperaturen sind im Moment auch moderater als in den letzten Tagen. Da war bei -13° schon nach 2 Stunden der Akku fast leer.

Was mir ein bisschen sorge macht, wie verhält sich der Pi bei Feuchtigkeit. Kann das teil ja nicht in eine Plastiktüte packen ;).

Nach dem heutigen Abend bin ich recht zufrieden wie es gelaufen ist.
Das Grundsätzliche funktioniert. Jetzt geht es an den Feinschliff.
 

mbba18

Mitglied
Hallo nochmal,

als Nachtrag, wenn man sich überlegt so ein System aufzubasteln sollte man sich dazu überlegen ob man nicht direkt auf den Pi mit 8GB geht.
Der 4GB zappelt doch schon mal etwas rum und kommt nicht so schnell in die Pötte ;).
Hat nichts mit dem WLAN zu tun, das funktioniert ja in der Wohnung reibungslos.
Mein subjektives Empfinden.
 
Moin,

danke für das erste Bild und Deine Eindrücke!
Bezüglich des WLAN kann ich nur sagen, dass der RPi bei mir seit der Festlegung auf 2.4GHz wie eine LAN-Verbindung steht. Auch über Stunden kein abreißen der Verbindung mehr. Kann ich Dir nur empfehlen, falls Dein Router das hergibt (BSSID & abschalten Band-steering).
Zu 4GB vs. 8GB kann ich nichts sagen. Meiner hat 4GB, aber ich hab auch keine praktische Erfahrung mit meinen beiden ASI120. Sie laufen nur im Testbetrieb.

Was für eine Power-Bank hast Du angeschlossen bzw. wie viele Ah soll der Akku den hergeben?

Zurzeit habe ich nur einen 22,8Ah Akku dran. Da hält die Montierung ein paar Stunden bei 20°C.
Leider scheint aber der RPi ein richtiger Stromfresser zu sein. Ich habe den über einen USB 3 Hub laufen, der an einem 3A Netzteil hängt. Den Ladesaugang des Hub habe ich an den USB-C Eingang des RPi gelegt. Der Ladeausgang bringt aber nur max. 2,4A. Lasse ich den Astroberry mit KStars laufen incl. Tracking, dann bricht ab und zu alle paar Minuten die Spannung unter das erlaubte Niveau (rote LED geht für 1-2sec aus). Einfluß auf die Funktion hat das nicht, es setzt aber das throttling (CPU Takt Drosselung) für diesen Zeitraum ein. Ich werde den RPi wieder direkt an den Akku anschliessen. Er brauch wohl entweder in den Spitzen wirklich die 3A oder aber das Netzteil des Hubs schafft die 5,1V nicht, die der RPi eigentlich sehen will. (Das haben die echt geschickt gemacht mit ihren 5,1V, damit sie auch ihre Netzteile vermarkten können... :devilish:)

Der Hub bleibt aber dran. Da hängt der Fokusser und eine ASI120 dran, da ich insgesamt zurzeit min. 5 USB Ausgänge brauche.

Gestern habe ich mich übrigens leider so dermassen verkonfigiert, dass der "Meridian Flip" nur noch Mist gebaut hat. Auch zurücksetzen auf Werkseinstellung des HC als auch das konfigurieren der Config-Files direkt hat nichts gebracht. Zum Glück mache ich regelmäßig BackUps der SD Karte. Jetzt läuft es wieder.
Aber jetzt muß ich erst mal auf eine größere SD umsteigen wg. der gigantischen Index FIles für die Offline Astrometry. Da reicht die 32GB Karte nicht, geschweige den, wenn ich Aufnahmen direkt auf die SD machen will..

Ach ja, wg. der Feuchtigkeit und dem RPi brauchst Du Dir keine Sorgen machen. Ich betreibe eine kleine Wetterstation mit einer ESP32 MCU seit 1,5 Jahren im 24/7 Betrieb ohne abgedichtetes Gehäuse, also nur Schutz gegen direkten Regen, bei 100% Luftfeuchte völlig problemlos. Da man ja den RPi nach ein paar Stunden Betrieb (CPU Temperatur ca. 63°C bei 20°C Umgebung heizt seine direkte Umgebung) wieder in die Wohnung nimmt, sollte das kein Problem sein. Ich würde ihn nur nicht draussen lassen, da die (nicht gelöteteten) Steckverbindungen (USB, GPIO) im laufe der Zeit korrodieren könnten.

CS Hartmut
 

Neuge

Mitglied
Hallo Matthias,

der 8Gb lohnt sich eigentlich nur , wenn man Videos am Planeten macht.
Hier ist viel Speicher deshalb sinnvoll, da der Ram schneller als andere Datenträger beschrieben werden kann.
Ich habe dazu ein paar Versuche mit Firecapture gemacht. Das läuft mit Ram Puffer am 8 GB am stabilsten und man kann auch so höhere Frameraten erreichen.
Ich will die Tage mal mit dem Jetson Nano und der 12Mpix Kamera im Videomodus experimentieren. Leider schafft der Raspberry bei voller Auflösung nur 2 Bilder die Sekunde. Problem ist hier die gleichzeitige Darstellung des Bildes. Hatte verschiedene Programme getestet, aber so richtig zufrieden bin ich nicht. Gerade versuche ich mit PiCamera App zu experimentieren. Hier komme ich bei voller Auflösung auf ca 20 fps. Das Vorschaubild wird hier als Overlay direkt von der GPU erzeugt. Das belastet die CPU also weniger und es wird schneller dargestellt. Nachteil, man sieht es nicht im VNC, nur über HDMI. Geht also nur direkt am Teleskop mit Monitor oder kleinem Display. Wenn das 5,5 " OLED da ist, teste ich mal, wie das in der Praxis geht. Im Grunde benötigt man das ja nur, als Vorschaumonitor zum Scharfstellen. Der Jetson Nano sollte das aber schaffen da er eine richtige Grafik CPU besitzt. Leider werden wir mit der 12Mpix Kamera nie mehr als 15-20 fps schaffen, da der CSI Bus nur 2 Lanes hat. 3 Wären nötig um 30 fps bei 12Mpix zu schaffen. Allerdings stellt sich die Frage nach der Sinnhaftigkeit. Man muss die Datenmenge ja auch irgendwie speichern können. Der kleine Chip kann aber echt gut ausgeleuchtet werden, sodass man am Planeten dann viel mehr Auflösung erreichen könnte.
Mir schwebt hier ein kompakte kleine Kiste vor, an die man nur die Kamera ansteckt. Alles andere soll in einem Gehäuse untergebracht sein. Das da wären GPS, Akku, Raspberry, Display und diverse Schnittstellen. Vielleicht auch noch Stromversorgung für Heizung und/oder Motorfokus. Na mal sehen. Versand dauert ja gerade wieder ein paar Tage länger.

Tino

Nachtrag: Ich habe meinen Raspberry Pi4 übertaktet. 2Ghz schafft er ohne Probleme und die GPU kann auch 650 oder gar 700 MHz. Er wird dadurch aber auch hungriger.
 
@Neuge
Was sagt den die CPU Temperatur bei der Übertaktung?
Ich habe zurzeit keinen Kühlkörper drauf. Den 30mm Lüfter habe ich nach 5min Betrieb wieder rausgeworfen wegen des kreischenden Lärms. Ist schon mein dritter Lüfter (25mm ist Schrott und 2 x 30mm sind ebensonicht zu gebrauchen.
Auf einem RPi4 2GB, den ich zur Überwachung meiner 3D Drucker einsetze, habe ich einen 40mm Lüfter auf das Gehäuse von aussen aufgeschraubt. Der ist auch laut, macht aber nicht so kreischende Geräusche...
 

Wintergatan

Mitglied
man sieht es nicht im VNC, nur über HDMI. Geht also nur direkt am Teleskop mit Monitor oder kleinem Display.
Habe mir dafür einen kleinen USB/HDMI-Capture-Stick gekauft. Preis ca. 16€ Beschreibung "DIGITNOW! Videoaufnahmekarte, HD Video und Audio Capture Card HDMI zu USB 2.0 1080P".
So kann man auch schlicht sein Notebook nehmen oder mit Adapter auch an einem Smartphone den Output des HDMI direkt betrachten, inklusive der auf der GPU gerenderten Inhalte.
 

Neuge

Mitglied
Also die Temperatur ist natürlich ohne Lüfter ein Problem. Entweder man nimmt gleich ein Aluminiumgehäuse, oder man verbaut einen Lüfter.
Dieser muss ja auch nicht immer laufen und kann über die eingebaute Steuerung bei Temperaturen über 60°C eingeschaltet werden.
Ich habe zum Test im Moment noch den kleinen Lüfter vom PoE Hat in Nutzung. Dieser reicht aus und ist nicht so schrecklich laut. HAbe mir an meinen Balkon eine LAN Buchse geschraubt. Da versorge ich alles über 1 Kabel mit Strom per PoE.
Final soll das aber ohne Lüfter auskommen, da werde ich etwas mit Aluminium bauen müssen.

Das mit dem HDMI Grabber ist keine schlechte Idee. Schöner wäre es aber ohne Kabel. Ich möchte den Raspberry ja vom Tablet oder PC aus bedienen per VNC.

Ich möchte auf jeden Fall keine Sonderlösungen basteln. Es soll für alle einfach nachzubauen sein. Da sind Spezialanfertigungen immer problematisch.
Am Besten ist, man baut alles aus Standardkomponenten zusammen, die jeder im Netz kaufen kann.

Tino
 
So, dann doch noch einen 40mm Lüfter im Keller aufgetrieben, der erträgliche Musik macht. Einen Kühlkörper habe ich n.n. verbaut.
Dann noch moderat von 1,5GHz auf 1,75Ghz übertaktet (Umgebungstemperatur 20°C) und CPU Temperatur liegt nun bei max 39°C (vormals ohne Übertaktung bei 63°C). Erst mal beobachten, wie stabil das ganze läuft, aber 2GHz müßten eigentlich auch drin sein...
 

Anhänge

  • IMG_20210218_175615.jpg
    IMG_20210218_175615.jpg
    195,7 KB · Aufrufe: 25

Wintergatan

Mitglied
Übrigens, ich hatte mal ein defektes Netzteil welches mein WLAN gestört hat. Dauerte eine Weile dieses als Ursache zu ermitteln (abgeschirmt mit Alu-Folie), um es dann aber zeitnah auszutauschen. Ich hoffe ihr findet eine Lösung für euer Netzwerk.
 

mbba18

Mitglied
Hallo in die Runde,

hatte ich hier erwähnt ;):
ob ich für die meine, Goobay 59821 10000mAh, (schon) eine Empfehlung aussprechen kann, weiß ich noch nicht.
Habe mich halt auf mehreren Pi-Webseiten umgetan und mich dann für diese entschieden.
Die Praxis wirds weisen.
Für meine iOptron brauche ich keine externe Stromversorgung und das wird auch die Hauptmontierung für das ganze System.
Die hat einen (austauschbaren) verbauten Akku.
Somit bin ich nicht auf eine große Powerbank angewiesen.
Außer bei der EQ-6 R. Da ich die aber nicht mehr rumschleppe, ist das auf dem Balkon egal, da gibt es eine Steckdose ;). Netzteil dran und gut ist.
 
Zuletzt bearbeitet:

steins-ursel

Mitglied
Zu der Powerbank kann ich sagen das sie nach 3,5 Stunden noch 50% Füllung angezeigt hat. Find ich schon mal recht gut. OK, die Temperaturen sind im Moment auch moderater als in den letzten Tagen. Da war bei -13° schon nach 2 Stunden der Akku fast leer.
Was für eine Power-Bank hast Du angeschlossen bzw. wie viele Ah soll der Akku den hergeben?
Da ich nicht am Haus beobachten kann schliesse ich mich an @elythomaslumber an
Hallo!
Der Raspi zieht ca. 3-4W, KSTARS, EKOS und Nachführung laufen. Damit er 10h durchhält, müssen mind. 40Wh vorgehalten werden, bei 12V sind das mind. 3,4Ah, bei einer Powerbank mind. 11Ah. Es ist hier sinnvoll von Energiemengen (Wh) zu sprechen, da die Ah sich immer auf die Abgabespannung beziehen, die Angaben der Hersteller auf den Powerbanken sind markentingtechnisch optimiert!
Für ein komplettes Equipment für eine Nacht sollte man mind. 200Wh vorhalten. (Montierung, Kameras, Heizbänder, Focuser ....)
Mein Equipment (EQ6r-Pro, ASI 2600+ASI290, Raspi 4 mit WLAN und BT, EAF, ein Heizband bei ca. 30%) hält mit 256Wh (4xLiFePo4 â20Ah) ca. 10h durch.
Bleibatterien sind entsprechend noch größer zu dimensionieren, da bei kalten Temperaturen die Kapazität schnell gegen 50% geht.
 
OK, zurzeit nutze ich diese hier zusammen mit einer Dobson PUSH+: Akku Das schöne daran sind die vielen Ausgänge bzw. Varianten.
An der EQ6-R Pro hält sie ein paar Stunden, mache aber zurzeit keine Astrofotografie. Ich muß mal den Raspi nachmessen. Der Fokusser braucht so gut wie nix im Vergleich zur Montierung.
Denke aber, da ist später was größeres notwendig.
Hab das Ding noch für 69,-€ gekauft. Negativ ist nur, dass bei einer Stromabgabe unter ca. 200mA abgeschaltet wird. Mit einer EQ6-R ist das kein Thema, wohl aber an der PUSH+. Deshalb hab ich da immer noch das Smartphone als Steuerung mit angeschlossen und ein bisschen Beleuchtung.

CS
Hartmut
 

noideaforaname

Mitglied
Bezüglich der LED's!

Folgendes in die /boot/config.txt eintragen:

[pi4]
# Disable the PWR LED
dtparam=pwr_led_trigger=none
dtparam=pwr_led_activelow=off
# Disable the Activity LED
dtparam=act_led_trigger=none
dtparam=act_led_activelow=off
# Disable ethernet port LEDs
dtparam=eth_led0=4
dtparam=eth_led1=4

Dann sind die LED's nur kurz beim Einschalten an und direkt aus.

Funktioniert so beim 4er, 3er müsste ich nochmals nachschauen.

CS

Ralph
 

BarFly

Mitglied
Hallo,

OK, zurzeit nutze ich diese hier zusammen mit einer Dobson PUSH+: Akku Das schöne daran sind die vielen Ausgänge bzw. Varianten.
An der EQ6-R Pro hält sie ein paar Stunden, mache aber zurzeit keine Astrofotografie. Ich muß mal den Raspi nachmessen. Der Fokusser braucht so gut wie nix im Vergleich zur Montierung.
Denke aber, da ist später was größeres notwendig.
Hab das Ding noch für 69,-€ gekauft. Negativ ist nur, dass bei einer Stromabgabe unter ca. 200mA abgeschaltet wird. Mit einer EQ6-R ist das kein Thema, wohl aber an der PUSH+. Deshalb hab ich da immer noch das Smartphone als Steuerung mit angeschlossen und ein bisschen Beleuchtung.
CS
Hartmut

Sieht aus, wie wenn das Teil einige Stromprobleme lösen kann.
Danke für den Tipp.
 

Neuge

Mitglied
Kennt jemand von euch eine Software die auf dem Steellarmate Image läuft und Videos aufnehmen kann?
Mal abgesehen von Firecapture habe ich noch nichts zu Laufen gebracht.
Auf dem Astroberry Image habe ich immer oacapture benutzt. Wichtig wäre, dass die RPI HQ Kamera damit läuft. Müsste also V4L2 fähig sein.

Tino
 

Neuge

Mitglied
Leider arbeitet AstroDMx auf dem Stellarmate Image nicht mit der RPi Cam zusammen.
Dann werde ich wohl 2 Images machen und auf verschiedene USB Sticks packen. Eines für Fotos und eines für Videos, bis es eine bessere Lösung gibt.

Diese Boards gibt es scheinbar nicht in D zu kaufen. Das muss man alles importieren. Ich glaube aber auch nicht dass man da 10 fps per USB übertragen kann.

Tino
 
Oben