TeenAstro ein onStep projekt | Seite 14 | Astronomie.de - Der Treffpunkt für Astronomie

TeenAstro ein onStep projekt

miesel

Mitglied
Hallo Chales,

ich danke Dir.
Ich bin fasziniert was dieses "kleine" Selbstbauprojekt zu leisten vermag.
Ich konnte in den letzten 14 Tagen ohne viel zu sagen zwei weitere Astrokumpels für das Projekt begeistern.
Du machst das großartig.
Ich bin gespannt welche Funktionen in Zukunft noch den Weg in die TeenAstro finden.

Viele Grüße
Ralf
 
Hallo TeenAstro Gemeinde,
ich habe da ein kleines Problem. Habe eine TeenAstro V2.3.1 (Bj. 03.2019) und wollte eine neuere Version aufsetzen. Anscheinend gehöre ich zu den DAU´s und komme nun nicht mehr weiter.
Nach dem Upload und erneutem einschalten kam ganz normal das " TeenAstro Bild " dann " SHC Version 1.2.b " und nach etwa 2 sek. " !! Error !! Not Connected " . Weitere Versuche mit anderen Versionen ändern am Zustand nichts. Habe ich etwas zerschossn oder muss ich etwas rebooten?
Vielen Dank für die Erste-Hilfe-Leistung!
Schönen Gruß
Wolfi
 
Noch eine kleine Ergänzung.
Ich habe es versucht den Wemos ESP8266-Mikrocontroller neu zu laden.
Die kleine blaue LED auf dem Wemos-Mikrocontroller (SHC) blinkt sehr unregelmäßig und bleibt auch mal länger aus. Es wird auch kein ComPort angezeigt.
Grüße
Wolfi
 

miesel

Mitglied
Hallo Wolfi,

so ein ähnliches Problem hatte ich auch mal.
Bei mir hat es geholfen den gesamten EEPROM mit "FF" zu überschreiben und anschließend neu zu flashen.
Google mal nach "ESP8266/85 Flash-Speicher Löschen".
Bei mir hat es zumindest geholfen.

Gruß
Ralf
 

Charles

Mitglied
Hast du beide mit dem Beta version installiert?
Wenn du das Logo sieht dann ist alles noch ok, nur die Versionen passen nicht zusamen
 
Hallo,
es war dann kein Logo mehr im HC zu sehen. Ich habe den Wemos erneuert, installiert und die Vebindung war wieder da.
Aber der DEC TOS-100 wurde nun nicht mehr angeseuert. Der Stepper gab nur ein kurzes leises Knattern von sich.
TEENSY 3.2 ausgewechselt. Jetzt passt wieder alles.
 

Charles

Mitglied
Am besten die Montierung Parameter mit Jürgen Golden tool exportieren, dann neu Firmware spielen, dann reset to Factory dann mit Jürgen tool die Parameter laden.
Wenn etwas nicht funktioniert nach ein update, liegt es sehr oft an einen korrupt EEPROM, dass reset to factory hilft sehr.
 

Coyote

Mitglied
Hallo Leute
Habe ein kleines Problem beim durchtrennen der Teensy´s und sicherlich könnt Ihr mir hier schnelle Hilfe leisten da ich bei TeenAstro@groups.io auf dem Bild und der Beschreibung nicht eindeutig ersehen/erlesen konnte ob ich pro Teensy 3.2 zwei Schnitte machen muss oder nur einen? Wenn man das ganze anschaut sieht man links neben dem angelöteten D--Kabel ein größerer Lötpunkt u. weiter links 2 kleinere Lötpunkte. Auf dem Bild der Group konnte man nur sehen dass die beiden kleineren Lötpunkte durchtrennt sind aber in der Beschreibung könnte man es so auffassen das auch die Verbindung vom großen Lötpunkt zum benachbarten kl. Lötpunkt ebenfalls durchtrennt werden muss. Ist dem so oder reicht nur der eine Cut?

Als zweites wollte ich noch in Erfahrung bringen ob ich das an beiden verbauten Teensy´s durchführen muss?

Vorab schon mal vielen Dank für eure Hilfe

CS u. LG, Tom
 
Hallo Tom,
ich zitiere aus der guten Bauanleitung von Matthias Schmidt .
"Trennen der Verbindung beider Lötpads mit einem Messer. Damit wird die 5V Stromversorgung von der Micro USB-Buchse unterbrochen, da der Mikrocontroller extern versorgt wird".
und du musst es an beiden durchzuführen.
Grüße
Wolfi
 
Bei der Gelegenheit ein Gesuch!
Hallo TeenAstro Gemeinde,
hat jemand da draußen noch eine Platine für V2.3.1 und HC V0.1 übrig und (natürlich gegen harter Währung) abzugeben?
Schöne Grüße
Wolfi
 

Matthias_

Mitglied
Hallo Leute
Habe ein kleines Problem beim durchtrennen der Teensy´s und sicherlich könnt Ihr mir hier schnelle Hilfe leisten da ich bei TeenAstro@groups.io auf dem Bild und der Beschreibung nicht eindeutig ersehen/erlesen konnte ob ich pro Teensy 3.2 zwei Schnitte machen muss oder nur einen? Wenn man das ganze anschaut sieht man links neben dem angelöteten D--Kabel ein größerer Lötpunkt u. weiter links 2 kleinere Lötpunkte. Auf dem Bild der Group konnte man nur sehen dass die beiden kleineren Lötpunkte durchtrennt sind aber in der Beschreibung könnte man es so auffassen das auch die Verbindung vom großen Lötpunkt zum benachbarten kl. Lötpunkt ebenfalls durchtrennt werden muss. Ist dem so oder reicht nur der eine Cut?

Als zweites wollte ich noch in Erfahrung bringen ob ich das an beiden verbauten Teensy´s durchführen muss?

Vorab schon mal vielen Dank für eure Hilfe

CS u. LG, Tom
Es ist keine Modifikation der Teensy`s notwendig, außer das einlöten des Uhrenquarzes und auch nur für die MainUnit.
Man muss nur die D++ und D-- Kabel anlöten.
Das trennen der 5V durch einen cut war leider ein Missverständnis von mir. Es ist deshalb nicht nötig, da es bereits keine Verbindung mehr von der USB Buchse an der Hauptplatine zu dem Teensy gibt.

Grüße Matthias
 

Coyote

Mitglied
Hallo Wolfgang, hallo Matthias

Vielen lieben Dank für die schnelle und kompetente Hilfe. Ich sehe das ich den Hinweis von Matthias in der Doku mit zwei Cut´s richtig verstanden habe. Da Matthias dies nun im letzten Post korrigiert hat werde ich keine Trennungen durchführen u. die Teensy´s so belassen wie sie sind.

Habe bei der Gelegenheit eine weitere Frage an die Gemeinde!
Da ich für einen Vereinskameraden ebenfalls die Steuerung löte habe ich mir einen weiteren TMC2130 v. Wattenrott bestellt. Auf der Homepage war das Teil als Bild dargestellt und hat genau so ausgesehen wie das was ich kurz zuvor für mich gekauft hatte und auch Charles propagierte. Allerdings war in der Beschreibung von einer Version 2 (V2) die rede. Nachdem ich nun das neue Teil bekam habe ich gesehen das die Widerstandskombi über dem Drehpoti nicht mehr vorhanden ist und ich nun verunsichert bin ob der TMC2130 für die Schaltung noch geeignet ist oder ich versuchen muss die ältere Version irgendwo aufzutreiben. Ich habe mal ein Bild eingestellt um es zu verdeutlichen.

TMC2130.jpg


Ich hoffe Ihr könnt mir dazu etwas sagen. Klar, ich kann ihn jetzt auch erst einmal einbauen und Power darauf geben aber ich möchte ihn nicht gleich grillen wenn ich falsch agiert habe. ;)

CS, Tom
 

Coyote

Mitglied
Hi Leute
Habt ihr auch das Problem das mit den Tasten von Reichelt das Handgehäuse mit dem großen Display nicht mehr zu geht? Ich probiere jetzt schon den ganzen Tag und kürze bzw. verlege meine Leitungen in die letzten Winkel krieg das Ding aber nicht zu.
 

Coyote

Mitglied
Hallo Henri
Alles gut, ich musste die Leitungen einzel zwischen den Taster verlegen/verstecken damit keine Leitungen zwischen Lötpunkte und Gehäuseboden zum liegen kommen. Dann passte es endlich. Ich hatte vermutet das meine verbaute Steckerlösung zum trennen der Tastatur vom Grundgehäuse irgend wo im Weg war was sich aber dann als unproblematisch herausstellte.

Grüße u. evtl. schönen Feiertag

Tom
 

Coyote

Mitglied
Guten Morgen aus dem feiertagverwöhnten Badenerland

Habe meine TeenAstro mech. u. elek. fertig gebaut und an Spannung angeschlossen. Das Display lief sofort mit der SHC Version 1.1.5 hoch. (y) Nach dem Start wurde im Display "Error not connected" angezeigt? Was bedeutet das und wie muss ich jetzt weiter verfahren?
Drücke ich nach der dauerhaft angezeigten Errormeldung auf die Shift-Taste (li. Seite SHC) kommt die Meldung "Device will reboot" u. das System startet neu bis zur Errormeldung.

Grüße, Tom
 
Zuletzt bearbeitet:

Coyote

Mitglied
Hi All
Habe noch festgestellt das ich auch durch die Eingabe der IP-Adresse keine Verbindung aufbauen kann! Da fällt mir noch ein, braucht man zum korrekten Betrieb den Anschluss an die Motoren o. kann dieser zu Testzwecke weggelassen werden? Ich habe zur Zeit nur die nackte Steuerung zum probieren!

Tom
 
Zuletzt bearbeitet:

Henri

Mitglied
Hallo Tom, hast Du mal das Kabel vom SHC zur Steuereinheit durchgemessen?
Ist der ESP im SHC programmiert?

Ich habe gerade meine Steuerung ohne Motoren eingeschaltet. Funktioniert, ist aber noch 1.1.4

Gruß, Henri
 
Das Homepagetool mit der aktuellen Mondphase u.v.m.

(Alle Angaben für 10 Grad ö.L. Länge / 50 Grad n.B.)

In Kooperation mit www.Der-Mond.org Hole Dir jetzt das kostenlose Mondtool für Deine Homepage

Oben